1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved 2nd printer and can't get the printing right

Discussion in 'Troubleshooting' started by aznhlfan, May 19, 2017.

Thread Status:
Not open for further replies.
  1. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    You do realize that every time you flash new firmware you must do a M502 followed by an M500 or anything in EEPROM will overwrite your firmware settings every single time you restart your printer.
     
    aznhlfan and mark tomlinson like this.
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    All you likely need are spare nozzles. Not a whole hotend
     
    KTMDirtFace and aznhlfan like this.
  3. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    But Robo is sending me one free

    Sent from my Galaxy S7 using Tapatalk
     
  4. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I have done an M502 and M500 every single time. I have only changed I thing ever, that is my esteps. This all started when I calibrated the extruder and changed the esteps. Otherwise I wouldn't of flashed it at all.

    Sent from my Galaxy S7 using Tapatalk
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    Just bear in mind that the nozzles do wear out :)
    You will eventually want spares any way.
     
  6. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Yea I figured that, I will put the new one on the refurbished I just got and get new nozzles for the other one. It's just weird that one day good prints, and the next underextrusion, the refurbished one has never printed right. The firmware on it was V3 and have never found it to back to it again.

    Sent from my Galaxy S7 using Tapatalk
     
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    If extrusion is actually varying (in other words: if it is extruding different amounts when told to do a fixed amount) then that is the stepper driver for the extruder most likely. It might also be the extruder stepper, but start with the stepper driver (cheaper).
     
    aznhlfan likes this.
  8. Quest

    Quest Member

    Joined:
    Jan 7, 2015
    Messages:
    59
    Likes Received:
    9
    It could be something as easy as not feeding well due to slippage on the hobbed bolt. Might try playing with the spring pressure and making sure the teeth are not full of filament.
     
    aznhlfan likes this.
  9. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    It is not verying, it was constantly extruding fine one day, and now it is constantly under extruding. The refurbished should not have bad extruders should it (driver or otherwise). It is new to me. Is it possible that the firmware is not allowing full power to the steppers?

    Sent from my Galaxy S7 using Tapatalk
     
  10. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Tried that, and used a dental pick and canned air on the feeder teeth.

    Sent from my Galaxy S7 using Tapatalk
     
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    This is in no way a firmware issue. A refurbished unit comes in and gets some work done and then back out. There is no reason to presume that all bits of it are perfect :) It is not the extruder itself that is problematic in your case, if extrusion is varying then it has to be something in the extruder drive train -- the stepper motor, the stepper driver or the RAMPS board.
     
    aznhlfan likes this.
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    I suggested starting with the stepper driver since it is the cheapest and easiest to mess with.
     
    aznhlfan likes this.
  13. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I agree fully, I have replaced the ramps board on one of them a little less than a year ago. So would it be a safe bet to replace all the drivers just in case. I still have the original ramps that I replaced, I could use those drivers possibly.

    Sent from my Galaxy S7 using Tapatalk
     
    mark tomlinson likes this.
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    If you have spares sure, they are easy to replace so try a couple and see if you get different behavior.
     
    Geof and aznhlfan like this.
  15. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Got it, I'll try that out

    Sent from my Galaxy S7 using Tapatalk
     
  16. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    after trying what I thought was everything, I switched from Matterhackers to Cura 15.04, followed Mike Kelly's post for step by step set up. Both my Rodo's r1+ printers, print 99% better, I just need to do some tweaks as well as change the nozzles.
     
    Geof likes this.
  17. enric corbeil

    enric corbeil New Member

    Joined:
    May 3, 2017
    Messages:
    4
    Likes Received:
    0
    i am having the same problems as you, can you link me Mike kelly's post?
     
  18. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I will when I get to my PC, not sure how to do it on the phone.

    Sent from my Galaxy S7 using Tapatalk
     
  19. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,330
  20. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Thank you Geof

    Sent from my Galaxy S7 using Tapatalk
     
    Geof likes this.
Thread Status:
Not open for further replies.

Share This Page