1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

2nd Robo R1++ not printing correctly

Discussion in 'General Questions' started by aznhlfan, May 20, 2017.

  1. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    This is my first time changing the firmware, so I don't even see where to change it.the firmware 1.6.9 that I have, has both marlin.ino file and robo3dr1plusv2.ino, they both open the Arduino deal that flashes the firmware. But I have no idea which one I want and where I go to change the value of the esteps

    Sent from my Galaxy S7 using Tapatalk
     
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    1. You have Arduino IDE 1.6.9
    2. You have firmware downloaded from Robo's site, use Marlin.ino, assuming it is ROBO3DR1V3
    3. Line # 445 reads
      Code:
      #define DEFAULT_AXIS_STEPS_PER_UNIT   {80,80,2560,723.38}  // default steps per unit for RoBo 3D R1
      Change 723.38 to the number you determine from your measurements
     
    aznhlfan likes this.
  3. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Does it show the lines of code after I load it into the Arduino thing, after I flash the firmware? Right now I open the Arduino web portal to flash, and it shows no lines, just blank

    Sent from my Galaxy S7 using Tapatalk
     
  4. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I did find the default_axis_steps_per_unit but it is {80,80,800,723.38} NOT {80,80,2560,723.38} as u stated. Do I have the right one, and do I still change the 723.38 to my readings? It shows ROBOR1PLUSV2 not ROBOR1PLUSV3

    Sent from my Galaxy S7 using Tapatalk
     
    #24 aznhlfan, May 21, 2017
    Last edited: May 21, 2017
  5. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Do you have an R1 or an R1+PLUS, parameter number 3 is as follows
    1. R1 = 2560
    2. R1+PLUS = 800
    otherwise parameters 1, 2 and 4 are identical
     
    aznhlfan likes this.
  6. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I have an R1+plus, so it doesn'tatter if the printer reads be currently, but the flash I'm using is v2?

    Sent from my Galaxy S7 using Tapatalk
     
  7. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I'm sorry I'm such a noob with this and have 1000 questions.

    Sent from my Galaxy S7 using Tapatalk
     
  8. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I have 2 R1++, 1 of them I flashed the firmware for default_axis_steps_per_unit to {80,80,800,820}, the other went from v3 to v2 but the esteps does not change on the printer. I have tried several times

    Sent from my Galaxy S7 using Tapatalk
     
    #28 aznhlfan, May 21, 2017
    Last edited: May 21, 2017
  9. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    this is the error I get when trying to upload the firm ware from arduino 1.8.2 or 1.6.9
    exit status 1
    expected unqualified-id before ')' token
     
  10. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Here is the exact procedure I used. I had the 1.6.9 IDN and used it on 1 of my R1++ printers, upgraded the esteps to 820 from 732.3 with no problems. I then went to my 2nd R1++ and did the same. But for some reason on the printer the esteps stayed at 732.3. So I figured there was a problem with the 1.6.9 IDN. So I went to arduino.cc and downloaded 1.8.2 IDN, then when I went to use it I got an error. So I went back to arduino.cc and re-downloaded the 1.6.9 and uninstalled 1.8.2 and installed 1.6.9 once again. Again an error. So now I can not flash the firmware with the new esteps. I know nothing about code, so I don't know what that error is telling me, all I know is it won't let me flash the firmware.

    Sent from my Galaxy S7 using Tapatalk
     
  11. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I don't know that error either.
     
    aznhlfan likes this.
  12. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    So how do I flash the firmware now, neither 1.6.9 IDN works or 1.8.2 IDN.

    Sent from my Galaxy S7 using Tapatalk
     
  13. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Try rebooting and then loading the firmware for your second Robo then trying to flash it. Otherwise it is an Arduino error and maybe they have a forum.
     
    aznhlfan likes this.
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    Yes, pasting in the exact error so we can see it would be helpful
    Otherwise we are guessing.
     
    aznhlfan likes this.
  15. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Tried the rebooting thing, no bueno. I guess I will try the Arduino forum if they have 1.

    Sent from my Galaxy S7 using Tapatalk
     
  16. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    exit status 1
    expected unqualified-id before ')' token

    Sent from my Galaxy S7 using Tapatalk
     
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    The first error the compiler reports is the one we need to know, not the last one.
     
    aznhlfan likes this.
  18. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    That is what it showed when I went to verify the sketch or download the sketch

    Sent from my Galaxy S7 using Tapatalk
     
  19. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    here is a screenshot:
     

    Attached Files:

  20. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,657
    Likes Received:
    7,316
    If that file is the only thing open in the IDE then you did not open the project file.
    All of the source files for the project should be loaded in the IDE.
     

Share This Page