1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved Autolevel Z offset

Discussion in 'Troubleshooting' started by nol b, Apr 28, 2020.

Thread Status:
Not open for further replies.
  1. nol b

    nol b Member

    Joined:
    Mar 1, 2014
    Messages:
    61
    Likes Received:
    10
    My z offset doesn't seem to be working. I switched over to Cura (in an attempt to troubleshoot some other stuff). I am guessing that something in the G code is resetting it. Does any of this look like it would reset the specified offset?

    ;Generated with Cura_SteamEngine 15.01
    ; Default start code
    G28 ; Home extruder
    G29 Z12.5; Auto Level (Z1.9 was old offset)
    G1 Z5 F100
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    ; Activate all used extruder
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    ;Layer count: 170
    ;LAYER:0
    M107
    G0 F9000 X86.173 Y103.380 Z0.300
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,569
    Likes Received:
    7,229
    WHich printer and which firmware?
     
  3. nol b

    nol b Member

    Joined:
    Mar 1, 2014
    Messages:
    61
    Likes Received:
    10
    R1 from 2014ish I think. I have lead screw upgrade and E3Dv6. Also I've replaced the RAMPS with whatever the newest version is and I have a separate board to drive the bed heater.

    I can't find the firmware file but it was around the time that auto level was added.
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,569
    Likes Received:
    7,229
    So try this:

    G28 ; Home extruder
    M565 Z-12.5;
    G29 ;
    G1 Z5 F100
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    ; Activate all used extruder
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    ;Layer count: 170
    ;LAYER:0
    M107
    G0 F9000 X86.173 Y103.380 Z0.300


    The R1/R1+ used Marlin 1.0.x and you needed to use the M565 for the autolevelinng Z offset (and it should be a negative number).

    If that does not work start with a -1.0 and tweak up/down from there. The number you provided (12.5) seems rather extreme so perhaps you want to just start with -1.0 and go from there. More negative => further from bed and less negative => closer to bed. I have not seen an R1/R1+ need that large of an offset before. Usually 1-2mm max.
     
    nol b likes this.
  5. nol b

    nol b Member

    Joined:
    Mar 1, 2014
    Messages:
    61
    Likes Received:
    10
    The 12.5 was just to see if it was actually working or not. I'll try what you posted and let you know. Thank you for the help!
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,569
    Likes Received:
    7,229
    Ah, well keep it negative to avoid driving the nozzle into the bed :)
     
  7. nol b

    nol b Member

    Joined:
    Mar 1, 2014
    Messages:
    61
    Likes Received:
    10
    M565 worked! Thank you!
     
    mark tomlinson likes this.
Thread Status:
Not open for further replies.

Share This Page