1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Crooked Z axis coupler and chipped glass bed

Discussion in 'Technical Support' started by Red Submarine, May 8, 2014.

  1. Red Submarine

    Red Submarine Active Member

    Joined:
    Mar 12, 2014
    Messages:
    130
    Likes Received:
    39
    Hi Jerry,

    1. Recently, I found a thread on here where someone was having the same issues I am. Basically, the crooked z axis threaded rod coupler is causing my layers to shift left and right as they go up, resulting in a "wave" pattern on vertical edges. This happens because the rod will lean to one side or the other and pull the whole carriage as it does so.

    Can you please send me a replacement? I can send pictures/videos if you would like.

    2. My bed is chipped, missing a small piece half the size of a dime. I don't know how it happened but I guess it's bound to happen sooner or later. Can I order a new bed from you? Perhaps the new steel rod y axis upgrade kit comes with a new bed?

    Please let me know and thanks for your help,

    Jake
     
  2. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Hey Red, it's easiest to get ahold of Jerry using the Tech Support Request

    I don't think he handles replacements in the forums.
     
  3. Red Submarine

    Red Submarine Active Member

    Joined:
    Mar 12, 2014
    Messages:
    130
    Likes Received:
    39
    Thanks for the heads up Mike.
     

Share This Page