1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Cura tempature material problem

Discussion in 'General Questions' started by JohnShuba, Mar 10, 2017.

  1. JohnShuba

    JohnShuba New Member

    Joined:
    Mar 4, 2017
    Messages:
    24
    Likes Received:
    16
    I notice in the Cura software when it writes the gcode file it does not set the material tempature to the material selected in the library. Its always processes the tempature to 190 degrees no mater what material I have selected. The Manage Materials selection in Cura 2.3.1 does not work in windows, I read that there was a known problem with Manage Materials in the older versions but it was stated to be fixed in the newer version which it is not.

    My fix is to manual edit the gcode file and input my desired tempature. Anyone have any other suggestions?
     
    #1 JohnShuba, Mar 10, 2017
    Last edited: Mar 10, 2017
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Copy, Paste your start-uip gcode here.
     
  3. JohnShuba

    JohnShuba New Member

    Joined:
    Mar 4, 2017
    Messages:
    24
    Likes Received:
    16
    2017-03-10 09_29_34-Program Manager.png
    I found you can set tempature in Cura under custom but still can not set it base on material selection.

    Here is my gcode start header.

    ;FLAVOR:RepRap
    ;TIME:4159
    ;Generated with Cura_SteamEngine 2.3.1
    M104 S245
    M109 S245
    ; -- START GCODE --
    ;-- end of START GCODE --
    ;LAYER_COUNT:60
    ;LAYER:-8
    M107
    G1 F1500 E-1
    G0 F6000 X30.248 Y14.549 Z.239
    G1 F1500 E0
    G1 F1125 X30.817 Y14.036 E0.0609
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    Not exactly what @WheresWaldo was asking, but in an effort to be helpful I loaded up Cura 2.4 and took a look and could not find the section either. Turns out:

    https://github.com/Ultimaker/Cura/issues/780

    There isn't one (or at least not in the GUI -- you have to edit JSON files).

    This is one example of why software questions are sometimes better answered by the people who wrote it :)

    I am not sure many people here use Cura 2.x, most seem to be using the older 15.x (yea, higher version number, but still older)
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    Just to be clear... most slicers have a screen in the UI where you can specifically edit what will be executed at the start of the GCode file and at the end. Most even have places to edit what happens at layer changes. This version of Cura does not have that in the user interface, you would have to edit JSON scripts... not fun.
     
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @mark tomlinson and @JohnShuba
    Settings > Manage Printers > Printers > Machine Settings for the startup gcode.
    Settings > Manage Materials > Print Settings to show you what temps it prints at
     
    mark tomlinson and Geof like this.
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    Very well hidden :)
    Thanks.
     
  8. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Just an FYI there is an error in the default Low Quality settings. It sets one parameter to something physically impossible. The R1+PLUS can only print in layer increments of 0.02 mm as one microstep is equal to 0.02 mm of linear movement. No stepper can move fractional microsteps, or at least cannot move with that level of accuracy, so the Low Quality setting of 0.15 mm layer height cannot be guaranteed.

    http://www.prusaprinters.org/calculator/#optimallayer

    0.15 layer height = 7.5 steps
     
  9. JohnShuba

    JohnShuba New Member

    Joined:
    Mar 4, 2017
    Messages:
    24
    Likes Received:
    16
    Thank you everyone that is good info :), and yes some of the commands are layers deep in the menu structure. I just got to dig deeper i guess.
     
  10. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Does anyone know the pitch of the lead screw for the Z axis on the C2? My statement above was directed at R1+Plus usage since I forgot what sub-forum I was looking at.
     
    #10 WheresWaldo, Mar 10, 2017
    Last edited: Mar 10, 2017
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    Actually that menu path does not work for the version I have installed...
     
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    Settings -> Printer-> Manage Printers

    works but then there is no "Machine Settings" screen I can see.
    If I select a machine there is no obvious place to edit the startup GCode in any of those settings.


    At any rate :)
    It is well buried in there somewhere.
     
  13. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    I can measure threads per inch if that helps. I don't have the tools to get more precise handy :)
     
  14. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I just installed 2.4.0 from a download when I posted my first post in this thread.

    There is a button that says Machine Settings right next to a button that says Upgrade Firmware
    Are you using 2.4.0 or something other supplied by Robo3D?

    Untitled.png
     
    #14 WheresWaldo, Mar 10, 2017
    Last edited: Mar 10, 2017
  15. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    snap1.jpg

    Standard version downloaded (not from Robo). No matter which I select the options do not change to show an Update firmware either.
    (I poked around all the menu options I had)

    I am really not too concerned, but if the OP (@JohnShuba ) wants to pursue this further I will bow out.
     
  16. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Hmm... something very fishy here
    box.png
     
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    I did not try configuring an R1+ but the delta nor the C2 offer that:

    scan3.jpg
     
  18. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    If you don't have settings how do you tell Cura what size your printer is?
     
  19. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    The hard way :)

    "machine_height": {
    "default_value": 155
    },
    "machine_depth": {
    "default_value": 125
    },
    "machine_width": {
    "default_value": 125
    },
    "machine_extruder_count": {
    "default_value": 2
    },
    "machine_gcode_flavor": {
    "default_value": "RepRap (Marlin/Sprinter)"
    },
    "machine_start_gcode": {
    "default_value": "M107 ;start with the fan off\nG28 ;Home all axes (max endstops) \nG29 ; auto level \nM117 Printing..."
    },
    "machine_end_gcode": {
    "default_value": "M104 S0 ;extruder heater off\nM140 S0 ;heated bed heater off (if you have it)\nG91 ;relative positioning\nG1 E-190 F600 ;retract the filament to starting position\nM84 ;steppers off\nG90 ;absolute positioning"
    },
    "machine_shape": {
    "default_value": "rectangular"
    }
     
  20. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    Perhaps now you see why I was pulling my hair out the other day trying to get this working.

    ;)
     

Share This Page