1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

E3D Titan Extruder

Discussion in 'Mods and Upgrades' started by RotusZ, Apr 9, 2016.

  1. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    Odd, mine only has a problem when its too tight then I get grinding and slipping ( crazy huh when its tighter its worse lol ). I think i have maybe one turn from full loose.

    I had the same symptoms as you but with ninja flex. extruded in mid air fine. but during a print would stop..motor spin but would grind.

    Ninja flex was the pickiest with mine once i loosened that up..I havn't messed with it and since and haven't had any feed problems.

    I have not tried ABS.. I have tried PLA, PETG, PLA/PHA, and Ninja Flex. I just did 10+ hours worth of PLA/PHA prints with it the last two days with no problems.

    I think there is a e3d forum, maybe check there too since only a couple of us here are using them.
     
    #401 KTMDirtFace, Jun 8, 2016
    Last edited: Jun 8, 2016
  2. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    I plan to try Yogi's mount out soon, but mine already fits my machines and bearings.. so lol I punched out a huge hole so that I can install it. printing now lol

    [​IMG]

    It may end up being too flexy and wobbly. Might be good enough to get it installed on my other machine for now though.
     
    Ezra Ehrhard likes this.
  3. Yogi

    Yogi Member

    Joined:
    Feb 17, 2016
    Messages:
    45
    Likes Received:
    30
    I ended up fixing the issue with the grinding filament. I'm not sure what changed but I Took it apart, cleaned it all up and reassembled the titan and it works great.

    So heads up if anybody has odd grinding issues, double check your assembly.
     
  4. Terry Reilley

    Terry Reilley Member

    Joined:
    Dec 21, 2015
    Messages:
    104
    Likes Received:
    20
    I did it!!! Installed Titan and E3D v6. I used Yogi's extruder mount/carriage and it works very well. My only complaint thus far is rough extrusions, which may be due to over-extrusion so I need to test it somehow.
     
  5. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,074
    Congrats

     
  6. Yogi

    Yogi Member

    Joined:
    Feb 17, 2016
    Messages:
    45
    Likes Received:
    30
    Awesome, glad it worked well for you!

    It really has been a nice step up from stock. Took a fair bit of measuring to get my final extrusion number to modify in the firmware and I remember 420 ended up working perfectly for me.

     
  7. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    Got titan installed on my other robo3d ( r1+ ) finally.

    I used the 25mm motor this time instead of the 20. With my mount it just touches the X belt. So I spun it around. I tried to undo the driver pully on the X axis motor, took the set screws out and the thing would not budge at all. its stuck on the shaft completly. My plan was to move the driver pully out a hair so the belt would clear. Oh well.

    Don't really like how my wires are they will smash into the side if I try to print to the far right, and they get kinda bound up and want to fall back into the belt if I raise Z way up. I may have to go back to a cable chain.
    [​IMG]

    [​IMG]

    Used 408 for e-step setting. I used 406 on my other one. What are others using?
     
  8. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    Made a little bracket to have something to zip tie my wires to, cleaned them up so they don't keep flopping into the belt. Used two of longer screws that came with the titan.

    [​IMG]

    [​IMG]
    [​IMG]

    [​IMG]

    Printed a vase in PETG, in vase mode ( never tried that before )

    Looks like its working awesome.

    [​IMG]
     
    Rigmarol and danzca6 like this.
  9. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,074
  10. Rigmarol

    Rigmarol Well-Known Member

    Joined:
    May 14, 2016
    Messages:
    544
    Likes Received:
    280
    I love a happy ending.
     
  11. Brendan Fennell

    Brendan Fennell New Member

    Joined:
    Nov 30, 2015
    Messages:
    23
    Likes Received:
    8
    First of all, I want to say the designs you've put up in this thread are AWESOME!! I LOVED the way you built those plugs into the fan mounts, GENIOUS. And the print quality in those pictures was unbelievable. I'll be downloading and incorporating all of your designs into a Christmas rebuild of my R1 Plus, so I'd LOVE to have this two-part cable chain, preferably one that fits with the chain off amazon. Please let me know if these are posted somewhere, or if there's another way for me to reach these files. Once again, I love your designs, your build quality, your print quality, and I want my printer to be just like yours!
     
  12. Brendan Fennell

    Brendan Fennell New Member

    Joined:
    Nov 30, 2015
    Messages:
    23
    Likes Received:
    8
    Okay, never mind. I found them on your Thingiverse profile. Thanks!
     
  13. CJH

    CJH Member

    Joined:
    Oct 21, 2015
    Messages:
    44
    Likes Received:
    10
    Hey lafaspot,

    So the purple carriage mount is which design? Can you provide a link? Is it on thingiverse?

    Thanks for preparing a material list for us newbies.

    CJ
     
    paul riberth likes this.
  14. lafaspot

    lafaspot New Member

    Joined:
    Apr 3, 2016
    Messages:
    6
    Likes Received:
    6
    I the one below, I also made some changes on the cable management holes with a knife and removed some walls to give more space for cables, as you can see from the pictures.

    http://www.thingiverse.com/thing:1521037


     
  15. Jeff Hamilton

    Jeff Hamilton Member

    Joined:
    Mar 6, 2016
    Messages:
    41
    Likes Received:
    18
    Well I have taken this Christmas holiday time off and finally got a chance to update my printer. Yogi's carriage and instructions worked great. I made a new drag chain mount to take the Amazon drag chain and designed a dray chain quick release for the side of the case. Also designed the R1+ fan cover for the front fan and used fans that light up blue when they come on. Now just to tweak all my settings and get back to work.
     

    Attached Files:

    KTMDirtFace and WheresWaldo like this.
  16. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,860
    Likes Received:
    3,556
    @Jeff Hamilton that is great work, would you be willing to create a new thread outlining and explaining what modifications you made and how you got it done?
     
  17. Jeff Hamilton

    Jeff Hamilton Member

    Joined:
    Mar 6, 2016
    Messages:
    41
    Likes Received:
    18
    I was thinking about doing that, but I didn't want to offend anybody. There are several ideas and problem solving ideas spread across many thread that really need to be combined into a single upgrade thread.
     
    WheresWaldo likes this.
  18. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    Update: I ditched my "simple titan mount" I had some slop in the hot end in it for some reason on one of my machines.

    Using Yogi's mount now and its really good, works awesome. Bit more work to print just right but worth it.
     
    SPyKER likes this.
  19. woferry

    woferry Member

    Joined:
    Jan 14, 2016
    Messages:
    42
    Likes Received:
    11
    So has anybody thought about the Titan Aero yet? I never opted for the Titan, but the reduced Z footprint looks really tempting to me. I'd wonder if it would involve 'flipping' the X-carriage so that the horizontal part would ride below the rails rather than on top of it, or is there no chance of getting the Titan body to fit between the rails? Think I might order one and see what I can come up with.
     
  20. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,664
    Likes Received:
    2,291
    It will likely need a new mount, I bought one but not for my robo. It's an interesting extruder
     
    SPyKER likes this.

Share This Page