1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved Firmware upgrade for E3Dv6 and BondTech

Discussion in 'Troubleshooting' started by Jacques LeDee, Apr 2, 2017.

  1. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    Can someone advise me on how to use the Arduino software to update my firmware so that I can use the E3Dv6 hot end and Bond Tech extruder? I'm following all the directions from ROBO 3D website. See second to last attached photo.
    I've built a carriage for them and have them both mounted and wired up-as far as I can tell.
    I know (from pics attached) what to put into the software, but I don't know where or how to do it.
    I've included pics of what I'm looking at on my computer. The ones I am looking at are the last two uploaded photos.
    I'm extremely new to this type of work, so I would really appreciate some good guidance. Right now all I've got is a printer with nice parts that just sits still. I'm ready to get past this point. I'm ready to use this 400 dollar upgrade that's been collecting dust just bc I'm not a computer programmer. :(
    Thanks.
     

    Attached Files:

  2. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    Hi there. To upload you need to close out of any programs that use USB. Then you need to (If you've made the changes you need to) press verify button (on the top left of the main arduino screen) if you hover over the button it will say what it is. If it verifys you need to hook up to your printer and press upload. Do you get any errors?

    I have not done any bondtech upgrades so I can only help in the how those should work not in the this is how they work sense but I'll do my best :D
     
  3. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    Thanks for the help. But it's the changes that need to be made that I can't figure out where to put them. As you can see in the attached photos, I have the values I need. Uploading and all that seems easy and understandable. I just don't know where to put these codes at. I'm guessing under the configuration tab somewhere???
     
  4. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    It looks like all your changes are in the config.h tab. You'll basically scroll through until you find the line that matches their instructions and change it. after you change it add notes. To do so after the change put in : //write you changes here

    the // makes it a comment/note section
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,230
    Configuration.h, but yes...
    :)
     
    Geof likes this.
  6. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    Awesome! Finally-this is the answer I was looking for! I really appreciate the help! Thank you.
    I'm not by my ROBO, but as soon as I get by it, I'm gonna do what you said. Thanks again.
     
  7. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    if you have issues reach out. One of us will surely be able to help
     
  8. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    one work of advise. Make sure you include all their change! If its capital letter make it so. If there is a " ...make it so lol.
     
  9. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    Dude y'all are awesome! Okay I will!
     
    Geof likes this.
  10. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    So I was able to find the spot where I needed to change the temp sensor to 05, but I don't know where this goes. Check attachment plz. This is supposed to be for the extruder. Progressing, but not there just yet.
     

    Attached Files:

  11. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    My E3DV6 is working just fine. I can't even get the extruder to move tho
     
  12. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    Your picture indicates a gcode command so you want to open your slicer connect via usb to the printer and type that line in letter for letter (capitals spaces and all)
     
  13. Jacques LeDee

    Jacques LeDee New Member

    Joined:
    Mar 10, 2017
    Messages:
    28
    Likes Received:
    6
    where is the 'slicer'?
     
  14. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    What you load your models into to print. Mattercontrol, cura, simplify 3d are all slicers
     
  15. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,230
    and those have a GCode terminal -- that is where you enter the commands that go to the printer.
     

Share This Page