1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Help I can't get the auto level right

Discussion in 'General Questions' started by Lance Weston, Jan 8, 2022.

  1. Lance Weston

    Lance Weston Active Member

    Joined:
    Jun 2, 2018
    Messages:
    515
    Likes Received:
    171
    I go through all of the procedures and the gap between the head and the bed is a little off. I have tried everything I can think of to change the head to bed space. I have tried prob offset and home offset and neither seem to have any effect. Has anyone got this working?

    I had found the Robo R2/C2 manual a couple of years ago and It say use the home offset. Here is the manual:
    https://drive.google.com/file/d/1qnV6C_lc7KV86p0g5qLAKNnt72os-b5r/view?usp=sharing

    I have verified that going to the LCD and changing the "home offset" works.

    I also found that it is east to modify the number of points. I have a Robo R2 clone with a 12x12 bed that is randomly warped by up to 0.06mm. It also changes by 0.1mm from cold to 70C. I changed the number of points to 5x5 in the Marlin code to compensate..We should set up a Marlin topic, I have made many changes to the Marlin code.

    This is my initial Gcode:
    ;heatup of bed
    M190 S65
    ; set to millimeters
    G21
    ; home
    G28
    ; set absolute mode
    G90
    ; turn off fans
    M107
    ; move bed down 230mm
    G1 Z230 F300
    ; Home
    G28
    ; zero extruder
    G92 E0
    ; Robo Leveling
    G36
    ; home XY axis
    G28 X0 Y0
    ; zero extruder
    G92 E0; move bed to printing position
    G1 Z0.2
    ;non blocking heatup of bed
    M140 S60
    ;heatup of extruder
    M109 S220
    ; print 150mm priming line
    G1 Y-150 E10.0 F500
    ; Retract
    G10
     
    #1 Lance Weston, Jan 8, 2022
    Last edited: Jan 8, 2022
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,518
    Likes Received:
    7,304
    Probe offset is the spacing for the sensor (UV sensor on the R2/C2) to the nozzle and is moot for the R1 series (the nozzle is the sensor). Home offset (for the Z axis) should be the one to change on the C2/R2 (v1.0.x had a specific GCode for it that was later deprecated: M565).

    I have not changed anything on the C2 firmware (other than adding the second extruder) and that is a slightly never flavor of Marlin (1.1.x) than the R1 series (1.0.x).
     

Share This Page