1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Community Favorite Marlin 1.1.7 Release for Robo R1, R1+PLUS & Variants

Discussion in 'Mods and Upgrades' started by WheresWaldo, May 4, 2017.

  1. albert3d

    albert3d Member

    Joined:
    Feb 3, 2018
    Messages:
    65
    Likes Received:
    25
    @WheresWaldo you must not have been reading my original posts. That is exactly what I said to use G29 S-1 and it would return the M421 commands to recreate the mesh. :) That's ok...I'm new here. :D
     
    James Harry likes this.
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    I admit I didn't read it completely, I was under the assumption you had to do multiple commands. Don't know why that was, maybe I'm just tired after fighting all morning trying to make Robo's Marlin modifications work with my firmware.
     
    James Harry and albert3d like this.
  3. James Harry

    James Harry Active Member

    Joined:
    Feb 7, 2015
    Messages:
    127
    Likes Received:
    37
    Apparently, I didn't read it completely either. Lol. But I had used it before. Just had to look it up again.
     
  4. enigmrobo

    enigmrobo New Member

    Joined:
    Jan 11, 2018
    Messages:
    3
    Likes Received:
    3
    OK. I've read this thread three times. I've also read the Marlin wiki. I want to update Marlin and use UBL but, I am nervous lol. I have compiled version 1.1.8 with Robo options and UBL options enabled in configuration.h and configuration.adv_h. I have a working XXL controller and it is enabled in configuration.h If I somehow bork it all up, can I just flash the stock Robov2 firmware and be no worse for wear? Also, since Cura 3.2.1 has the z offset plug-in again, I shouldn't need the M851 in my start.gcode right? Thanks so much!
     
  5. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    Yes you can always flash back.
     
    enigmrobo likes this.
  6. Mike Toole

    Mike Toole Member

    Joined:
    May 18, 2017
    Messages:
    52
    Likes Received:
    10
    Total newb here. My Robo R1+ has been printing parts consistently since I received it. As far as I know, things are working ok. Do I need to update the firmware? And why? I’m afraid I’ll crash the whole thing and not be able to get it back to proper function. Inputs? Thank you!


    Sent from my iPhone using Tapatalk
     
  7. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    Why fix what isn't broken?

    This was a project specifically to bring the Robo up to current firmware standards. Not officially endorsed by Robo. I wanted a current version of the firmware for my printer and this was the only way to get it.
     
    Geof and mark tomlinson like this.
  8. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,400
    Likes Received:
    7,046
    Never update the firmware without a specific reason. By that I mean there is some difference in the new firmware that you need/want/can't live without.
    No. Update nothing.
     
    Geof likes this.
  9. Mike Toole

    Mike Toole Member

    Joined:
    May 18, 2017
    Messages:
    52
    Likes Received:
    10

    Thanks for the inputs. . I will not fix what is not broken.


    Sent from my iPhone using Tapatalk
     
    Geof likes this.
  10. enigmrobo

    enigmrobo New Member

    Joined:
    Jan 11, 2018
    Messages:
    3
    Likes Received:
    3
    I want to thank @WheresWaldo @danzca6 @mark tomlinson and all others involved for this excellent thread. I am now on Marlin 1.1.8 with UBL up and running on my R1+. I'm liking the new features and the time saved when starting a print. Once again, thanks for all your work on our Robo R1/R1+!


    [​IMG] [​IMG]
     
    mark tomlinson and Geof like this.
  11. Jim Leoanrd

    Jim Leoanrd New Member

    Joined:
    Oct 29, 2015
    Messages:
    16
    Likes Received:
    10
    I think I saw your post in the Robo3D facebook group. Looked to be working well. I would love to upgrade to MESH or UBL, but it prints so darn consistent right now. THe 9 point probing kills my Geckotek surface though.

    I havent followed Marlin since @WheresWaldo stopped posting the updates. Did 1.1.8 magically fix a bunch of UBL stuff?
     
  12. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    @Jim Leoanrd I am using 1.1.8 on the R2 with UBL, works very well. Ask @danzca6 where the link to his version of 1.1.8 is located.
     
    enigmrobo likes this.
  13. enigmrobo

    enigmrobo New Member

    Joined:
    Jan 11, 2018
    Messages:
    3
    Likes Received:
    3
    Jim, I'm not sure if 1.1.8 fixed anything but, it was far easier than I imagined to set up UBL. I couldn't find a link to 1.1.8 adjusted for our R1+ so I just copied the configuration.h and configuration_adv.h from the 1.1.7 posted here and built in Arduino. I only received one error about the nozzle park feature, which was just a wording issue, but since I don't plan on using filament change feature, I commented it out. I double checked the options for enabling my XXL controller and read the files to get a better understanding of them. I also mucked around and changed machine type to Cylon lol! I'm not going to say to upgrade the firmware and use the awesomeness that is UBL if your machine is printing fine. I personally am glad I did. YMMV.
     
    mark tomlinson likes this.
  14. Ed Neugebauer

    Ed Neugebauer Member

    Joined:
    Mar 31, 2016
    Messages:
    35
    Likes Received:
    1
    How do I exit out of manual mesh using 1.1.7 on the LCD? I'm stuck in this menu and cannot get out. It will not time out either.

    Thank you.
     
  15. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    Try rebooting the printer, I believe all Menu issues were resolved with 1.1.7, or you can try 1.1.8 or Bugfix-1.1.x
     
  16. Ed Neugebauer

    Ed Neugebauer Member

    Joined:
    Mar 31, 2016
    Messages:
    35
    Likes Received:
    1
    Won't I lose all of my manual mesh setting then? I tried to save it through Octopi using the terminal and M500 and it says it's busy.

    I ordered a new bed from Robo last year. I just installed it within the last few months and man is it warped. The auto mesh does not get me very close at all.
     
  17. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    Yep you will have to redo everything.
     
  18. Ed Neugebauer

    Ed Neugebauer Member

    Joined:
    Mar 31, 2016
    Messages:
    35
    Likes Received:
    1
    It finally timed out after changing a few more.

    On to my next question...Here is my mesh map:


    Recv: 0.000 0.000 0.000 0.070 0.070 0.040 0.020
    Recv: Recv: 0.000 0.000 0.000 [ 0.055] 0.070 0.040 0.035 T:210.00 /210.00 B:60.17 /60.00 @:61 B@:56
    Recv: Recv: Recv: 0.000 0.000 0.000 0.000 0.015 0.040 0.040
    Recv: Recv: 0.000 0.000 0.000 -0.010 -0.010 0.040 0.025
    Recv: Recv: 0.000 0.000 0.000 -0.040 -0.025 0.000 0.000
    Recv: Recv: 0.000 0.000 0.000 -0.041 -0.040 0.010 0.000
    Recv: Recv: 0.000 0.000 0.000 -0.040 -0.040 0.010 0.000

    On the positive values, like the top middle to right ones my print always stays the same and the print is too low. What am I doing wrong? I started out from 0 and it's still too low even with .070. That is almost .003 of an inch difference and nothing changes. My print looks the same with high spots and low spots.
     
  19. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,852
    Likes Received:
    3,553
    I haven't used MESH in a while, and we need a picture or it didn't happen.
     
  20. Ed Neugebauer

    Ed Neugebauer Member

    Joined:
    Mar 31, 2016
    Messages:
    35
    Likes Received:
    1
    It's pretty cut and dry really. I edit the mesh to go move certain points up for down and nothing happens. On one of my bigger prints that covers most of the bed, I get squished prints near the top and right side, too high of print on the left bottom, and 3d porn everywhere else. I output my mesh values to my host, Raspberry pi, and my adjusted values are there, but the print still looks the same. Maddening.
     

Share This Page