1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Unanswered New Screen Troubles

Discussion in 'Troubleshooting' started by Carlos144Green, May 8, 2020.

  1. Carlos144Green

    Joined:
    Mar 19, 2019
    Messages:
    34
    Likes Received:
    6
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,421
    Likes Received:
    7,299
    If you use that screen I am not sure the existing drivers for the 3.5 inch screen will work.
    You will probably need to installed the drivers for that one.

    That is probably the same as the 7" Waveshare: https://www.waveshare.com/wiki/7inch_HDMI_LCD_(B)
     
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,421
    Likes Received:
    7,299
    Raspbian has those drivers by default, but the Robo image with OctoPi and the LCD software would use a different driver for that 3.5" screen so you need to install the drivers for that one back :)
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,421
    Likes Received:
    7,299
    and as a TOTAL side note -- this is why Robo should never have gone down this road -- they are not software people and when you have an OS involved things get complicated :) They had enough issues dealing with Marlin much less Raspbian, OctoPrint and the custom menu stuff...
     
    tkoco and Carlos144Green like this.
  5. Carlos144Green

    Joined:
    Mar 19, 2019
    Messages:
    34
    Likes Received:
    6
    I just recently started playing around with these and I don't know much. Do you know where I can get the proper drivers and how to install them?
     

Share This Page