1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

New Update brought back leveling issue

Discussion in 'Troubleshooting' started by Sefa, Mar 12, 2018.

  1. Sefa

    Sefa New Member

    Joined:
    Jul 21, 2017
    Messages:
    17
    Likes Received:
    4
    Hi everyone,

    I used to have autoleveling problem, got an IR replacement which seemed to fix my issue for a while. Now I just got the update screen on my R2 and updated it. The bed and extruder movement seems a lot faster which is a good thing. However, I cannot start my prints, the extruder hits the bed really hard and it gives an error on the screen after trying twice. Am I the only one who has this problem after the new update.

    Here is the video:


    P.S. I can tell that the sensor is working because I can see the red light hitting the bed.
     
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,236
    Likes Received:
    3,186
    I have had that happen to me also, where the IR trigger is ignored. Does it happen every time?
     
  3. Sefa

    Sefa New Member

    Joined:
    Jul 21, 2017
    Messages:
    17
    Likes Received:
    4
    Now it is every time. The support sent me this update about 2-3 months ago when they were testing, it did the same and I had to downgrade my version. I guess I have to go back to the previous version. I am just trying to figure out if it is only me or is it everyone.
     
  4. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,236
    Likes Received:
    3,186
    I am not sure how to help, I have other issues, of my own making, that I have to fix before my R2 is usable with 2.0. From my understanding there is no way to go back to the old update, kind of like upgrading from Win7 to Win10, without reinstalling an older image. But what you are experiencing is, I believe, a firmware issue.
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    19,245
    Likes Received:
    6,403
    You can re-image the SD card to an older version. That is the only way.
     
  6. anmael

    anmael New Member

    Joined:
    Dec 30, 2014
    Messages:
    18
    Likes Received:
    5
    I am having the same problem.
    I managed to start a print by turning off the lights in the room. But then a few minutes after I turned them back on the nozzle dug into the print, disconnected the bed (I still have V1), and made the print fail.
     
  7. Shrey

    Shrey Active Member

    Joined:
    Jul 6, 2017
    Messages:
    143
    Likes Received:
    60
    I'm not having that issue, but needless to say autolevel makes my nozzle few mm away from the bed making the first layer sticking to bed very much pain. Currently I'm testing it out with having autolevel gcode, generally that's how I've been printing before without any issues.
     
  8. AllenMcAfee

    AllenMcAfee Moderator
    Staff Member

    Joined:
    Jan 4, 2016
    Messages:
    13
    Likes Received:
    13
    @Sefa a couple questions: are you always experiencing this when using (what looks like) cream-colored painters tape? Have you also made sure all your wiring connections for your extruder are seated nice and tight? If the red LED is illuminating when it senses the bed, the IR sensor is working correctly. If the printer is not picking it up during the leveling process I would first opt to check that. Since you are reporting it was working correctly in the previous version, we may indeed have another problem.

    The first thing I would check is the response of M501 (from Terminal on the printer dashboard). The top of the response should look like this:

    Send: M501
    Recv: echo:V41 stored settings retrieved (498 bytes; crc 47542)
    Recv: echo: G21 ; Units in mm

    If you are seeing EEPROM VERSION MISMATCH or any similar error in this line, let me know and we can go from there.
     
  9. AllenMcAfee

    AllenMcAfee Moderator
    Staff Member

    Joined:
    Jan 4, 2016
    Messages:
    13
    Likes Received:
    13
    @anmael the IR sensor is not used after the autoleveling sequence is finished, so the light in the room should have no effect once you start printing. The light levels in the room should actually have no real bearing on the printer in general. Are you using the latest version of the firmware that was updated on the printers yesterday?
     
  10. Sefa

    Sefa New Member

    Joined:
    Jul 21, 2017
    Messages:
    17
    Likes Received:
    4
    @AllenMcAfee Thank you for your response.

    When I enter M501 into the terminal, I get this:

    Send: M105
    Recv: ok T:18.75 /0.00 B:21.56 /0.00 @:0 B@:0

    The IR sensor seems to be working. When I try Z Offset wizard or Bed Calibration wizard, they seem to be working. The bed does not hit the bed at all. But if I try Fine Tune Offset Wizard or printing something the bed pressures on the extruder.
     
  11. anmael

    anmael New Member

    Joined:
    Dec 30, 2014
    Messages:
    18
    Likes Received:
    5
    Yes, I am using the latest version. Also, yesterday I updated to the V2 of the heat bed.
    I also spent some time cleaning the sensor with a duster and now the printer goes through the autoleveling properly and consistently.

    However, it seems that the first layer height changes a bit every time..
    I had one print that was perfect, first layer completely on point. Without changing any setting, I printed the same file with the same filament, and the print got almost glued to the bed. It took a lot of effort to remove (it actually chipped off parts of the bottom of the print), and now I have the skirt (petg) of that print virtually fused to the buildtak :/
     
  12. anmael

    anmael New Member

    Joined:
    Dec 30, 2014
    Messages:
    18
    Likes Received:
    5
    On a side note, any tip on how to replace the buildtak on the V2 of the bed? :D
     
  13. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,236
    Likes Received:
    3,186
    Pick a corner, pull up, sometimes heating with a hairdryer will help soften the adhesive. Clean all remaining adhesive from the bed. Place the new sheet on normally.
     
  14. AllenMcAfee

    AllenMcAfee Moderator
    Staff Member

    Joined:
    Jan 4, 2016
    Messages:
    13
    Likes Received:
    13
    @Sefa That response you posted was actually the temperature response that comes up every couple seconds. The M501 response is much longer. It would look like this:

    ```
    Send: M501
    Recv: echo:V41 stored settings retrieved (498 bytes; crc 55002)
    Recv: echo: G21 ; Units in mm
    Recv:
    Recv: echo:Filament settings: Disabled
    Recv: echo: M200 D3.00
    Recv: echo: M200 D0
    Recv: echo:Steps per unit:
    Recv: echo: M92 X80.00 Y80.00 Z800.00 E145.50
    Recv: echo:Maximum feedrates (units/s):
    Recv: echo: M203 X300.00 Y300.00 Z12.00 E25.00
    Recv: echo:Maximum Acceleration (units/s2):
    Recv: echo: M201 X3000 Y3000 Z100 E1000
    Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv: echo: M204 P500.00 R1000.00 T1000.00
    Recv: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv: echo: M205 S0.00 T0.00 B20000 X8.00 Y8.00 Z0.40 E1.00
    Recv: echo:Home offset:
    Recv: echo: M206 X0.00 Y0.00 Z-13.55
    Recv: echo:Auto Bed Leveling:
    Recv: echo: M420 S0
    Recv: echo: PID settings:
    Recv: echo: M301 P23.75 I1.48 D95.10
    Recv: echo: M304 P107.41 I21.29 D135.50
    Recv: echo:Z-Probe Offset (mm):
    Recv: echo: M851 Z-18.62
    Recv: echo:Linear Advance:
    Recv: echo: M900 K0.00 R0.00
    ```
     
  15. Sefa

    Sefa New Member

    Joined:
    Jul 21, 2017
    Messages:
    17
    Likes Received:
    4
    @AllenMcAfee
    I am sorry for the confusion, here it is:
    Send: M501
    Recv: echo:V41 stored settings retrieved (498 bytes; crc 23950)
    Recv: echo: G21 ; Units in mm
    Recv:
    Recv: echo:Filament settings: Disabled
    Recv: echo: M200 D3.00
    Recv: echo: M200 D0
    Recv: echo:Steps per unit:
    Recv: echo: M92 X80.00 Y80.00 Z800.00 E145.50
    Recv: echo:Maximum feedrates (units/s):
    Recv: echo: M203 X300.00 Y300.00 Z15.00 E25.00
    Recv: echo:Maximum Acceleration (units/s2):
    Recv: echo: M201 X3000 Y3000 Z100 E1000
    Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv: echo: M204 P500.00 R1000.00 T1000.00
    Recv: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv: echo: M205 S0.00 T0.00 B20000 X8.00 Y8.00 Z0.40 E1.00
    Recv: echo:Home offset:
    Recv: echo: M206 X0.00 Y0.00 Z-20.00
    Recv: echo:Auto Bed Leveling:
    Recv: echo: M420 S0
    Recv: echo:pID settings:
    Recv: echo: M301 P23.80 I1.70 D85.00
    Recv: echo: M304 P107.41 I21.29 D135.50
    Recv: echo:Z-Probe Offset (mm):
    Recv: echo: M851 Z0.00
    Recv: echo:Linear Advance:
    Recv: echo: M900 K0.00 R0.00
    Recv: ok

    I noticed that my Z value is -10.2 but when I enter EEPROM menu, and click Home Offset, I see -20. Does it seem right?
     
  16. AllenMcAfee

    AllenMcAfee Moderator
    Staff Member

    Joined:
    Jan 4, 2016
    Messages:
    13
    Likes Received:
    13
    @Sefa Thanks for that, it actually helps quite a bit. It looks like as of when you copied this, your Z Offset is set to the reset default of -20. This will cause the nozzle to print too high off the bed (air print) in order to prevent it from crashing into the bed if you start a print without the Z offset calibrated. You can tell in this line here:

    Recv: echo:Home offset:
    Recv: echo: M206 X0.00 Y0.00 Z-20.00

    Have you completed the Z Offset wizard since the update?
     
  17. Sefa

    Sefa New Member

    Joined:
    Jul 21, 2017
    Messages:
    17
    Likes Received:
    4
    @AllenMcAfee I contacted Robo support via email and they told me this:

    "Thanks for the video, it shows the tape you have on the bed and I think that is the cause of the issue as we have not tested our new firmware using that color tape and I think that is the cause here."

    So it seems that the new firmware does not work with that color tape. I did not think it would be the issue as I have always been printing on this color tape before. Anyway, my problem seems to be fixed now. Thanks a lot for your help, Allen!
     

Share This Page