1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved Prints not sticking to bed after hotend swap

Discussion in 'Troubleshooting' started by 4sfaloth, Nov 12, 2019.

  1. 4sfaloth

    4sfaloth Member

    Joined:
    Sep 9, 2018
    Messages:
    41
    Likes Received:
    6
    Hi,

    I have this very weird (at least for me) situation going on. I've had my Robo 3D R1+ printer for over a year now, and overall it has served me well. Over the last few months I had done dozens of several prints, with rare issues. Then one of the thermistor wires broke, so i ended up ordering a new hotend assembly (for official supplier: https://www.partsbuilt.com/r1-hotend-assembly-robo) and swapping it. The swap was fairly easy and everything with the hotend seems to fine (it heats with no issue, filaments goes out, etc...) but I've tried like 5 different prints (different models, even different filaments) that failed due to the filament not sticking to the print bed. Is it just a coincidence, or is there any reason why this might occur after a hotend swap? Did I have the re-calibrate anything?

    The only other relevant change I can think of is that in the 2 months it took for the whole diagnose-order-fix to take place the weather around here changed quite a bit, and temperatures dropped from over 24ºC to below 15ºC.

    Thanks in advance for the help
     
  2. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,672
    Likes Received:
    2,291
    Changing the hotend you’ll need to adjust your z offset and it should fix you up
     
  3. 4sfaloth

    4sfaloth Member

    Joined:
    Sep 9, 2018
    Messages:
    41
    Likes Received:
    6
    ah, great! I thought since it has auto-adjustment that the offset would be the same for all hotends.
    I'll give it a shot (maybe tomorrow, most likely over the weekend) and then close this if it works out

    Thanks for the quick reply
     
  4. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,672
    Likes Received:
    2,291
    Auto level is suppose to help with a non flat bed - z offset sets the initial gap between the bed and the nozzle. Manual adjustment :)
     
    mark tomlinson likes this.
  5. 4sfaloth

    4sfaloth Member

    Joined:
    Sep 9, 2018
    Messages:
    41
    Likes Received:
    6
    Another newbie question but I can't seem to find the answer anywhere: I've seen I can replace the z-offset with the M565+M500 to store command (or using the macros in MatterControl which do the same).
    But how can I read the current value stored in the printer?
     
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,864
    Likes Received:
    3,560
    From the Terminal screen if you issue a M565 it will spit out the current setting. If you want to see a list of settings M503 will display that list in the terminal screen.
     
  7. 4sfaloth

    4sfaloth Member

    Joined:
    Sep 9, 2018
    Messages:
    41
    Likes Received:
    6
    thanks for the tip. I checked and the current value was 0.9. I reduced it to 0.8, which is the lowest available MACRO in MatterControl, and things improved but still don't seem quite right. Basically the model I was printing (a small tabletop miniature) printed out alright, but the tree-like support structures didn't adhere to the bed. Is it safe to manually try even lower z-offsets (say, 0.75) or should I try something else?
     
  8. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,864
    Likes Received:
    3,560
    I don't use Mattercontrol but you could just issue an M565 with just about any number and it will stick for that session, no macros needed. If you want to make it permanent then issue a M500 afterwards.
     
    Geof likes this.
  9. 4sfaloth

    4sfaloth Member

    Joined:
    Sep 9, 2018
    Messages:
    41
    Likes Received:
    6
    yes, I've managed to get it all working by now. Thanks :)
     
    Geof and mark tomlinson like this.

Share This Page