1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Problems Encountered with my C2

Discussion in 'Troubleshooting' started by Don Anderson, Feb 20, 2017.

  1. Don Anderson

    Don Anderson New Member

    Joined:
    Jun 28, 2016
    Messages:
    14
    Likes Received:
    1
    I hope this is the correct place to post this info. I sent these items to Robo a few days ago and haven’t heard back from them yet. Maybe someone on the forum can assist.

    I updated my C2 to RoboOS 1.1.1 as of 2/11/17. Experienced no problem with the update or printing after the install.

    1 I am able to both connect via USB cable to the C2 and also via the IP address. I still can’t link to the C2 via the HotSpot mode. No idea why.

    2 I have to reset the Z Offset before every print!!!! The C2 won’t save the offset.

    a. When I execute the Z offset wizard, when its done it is usually 4.6 to 5. I save it and print. The print works fine.

    b. When trying to print the second model (I never powered off the C2), the Z offset has changed and needs to be reset via the wizard. Sometimes it becomes so small as to jam the extruder point into the bed, other times it is an inch or two below the extruder. The C2 isn’t saving the value permanently.

    c. Same problem occurs if C2 powered of and back on.

    2 When powering up the C2 and also when getting ready to print a model, the print head unit goes all the way to the back left corner (when facing the C2) and makes a terrific noise like it is trying to go farther but the rods won’t let it. This occurs every time now.

    a. I have tried to set the X axis more towards the right of the C2 and the Y axis more towards the front of the C2. These don’t save and they revert back to their original settings.

    b. I even tried touching the home key after adjusting. No difference except the print head goes to the back Left corner and rattles again.

    c. Definitely need help on this before something breaks.

    3 Minor persistent problem in that I cannot activate any item on the C2 screen with my fingers. I need to use a pencil with an eraser to select options.

    4 I also need the fix for the Filament Runout Sensor (FRS)problem.

    5 Any suggestions on how to keep the Build Plate Adhesion from cementing the base of a model to the print bed pad? On my R1+, I spray the heated bed with Aqua Net hairspray but that doesn’t help on the C2.

    6 I also noticed that the front horizontal rods holding the print head is positioned all the way to the right inside of the C2. It seems to run along the side with no gap as it prints but I haven’t noticed any problems with it otherwise. Just checked the horizontal rods through the print head again and they both have moved farther to the right. Something might be loose and I don’t know what to do about it. Don’t know if this is dangerous to C2 or not.

    As I said before, any assistance from the forum users would be greatly appreciated.
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,629
    Likes Received:
    7,312
    Have you looked on the LCD config to see what the Z offset is set to?
    That might tell us if it is actually storing it or not.
    May have you set it and then force a EEPROM set to store it or forcibly clear the flash EPROM first and then store it.
    I can walk you through that (using OctoPrint and the terminal).

    Not sure what the "filament run-out sensor" problem is, you might want to illuminate us.

    Take a picture of the top of the rods and upload it so we can see what you mean (or several if needed). mine came with one completely out of position.
     
  3. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    Check the end stop switch theres two of them 1 on the back wall left side and 1 on the left wall near the back. Make sure the bars are hitting it if not you can grip one bar and pull it back to make sure it hits. The rods wont be exactly centered they need to be closer to the side where the switch is for them to hit it. The rods should not be loose when you try to pull them from oneside to the other it should feel pretty tight. Also like Mark said check when you click on file to print on the printer screen itself it will tell you what the z axis is set at.
     
  4. John M. Fruits

    Joined:
    Oct 9, 2013
    Messages:
    55
    Likes Received:
    22
    The noise while homing is due to the rods (going from the left to the right) are not hitting the limit switch. These rods are easily moved back and forth. I had this exact same problem. After a few seconds, the printer gives up and assumes you have homed. Just reach in and push the back one (from left to right) and if you look closely, you will see where it is designed to hit the limit switch.

    I would also carefully slide the carriage to the front or the back, and assure that the carriage is perpendicular..... if not, slide it back to the middle, and put slight opposite forces on the left and right sides, causing the belt to jump teeth and create alignment.
     

Share This Page