1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Robo R2 Z Wizard wont calibrate correctly

Discussion in 'Troubleshooting' started by Kizmet, Nov 22, 2019.

  1. tkoco

    tkoco - -.- --- -.-. ---
    Staff Member

    Joined:
    May 7, 2018
    Messages:
    691
    Likes Received:
    262
    Cura will do a decent job of slicing, plus it integrates into Octoprint very nicely. The ability to tweak various processes, like Simplify 3D is able to accomplish, is a bit lacking and can have unintended side effects. However, there is a lot of options for optimizing the print job - many of which I have yet to explore. If you need help with Cura, just ask ( in the Software area, please )
     
    wuidling and mark tomlinson like this.
  2. Yopz3d

    Yopz3d New Member

    Joined:
    Apr 24, 2020
    Messages:
    11
    Likes Received:
    1
    Similar problem to what I had, someone should take the time to write up a how to solve in a one response would save future users some time but thank you for yours


    Sent from my iPhone using Tapatalk
     
  3. John Wohlfeil

    John Wohlfeil Member

    Joined:
    Oct 13, 2017
    Messages:
    38
    Likes Received:
    15
    After sitting for a couple of years, I turned on my Robo R2 printer and immediately updated the firmware on the machine to RoboOS 2.0.0-r2.6 using the printer LCD screen.



    Then, I attempted to run the Z-Offset Wizard - which appeared to work. I was getting a new setting value of about 13.65-14.00. But if I attempted a test print, the print head was jamming down onto the print bed, tipping the opposite corner up, and grinding the hotend nozzle across the bed, scratching it.



    After a lot of trying, resetting and retrying the Z-Offset Wizard, I now learned that I was unable to run the Bed Calibration wizard, or the Fine Tune Offset, because of an error. I would get the error stating, your Z-Offset is set to 13.65 (for example), but the Z-Offset is not set. Set the Z-offset before you can run this ...



    The short story is:



    First, I downloaded and installed RoboOS 2.0.0-r2.6 using the Robo R2 printer LCD screen.

    Then I dowloaded and installed Official Marlin_1.1.6_RoboVersion_1.2.6_R2.hex as mentioned above, using the octo print web interface, under settings, firmware updater, then checking to be sure the correct version was loaded under EEPROM Marlin Editor Plugin (only check it here, I couldn’t load it from here, I had to load the .hex file under Firmware Updater just below EEPROM on the settings list.)



    Then, I manually set the Z-Offset using the LCD on the printer, under the Utilities, Options, EEPROM, Home Offset: to -7.0



    Changing this setting to a negative 7, allowed the printer to run the Bed Alignment Wizard, which lead me to manually adjust the screws on the print bed corners, and have an Z-Offset that will work.



    I loaded a test print and it printed.



    Now, I am printing a final file and it appears to be working normally.
     
    mark tomlinson likes this.
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,480
    Likes Received:
    7,303
    Some of that is in the FAQ, but glad you got it working,
    The golden rule is -- don't update the firmware unless you really must :)
    The last versions of 'RoboOS' (Raspbian + OctoPrint) had configuration problems.
    Once you get to a stable configuration -- DON'T update it again. There have been no productive firmware changes in several years.
     
  5. Lance Weston

    Lance Weston Active Member

    Joined:
    Jun 2, 2018
    Messages:
    491
    Likes Received:
    163

    -13.55 is fine. This sounds like settings->gcode scripts.. Please copy the file and post it. Your gcode script might be corrupted and adding an offset before print.
     
  6. Lance Weston

    Lance Weston Active Member

    Joined:
    Jun 2, 2018
    Messages:
    491
    Likes Received:
    163

    i would like to see the settings initial gcode script because it looks like offset was set, then he did not run the auto leveling. If the auto leveling is called in the initial gcode script but was never calibrated he will get the 2mm offset.
     

Share This Page