1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Answered Wiring help for Adrino after E3D V6 upgrade

Discussion in 'Troubleshooting' started by Arthur Smith, Mar 10, 2016.

  1. Arthur Smith

    Arthur Smith Member

    Joined:
    Feb 25, 2016
    Messages:
    30
    Likes Received:
    0
    I am totally lost trying to wire this after upgrading to the E3D V6. The video by Novice Expert is from the stand point of someone who knows what they are doing. The wiring video by Robo 3D, for the x, y, z says to reattach them how you labeled them when taking it apart. But how do I know which goes where if I didn't label it??

    Also, the D9 use to go to a fan. Novice expert's video says to hook that back in, but it never shows putting back on any fan that might go to it? What goes there?

    Finally, I also accidentally disconnecte4d the Aux from the light on the side of the unit. The male plug has 2 rows of 4, the female has 2 rows of 5. Anyone know which way I plug it in??
     
  2. robert sanchez

    robert sanchez Active Member

    Joined:
    Oct 9, 2014
    Messages:
    320
    Likes Received:
    160
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,365
    Likes Received:
    7,171
    I can give you a photo of a standard RAMPS 1.4 with the connections labeled, but I do not have one of those for the new RAMPS with the re-done connectors that the R1+ uses. Electrically they are the same, but the style and location of some connectors changed.

    Someone with an R1+ can take a photo of the RAMPS and you can use that I imagine :)

    (labeling them when you removed them would of course have been easier, but ... you knew that)
     
  4. Nathan Simers

    Nathan Simers Member

    Joined:
    Feb 25, 2016
    Messages:
    59
    Likes Received:
    19
    Im also looking for a updated install guide do we still need to drill a hole for the boden tube? this is for the newest robo
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,365
    Likes Received:
    7,171
    Good luck with that.

    I think the answer is yes you still need to widen the hole where the PTFE tube goes down into the hotend cold-section, but I don't have an R1+ to look at.
     
  6. Arthur Smith

    Arthur Smith Member

    Joined:
    Feb 25, 2016
    Messages:
    30
    Likes Received:
    0
    I'd LOVE a labeled pic if someone has one!!

    And yes, labeling as I went would have been smart. But I so do not know what I am doing I was just concentrating so hard on following the video step-by-step that I didn't think to do anything that wasn't said.

    How do I trace the wires backwards to know which is x, y, or z? I can see where each goes, but don't have the know-how to say 'ah ha! That's the Z"

    Oh, and I THINK I have the R1, not the R1+
     
    #6 Arthur Smith, Mar 10, 2016
    Last edited: Mar 10, 2016
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,365
    Likes Received:
    7,171
    If it is an R1 then it has a standard RAMPS 1.4

    ramps1-4connectors.png



    J3UXUYs.gif
     
  8. Arthur Smith

    Arthur Smith Member

    Joined:
    Feb 25, 2016
    Messages:
    30
    Likes Received:
    0
    So what I am needing is to know which wire to put where for the X Endstop, Y Endstop, Z Endstop, and possibly the Aux in the most lower right (though this may not even be needed.

    I think maybe I am misleading you into thinking I am smarter than I really am. So, in this pic, one of the wires for each of these endstops, goes to the three areas I have circled. Which is x, y, z? This is probably pre '3D Printer 101', but hey. :)
    .
     

    Attached Files:

  9. Arthur Smith

    Arthur Smith Member

    Joined:
    Feb 25, 2016
    Messages:
    30
    Likes Received:
    0
    And here is the aux3 I am trying to figure out.
     

    Attached Files:

  10. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,365
    Likes Received:
    7,171
    Endstops are clearly labeled in the one drawing. That is where they connect.
    Aux 3 is also labeled -- that is where the factory SD card reader connects.

    edit: Ah, you need to know the other end -- not Aux 3, but the SD card reader itself.
    Let me see if I can get a photo... but the wire colors are probably pointless as I doubt Robo is consistent with them.
     
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,365
    Likes Received:
    7,171
    OK, no... I do not have any factory ones left around to look at.
    Someone else might have a photo.
    I already upgraded all of mine to LCD controllers of different sorts.

    If memory serves though you can just wire it up and try reading it with a sacrificial SD card. It will either work or not and if not reverse the connections. It will not damage the RAMPS.
     

Share This Page