1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved Z axis grinding after upgrade

Discussion in 'Troubleshooting' started by Paladin, Mar 31, 2017.

Thread Status:
Not open for further replies.
  1. Paladin

    Paladin New Member

    Joined:
    Mar 18, 2017
    Messages:
    26
    Likes Received:
    9
    I just completed some upgrades on my kickstarter Robo 3D. I installed the couplers, brackets and switches today replace the original single Z axis. I replaced the J-head with an E3D V6 and dual parts fans. I also uploaded the newer R1 firmware so I could use auto leveling.

    I started Matter Control and used it to raise the Z axis which made a grinding noise while moving either up or down. The X and Y axis sounded fine.

    It'll be a couple days until I can work on it again but I did find one possible lead. I found a video online of someone who's Robo made a similar noise after upgrading to 8mm threaded rods. The poster commented that he fixed it by adjusting the trim pot to give the stepper motors a little more power.

    This seems plausible as the kickstarter x carriage rides on a pair of 'regular' sized nuts but I'm now using larger threaded couplers with brackets and microswitches attached, which must be increasing the drag on the threaded rods.

    Thoughts?
     
    #1 Paladin, Mar 31, 2017
    Last edited: Apr 1, 2017
  2. Paladin

    Paladin New Member

    Joined:
    Mar 18, 2017
    Messages:
    26
    Likes Received:
    9
    Getting ready for work this morning, I found a post here with a video of the same grinding sound as my Robo. It seems that there's a chance I installed the wrong firmware, as 8mm firmware might cause the same grinding on Z axis with my 5/16 rods. I'll check when I get home from work tonight. Hopefully it's that simple.
     
    mark tomlinson likes this.
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,421
    Likes Received:
    7,299
    That is the real problem with historic (non-C2/R2) firmware for Robo -- you need to be careful or you end up using the wrong one.
     
  4. Paladin

    Paladin New Member

    Joined:
    Mar 18, 2017
    Messages:
    26
    Likes Received:
    9
    Looking at the firmware page, I think I need to use "R1 with Auto Level and 5/16 inch Rods". I think the one I used was for the later 8mm R1's.

    I hope it's that easy! I'll post results later this evening.
     
  5. Paladin

    Paladin New Member

    Joined:
    Mar 18, 2017
    Messages:
    26
    Likes Received:
    9
    Sweet! Rather than using the "R1 with Auto Level and 5/16 inch Rods" firmware and having to change the hotend thermistor and max temp settings for the E3D V6 again, I just grabbed the steps line from configuration.h and changed the firmware I had previously installed (ROBO3DR1V3_06_11_2015) to match.

    For 5/16 threaded rods:
    #define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,2267.72,723.38}

    I realize I should print a calibration cube and do the math to get it as close as I can, but using 2267.72 for the Z axis stopped the grinding sound so I know it's a good baseline and that I didn't mess something up with my upgrades.

    To celebrate, I just ordered the parts to do the lead screw update!

    Now I just hope that the upgrades allow me to print PLA without it warping off the bed on the left side 95% of the time. Sometimes the print will stick to the blue tape but warp enough to start lifting the tape off the glass bed. But that's a problem for another post, or with luck it'll be solved with the new hotend and auto leveling.
     
    mark tomlinson likes this.
Thread Status:
Not open for further replies.

Share This Page