1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved At my wits end. Need help w/ firmware

Discussion in 'Troubleshooting' started by Scifideity, Sep 30, 2021.

  1. Scifideity

    Scifideity Member

    Joined:
    Mar 24, 2016
    Messages:
    71
    Likes Received:
    15
    Whelp. It wasn't the RAMPS. Put the new one in and same issue with the LCD.

    Pulled off the stepper drivers and swapped them a new set and the problem went away. Here's the bizarre part. With the LCD working again I figured I'd swap out the drivers one at a time determine which one was the culprit. I just swapped them out in the same slot one at a time and NONE of them caused the problem to return. Gave up figuring out which combination of them may cause it to return.

    Tried to do the PID Tuning for the Bed heater and found it not heating up. I've hooked everything up according to this thread http://community.robo3d.com/index.p...nstalling-ssr-pid-control-instructions.17512/ and double checked every connection shown in the images. I guess it's possible my Bed heater bit the dust. Short of the stepper motors it's the only powered component left that hasn't been swapped out. I replaced my Bed a while back because some glass popped off when removing a PETG print. I've still got that Bed so I'll test using that one tomorrow. If I mess with this thing any more tonight I'll probably end up punting it out the window. ;)
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,477
    Likes Received:
    7,303
    I was only able to get the bed pid tuning to work on one out of three. The heater was just so slow at actually heating it just never would PID tune correctly.

    It is more useful on the hotend than the bed IMHO so I never worried about it much :)
     
  3. Scifideity

    Scifideity Member

    Joined:
    Mar 24, 2016
    Messages:
    71
    Likes Received:
    15
    When it wouldn't do the PID Tuning I tried setting it for a print and the hot end started getting up to temp but the bed never read more than room temp the entire time. Gonna do some more troubleshooting and try the old bed if needed. Wish me luck ;)
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,477
    Likes Received:
    7,303
    Good luck. On many of them this was a symptom that the MOSFET (Q3) that drives the heated bed was dead.

    The best way to prevent that is to use an SSR to switch poewr to the bed and the control pins for the MOSFET are tied to the RAMPS output. What you can check is with no bed wires landed, and a way to get to the RAMPS, tell the bed heater to turn on and then read voltage on the bed heater output connections. If it is zero volts then ... dead MOSFET.
     
  5. Scifideity

    Scifideity Member

    Joined:
    Mar 24, 2016
    Messages:
    71
    Likes Received:
    15
    Looks like the problem is the SSR. Took the SSR out of the picture and the Bed starts heating up right away.
    I checked the voltages both with and without the SSR and I get the same readings so I'm not sure what the issue is. With the SSR in the circuit I never see the red light come on near the MOSFET on the RAMPS when the heating starts like I do now with the SSR out of the picture and the bed working again.

    Getting more and more convinced this thing is just cursed /LOL
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,477
    Likes Received:
    7,303
    Depending on how/where you sourced the SSR it is entirely possible you ended up with a bogus one.
    There are a lot of cheaper "fake" ones out there ... (Google fake FOTEC for some enlightenment).

    I would suggest that you buy the SSR from some place like Mouser or Grainger to insure you are getting an actual working one.
     
  7. Scifideity

    Scifideity Member

    Joined:
    Mar 24, 2016
    Messages:
    71
    Likes Received:
    15
    Got it via Amazon https://www.amazon.com/gp/product/B08FQWB8HJ/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
    According to the other threads it at least "looks" legit with the rounded corner sticker.
     
    mark tomlinson likes this.
  8. Scifideity

    Scifideity Member

    Joined:
    Mar 24, 2016
    Messages:
    71
    Likes Received:
    15
  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,477
    Likes Received:
    7,303
  10. Scifideity

    Scifideity Member

    Joined:
    Mar 24, 2016
    Messages:
    71
    Likes Received:
    15
    I'll give that one a try. Amazon claims it can be here tomorrow but I'll believe that when I see it on my front porch /LOL j

    Thanks
     
    mark tomlinson likes this.
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,477
    Likes Received:
    7,303
    Scifideity likes this.

Share This Page