1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Unanswered Smartscreen recognizes SD card on Startup and that's it

Discussion in 'Troubleshooting' started by woodpac9, Aug 1, 2020.

  1. woodpac9

    woodpac9 New Member

    Joined:
    Aug 1, 2020
    Messages:
    2
    Likes Received:
    0
    I am using the smart screen controller on my Robo R1 plus it recognizes it and then when I go to try to use the options to start print in the next screen tells me no SD card installed I have already switched the LCD screen out with another one that is brand new and I get the same problem thank you for your time and your help any help would be appreciated
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,446
    Likes Received:
    7,187
    Well do you have an SD card installed in the LCD with a sliced (GCODE) file on there for it to print?

    Oh, it also needs the GCODE FILE to NOT be using a long filename -- it needs to be in the 8.3 format (XXXXXXXX.GC or something similar, all uppercase).
     
  3. woodpac9

    woodpac9 New Member

    Joined:
    Aug 1, 2020
    Messages:
    2
    Likes Received:
    0
    Yes I have always printed my files with the SD card into the smartscreen holder I have five printer set up this way and have never had this problem
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,446
    Likes Received:
    7,187
    Then the SD card reader is likely defective -- or the RAMPS board is. You need to confirm that the wiring to the RAMPS is correct, getting one of the cables reversed could cause this sort of issue.

    If you feel confident the LCD is good (perhaps swap it onto another printer that is working and verify it is good) then you need to look at replacing the RAMPS and/or Arduino.
     

Share This Page