1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Partially Solved Autolevel going through the bed

Discussion in 'Troubleshooting' started by Dan Ershen, Dec 6, 2016.

  1. Dan Ershen

    Dan Ershen New Member

    Joined:
    Jan 11, 2016
    Messages:
    22
    Likes Received:
    2
    I cracked my bed, and ended up replacing it with glass that is thicker than the original bed. Now, when my printer attempts to do the autolevel routine, it will go down on the z axis, hit the bed and engage the z axis stop switch, and then continue to go. If I didn't hit the emergency stop button on Simplify3d, the extruder would have went straight through the bed.

    What gives? I thought the whole point of auto level was so that it wouldn't do this?
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    20,959
    Likes Received:
    6,982
    One or both of the Z home switches are not working (out of position, stuck open, stuck closed, wire disconnected, etc.)
    .
    Look at them closely and if they are correctly mounted/positioned then trace the wires back tot he RAMPS and make sure they are not disconnected. When the extruder hits the bed the X crossbar will start to raise, at that point one (or eventually both) of the Z switches will (or should) open to tell the arduino that the Z is 'homed'.

    Autoleveling failure is always an issue with the Z switches in some form or another.
     
    Geof likes this.
  3. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,551
    Likes Received:
    2,258
    yep them switches are a real booger sometimes. if you need a 2nd set of eyes on them upload a few clear pictures of how they are sitting.
     
  4. Rigmarol

    Rigmarol Well-Known Member

    Joined:
    May 14, 2016
    Messages:
    544
    Likes Received:
    280
    I am begining to have issues with my z switches too. While I am awaiting parts I found that if I manually "jiggle" the cross bar up and down a few times rapidly to work the switches my auto level then starts working correctly again.

    My issue is the opposite, the nozzle doesn't go all the way down on one or two points until I do the "jiggle" thing. I'm sure in my case new switches will fix it.
     
    mark tomlinson likes this.
  5. Dan Ershen

    Dan Ershen New Member

    Joined:
    Jan 11, 2016
    Messages:
    22
    Likes Received:
    2
    Ended up sorta solving it by going to the machine settings in Simplify3d and raising the z in that.

    Still having issues with the extruder being slightly too far from the bed while printing now.
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    20,959
    Likes Received:
    6,982
    That is not the best approach. If you are certain the Z home switches are correctly positioned then the M565 command in the startup GCode script is the correct way to set the offset.
     

Share This Page