1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

can not install octoprint plugins

Discussion in 'Troubleshooting' started by supercazzola, Nov 18, 2020.

  1. supercazzola

    supercazzola Active Member

    Joined:
    Jun 1, 2017
    Messages:
    396
    Likes Received:
    105
    I got a new SD image from Robo, and went to the Settings tab, Plugin Manager, clicked Get More, searched for "telegram" and tried to install that plugin. All appears to go well, up until the end where I get this pop up:

    Something went wrong

    Installing the plugin from URL "unknown" failed: Could not parse output from pip

    Any ideas on a fix ? I really need this plugin to work (it did on my old SD card).

    Here is what is displayed in the status window:

    Code:
    Installing plugin "OctoPrint-Telegram" from https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip...
    /home/pi/oprint/bin/python -m pip install https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip
    Collecting https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip
    Using cached https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip
    Requirement already satisfied (use --upgrade to upgrade): OctoPrint-Telegram==1.6.2 from https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip in /home/pi/oprint/lib/python2.7/site-packages
    Requirement already satisfied: OctoPrint in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pillow in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Login<0.3,>=0.2.2 in /home/pi/oprint/lib/python2.7/site-packages/Flask_Login-0.2.11-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Babel<0.10,>=0.9 in /home/pi/oprint/lib/python2.7/site-packages/Flask_Babel-0.9-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: scandir<1.4,>=1.3 in /home/pi/oprint/lib/python2.7/site-packages/scandir-1.3-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Assets<0.11,>=0.10 in /home/pi/oprint/lib/python2.7/site-packages/Flask_Assets-0.10-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: feedparser<5.3,>=5.2.1 in /home/pi/oprint/lib/python2.7/site-packages/feedparser-5.2.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: rsa<3.3,>=3.2 in /home/pi/oprint/lib/python2.7/site-packages/rsa-3.2.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: PyYAML<3.11,>=3.10 in /home/pi/oprint/lib/python2.7/site-packages/PyYAML-3.10-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: flask<0.11,>=0.9 in /home/pi/oprint/lib/python2.7/site-packages/Flask-0.10.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: tornado==4.0.2 in /home/pi/oprint/lib/python2.7/site-packages/tornado-4.0.2-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: sarge<0.2,>=0.1.4 in /home/pi/oprint/lib/python2.7/site-packages/sarge-0.1.4-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pkginfo<1.3,>=1.2.1 in /home/pi/oprint/lib/python2.7/site-packages/pkginfo-1.2.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: netifaces<0.11,>=0.10 in /home/pi/oprint/lib/python2.7/site-packages/netifaces-0.10.6-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Jinja2<2.9,>=2.8 in /home/pi/oprint/lib/python2.7/site-packages/Jinja2-2.8.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: chainmap<1.1,>=1.0.2 in /home/pi/oprint/lib/python2.7/site-packages/chainmap-1.0.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: sockjs-tornado<1.1,>=1.0.2 in /home/pi/oprint/lib/python2.7/site-packages/sockjs_tornado-1.0.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: future<0.16,>=0.15 in /home/pi/oprint/lib/python2.7/site-packages/future-0.15.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: psutil<3.3,>=3.2.1 in /home/pi/oprint/lib/python2.7/site-packages/psutil-3.2.2-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pyserial<2.8,>=2.7 in /home/pi/oprint/lib/python2.7/site-packages/pyserial-2.7-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: werkzeug<0.9,>=0.8.3 in /home/pi/oprint/lib/python2.7/site-packages/Werkzeug-0.8.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Principal<0.4,>=0.3.5 in /home/pi/oprint/lib/python2.7/site-packages/Flask_Principal-0.3.5-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: watchdog<0.9,>=0.8.3 in /home/pi/oprint/lib/python2.7/site-packages/watchdog-0.8.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Click<6.3,>=6.2 in /home/pi/oprint/lib/python2.7/site-packages/click-6.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pylru<1.1,>=1.0.9 in /home/pi/oprint/lib/python2.7/site-packages/pylru-1.0.9-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: netaddr<0.8,>=0.7.17 in /home/pi/oprint/lib/python2.7/site-packages/netaddr-0.7.19-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: requests<2.8,>=2.7 in /home/pi/oprint/lib/python2.7/site-packages/requests-2.7.0-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: markdown<2.7,>=2.6.4 in /home/pi/oprint/lib/python2.7/site-packages/Markdown-2.6.11-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: awesome-slugify<1.7,>=1.6.5 in /home/pi/oprint/lib/python2.7/site-packages/awesome_slugify-1.6.5-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: semantic-version<2.5,>=2.4.2 in /home/pi/oprint/lib/python2.7/site-packages/semantic_version-2.4.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Babel>=1.0 in /home/pi/oprint/lib/python2.7/site-packages/Babel-2.5.3-py2.7.egg (from Flask-Babel<0.10,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: speaklater>=1.2 in /home/pi/oprint/lib/python2.7/site-packages/speaklater-1.3-py2.7.egg (from Flask-Babel<0.10,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: webassets>=0.10 in /home/pi/oprint/lib/python2.7/site-packages/webassets-0.12.1-py2.7.egg (from Flask-Assets<0.11,>=0.10->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pyasn1>=0.1.3 in /home/pi/oprint/lib/python2.7/site-packages/pyasn1-0.4.2-py2.7.egg (from rsa<3.3,>=3.2->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: itsdangerous>=0.21 in /home/pi/oprint/lib/python2.7/site-packages/itsdangerous-0.24-py2.7.egg (from flask<0.11,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: certifi in /home/pi/oprint/lib/python2.7/site-packages/certifi-2018.1.18-py2.7.egg (from tornado==4.0.2->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: backports.ssl_match_hostname in /home/pi/oprint/lib/python2.7/site-packages/backports.ssl_match_hostname-3.5.0.1-py2.7.egg (from tornado==4.0.2->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: MarkupSafe in /home/pi/oprint/lib/python2.7/site-packages/MarkupSafe-1.0-py2.7-linux-armv7l.egg (from Jinja2<2.9,>=2.8->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: blinker in /home/pi/oprint/lib/python2.7/site-packages/blinker-1.4-py2.7.egg (from Flask-Principal<0.4,>=0.3.5->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: argh>=0.24.1 in /home/pi/oprint/lib/python2.7/site-packages/argh-0.26.2-py2.7.egg (from watchdog<0.9,>=0.8.3->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pathtools>=0.1.1 in /home/pi/oprint/lib/python2.7/site-packages/pathtools-0.1.2-py2.7.egg (from watchdog<0.9,>=0.8.3->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: regex in /home/pi/oprint/lib/python2.7/site-packages/regex-2018.2.21-py2.7-linux-armv7l.egg (from awesome-slugify<1.7,>=1.6.5->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Unidecode<0.05,>=0.04.14 in /home/pi/oprint/lib/python2.7/site-packages/Unidecode-0.4.21-py2.7.egg (from awesome-slugify<1.7,>=1.6.5->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pytz>=0a in /home/pi/oprint/lib/python2.7/site-packages/pytz-2018.3-py2.7.egg (from Babel>=1.0->Flask-Babel<0.10,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    You are using pip version 9.0.1, however version 20.2.4 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    Done!
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,716
    Likes Received:
    7,241
  3. supercazzola

    supercazzola Active Member

    Joined:
    Jun 1, 2017
    Messages:
    396
    Likes Received:
    105
    Thanks Mark, but it seems like it does the same thing, not not throw the error. It doesn't appear on the list of plugins, even after restart octoprint / reboot R2.




    Code:
    pi@husky-hubbard:~ $ source ./oprint/bin/activate
    
    (oprint) pi@husky-hubbard:~ $ sudo pip --disable-pip-version-check install https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip --no-cache-dir
    
    
    Usage:  
    
      pip <command> [options]
    
    
    no such option: --disable-pip-version-check
    
    (oprint) pi@husky-hubbard:~ $ man pip
    Code:
    (oprint) pi@husky-hubbard:~ $ /home/pi/oprint/bin/python -m pip --disable-pip-version-check install https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip --no-cache-dir
    Collecting https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip
      Downloading https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip
         | 440kB 5.7MB/s
      Requirement already satisfied (use --upgrade to upgrade): OctoPrint-Telegram==1.6.2 from https://github.com/fabianonline/OctoPrint-Telegram/archive/master.zip in ./oprint/lib/python2.7/site-packages
    Requirement already satisfied: OctoPrint in ./oprint/lib/python2.7/site-packages (from OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pillow in ./oprint/lib/python2.7/site-packages (from OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Login<0.3,>=0.2.2 in ./oprint/lib/python2.7/site-packages/Flask_Login-0.2.11-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Babel<0.10,>=0.9 in ./oprint/lib/python2.7/site-packages/Flask_Babel-0.9-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: scandir<1.4,>=1.3 in ./oprint/lib/python2.7/site-packages/scandir-1.3-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Assets<0.11,>=0.10 in ./oprint/lib/python2.7/site-packages/Flask_Assets-0.10-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: feedparser<5.3,>=5.2.1 in ./oprint/lib/python2.7/site-packages/feedparser-5.2.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: rsa<3.3,>=3.2 in ./oprint/lib/python2.7/site-packages/rsa-3.2.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: PyYAML<3.11,>=3.10 in ./oprint/lib/python2.7/site-packages/PyYAML-3.10-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: flask<0.11,>=0.9 in ./oprint/lib/python2.7/site-packages/Flask-0.10.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: tornado==4.0.2 in ./oprint/lib/python2.7/site-packages/tornado-4.0.2-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: sarge<0.2,>=0.1.4 in ./oprint/lib/python2.7/site-packages/sarge-0.1.4-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pkginfo<1.3,>=1.2.1 in ./oprint/lib/python2.7/site-packages/pkginfo-1.2.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: netifaces<0.11,>=0.10 in ./oprint/lib/python2.7/site-packages/netifaces-0.10.6-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Jinja2<2.9,>=2.8 in ./oprint/lib/python2.7/site-packages/Jinja2-2.8.1-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: chainmap<1.1,>=1.0.2 in ./oprint/lib/python2.7/site-packages/chainmap-1.0.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: sockjs-tornado<1.1,>=1.0.2 in ./oprint/lib/python2.7/site-packages/sockjs_tornado-1.0.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: future<0.16,>=0.15 in ./oprint/lib/python2.7/site-packages/future-0.15.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: psutil<3.3,>=3.2.1 in ./oprint/lib/python2.7/site-packages/psutil-3.2.2-py2.7-linux-armv7l.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pyserial<2.8,>=2.7 in ./oprint/lib/python2.7/site-packages/pyserial-2.7-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: werkzeug<0.9,>=0.8.3 in ./oprint/lib/python2.7/site-packages/Werkzeug-0.8.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Flask-Principal<0.4,>=0.3.5 in ./oprint/lib/python2.7/site-packages/Flask_Principal-0.3.5-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: watchdog<0.9,>=0.8.3 in ./oprint/lib/python2.7/site-packages/watchdog-0.8.3-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Click<6.3,>=6.2 in ./oprint/lib/python2.7/site-packages/click-6.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pylru<1.1,>=1.0.9 in ./oprint/lib/python2.7/site-packages/pylru-1.0.9-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: netaddr<0.8,>=0.7.17 in ./oprint/lib/python2.7/site-packages/netaddr-0.7.19-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: requests<2.8,>=2.7 in ./oprint/lib/python2.7/site-packages/requests-2.7.0-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: markdown<2.7,>=2.6.4 in ./oprint/lib/python2.7/site-packages/Markdown-2.6.11-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: awesome-slugify<1.7,>=1.6.5 in ./oprint/lib/python2.7/site-packages/awesome_slugify-1.6.5-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: semantic-version<2.5,>=2.4.2 in ./oprint/lib/python2.7/site-packages/semantic_version-2.4.2-py2.7.egg (from OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Babel>=1.0 in ./oprint/lib/python2.7/site-packages/Babel-2.5.3-py2.7.egg (from Flask-Babel<0.10,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: speaklater>=1.2 in ./oprint/lib/python2.7/site-packages/speaklater-1.3-py2.7.egg (from Flask-Babel<0.10,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: webassets>=0.10 in ./oprint/lib/python2.7/site-packages/webassets-0.12.1-py2.7.egg (from Flask-Assets<0.11,>=0.10->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pyasn1>=0.1.3 in ./oprint/lib/python2.7/site-packages/pyasn1-0.4.2-py2.7.egg (from rsa<3.3,>=3.2->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: itsdangerous>=0.21 in ./oprint/lib/python2.7/site-packages/itsdangerous-0.24-py2.7.egg (from flask<0.11,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: certifi in ./oprint/lib/python2.7/site-packages/certifi-2018.1.18-py2.7.egg (from tornado==4.0.2->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: backports.ssl_match_hostname in ./oprint/lib/python2.7/site-packages/backports.ssl_match_hostname-3.5.0.1-py2.7.egg (from tornado==4.0.2->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: MarkupSafe in ./oprint/lib/python2.7/site-packages/MarkupSafe-1.0-py2.7-linux-armv7l.egg (from Jinja2<2.9,>=2.8->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: blinker in ./oprint/lib/python2.7/site-packages/blinker-1.4-py2.7.egg (from Flask-Principal<0.4,>=0.3.5->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: argh>=0.24.1 in ./oprint/lib/python2.7/site-packages/argh-0.26.2-py2.7.egg (from watchdog<0.9,>=0.8.3->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pathtools>=0.1.1 in ./oprint/lib/python2.7/site-packages/pathtools-0.1.2-py2.7.egg (from watchdog<0.9,>=0.8.3->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: regex in ./oprint/lib/python2.7/site-packages/regex-2018.2.21-py2.7-linux-armv7l.egg (from awesome-slugify<1.7,>=1.6.5->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: Unidecode<0.05,>=0.04.14 in ./oprint/lib/python2.7/site-packages/Unidecode-0.4.21-py2.7.egg (from awesome-slugify<1.7,>=1.6.5->OctoPrint->OctoPrint-Telegram==1.6.2)
    Requirement already satisfied: pytz>=0a in ./oprint/lib/python2.7/site-packages/pytz-2018.3-py2.7.egg (from Babel>=1.0->Flask-Babel<0.10,>=0.9->OctoPrint->OctoPrint-Telegram==1.6.2)
    (oprint) pi@husky-hubbard:~ $ 
     
  4. supercazzola

    supercazzola Active Member

    Joined:
    Jun 1, 2017
    Messages:
    396
    Likes Received:
    105
    tkoco and mark tomlinson like this.

Share This Page