1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Enabling SSH

Discussion in 'General Questions' started by Jerome Helbert, Aug 21, 2018.

  1. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,141
    Likes Received:
    6,998
    That is odd, because I have had mine out of the case and hooked up via HDMI and it works as expected (actually boots to a Pi desktop). It is starting to sound like your image is hosed. I have sent you the details on mine.
     
  2. Jerome Helbert

    Joined:
    Aug 19, 2017
    Messages:
    35
    Likes Received:
    13
    I would agree except I see this same behavior both with the sd card I have been running since I got the machine, as well as with a factory fresh image I just requested from Robo on Monday.

    When you say it boots to a Pi desktop... is that running with the standard C2/R2 image? Don't they use HDMI to display to the LCD, shouldn't you see the RoboLCD stuff there?
     
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,141
    Likes Received:
    6,998
    Well, let me rephrase that ... the C2 doesn't really use the HDMI :)
    It has a different LCD that is connected via the I/O headers. However you can do this (which I have done as well)

    If you can putty into the Pi you can enable VNC server and then run the VNC clients to get a desktop.

    Since you can't get onto the Pi at all that severely limits what you can do here.
     
  4. Jerome Helbert

    Joined:
    Aug 19, 2017
    Messages:
    35
    Likes Received:
    13
    Ah, when I unplug the HDMI, The LCD no longer functions. I wonder if they are pulling power from it?
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,141
    Likes Received:
    6,998
    They may be, the C2 LCD gets power via the I/O bus pins. It is also a smaller (3.5") display. SunFounder makes them :) cheap enough even for the larger ones (which we have used on the BarBot among other things).
     
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,806
    Likes Received:
    3,521
    Let me jump in here with a small comment, when you diff the Raspbian Lite with the Robo image you will probably see too many differences to wade through. I am pretty sure Robo built their image on full Raspbian. It isn't even a current version, if you take their image when you eventually get SSH and then perform an update using apt-get you will see that every single piece is several versions behind the current distro and the kernel is even older too.
     
  7. supercazzola

    supercazzola Active Member

    Joined:
    Jun 1, 2017
    Messages:
    369
    Likes Received:
    97
  8. Jerome Helbert

    Joined:
    Aug 19, 2017
    Messages:
    35
    Likes Received:
    13
    Ding Ding Ding, we have a winner! Oh man do I feel like a dunce.

    I just originally assumed the ssh disabling was a Raspberry Pi based thing and kept trying to enable it in Raspberry Pi ways. It never occurred to me that Robo would put it right on the printers webpage...

    Thanks for all the help everyone provided helping me get to this working
     
  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,141
    Likes Received:
    6,998
    It still IS a pi thing since that is where that code runs :) However it is nice that they have a ui for it in OctoPi
    That is far easier than burrowing into the bowels of raspbian.
     
  10. Jerome Helbert

    Joined:
    Aug 19, 2017
    Messages:
    35
    Likes Received:
    13
    The problem I had is that it's being disabled by something running on top of raspbian, so all of the solutions to make ssh work in raspbian would't work.

    Interestingly, the first boot after enabling the Remote Access Mode showed a raspbian login screen instead of the Robo Splash screen before jumping into the RoboLCD menu. Subsequent boots didn't have it and booted normally
     
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,141
    Likes Received:
    6,998
    I have noticed it do that if I change drivers or other boot time things with the Pi.
    The thing disable/enabling it is probably an OctoPi plugin (just a guess).
     
  12. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,806
    Likes Received:
    3,521
    When I get home I am going to have to look at raspi-config to see if SSH is listed as enabled or disabled there when you toggle that setting. I am not sure it is something added by Robo, they have done very little work changing OctoPrint other than placing a theme on it. That setting might totally be an OctoPrint thing.
     
  13. Frank van Gilluwe

    Joined:
    Sep 27, 2017
    Messages:
    47
    Likes Received:
    21
    Ran into the same problems - thanks for being at the forefront! Now SSH working. Never would have figured it out on my own!
     
    mark tomlinson likes this.

Share This Page