1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

OctoPrint: 1.4.0-rc6

Discussion in 'Software' started by Lance Weston, May 5, 2020.

  1. Lance Weston

    Lance Weston Active Member

    Joined:
    Jun 2, 2018
    Messages:
    317
    Likes Received:
    131
    OctoPrint: 1.4.0-rc6 is the Octoprint version I am using. Is it the latest?
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,716
    Likes Received:
    7,241
  3. supercazzola

    supercazzola Active Member

    Joined:
    Jun 1, 2017
    Messages:
    396
    Likes Received:
    105
    1.4.2 seems to be out. Is there a way to upgrade to it without breaking anything in stock R2? some of the newer plugins don't work in 1.4.0-rc6
     
  4. Lance Weston

    Lance Weston Active Member

    Joined:
    Jun 2, 2018
    Messages:
    317
    Likes Received:
    131
    Sounds like something you can test for all of us. Just make a backup of the sd card then do the update and let us know.
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,716
    Likes Received:
    7,241
    I'll save you the trouble and tell you the answer -- no. Not entirely will everything work :)
    The plugin for the LCD will be no-workable if you upgrade OctoPrint or Raspbian really since it relies on an older version of the one of the libraries for the LCD software.
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,716
    Likes Received:
    7,241
    Now some folks have just replaced the OctoPi image provided by Robo with their own more current one and are using a different non-Robo-specific LCD menu plugin.
     

Share This Page