1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

R2 Not showing files on flash drive

Discussion in 'Troubleshooting' started by Matthew P, Feb 12, 2020.

  1. Matthew P

    Matthew P New Member

    Joined:
    Feb 11, 2020
    Messages:
    4
    Likes Received:
    1
    I am coming up with two different issues. One that I tried to resolve that causes the other.

    I have a 60gb flash drive that I have loaded with gcode files and plugged into the front of the R2. When I do that, it will show that it's detecting the drive and show the list of files but upon selecting any of them the unit freezes and will not proceed further. I have to forcibly shut it down when this happens.

    So I tried partitioning the flash drive so that there's a 8gb smaller partition but it won't see either partition when I do this or sometimes/somehow it will show ONE of the files on the drive. For testing purposes I created a folder FROM the R2 screen on to what it thought it mounted and I cannot find that folder on the flash drive for the life of me.

    Any help would be appreciated, thanks.
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,981
    Likes Received:
    7,116
    If it is formatted as a single 60gb drive it is too large.

    The drive has to be FAT32 format and 32GB is the cap.

    Just use a smaller one formatted FAT32 for its entire capacity.

    This is a limitation of the Arduino... not specific to the Robo. Almost all printers use FAT32 for the SD card format.

    You might try using the https://www.sdcard.org/downloads/formatter/ (for mac or windows)

    more details here: https://forum.arduino.cc/index.php?topic=357127.0


    Cards above 64 GB are formatted to exFAT file system and that will not work with the printer (any formatted larger than 32GB are probably formatted exFAT also, but it is moot since it is too large of a filesystem for the ATmega2560 8-bit MCU). I am amazed that in any instance it works at all, the hang is almost certainly because the file selected pints to a sector number that is overflowing the ATMega MaxInteger size :) -- note: Even though the CPU has 8-bits internal registers the hardware can address a MAXINT of -32,768 to 32,767... which is far less than the number of sectors on that drive...
     
    #2 mark tomlinson, Feb 13, 2020
    Last edited: Feb 13, 2020
  3. tkoco

    tkoco - -.- --- -.-. ---
    Staff Member

    Joined:
    May 7, 2018
    Messages:
    504
    Likes Received:
    193
    @mark tomlinson is correct. Due to hardware limitations, 32Gb is the largest sized SDcard or USB drive supported. A work-around is to partition the USB drive into 2 ( or more ) smaller partitions and format each one as a FAT32 partition.
     

Share This Page