1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved Cura, C2 and Linux: A beginner's journey

Discussion in 'Software' started by tkoco, May 9, 2018.

  1. tkoco

    tkoco Administrator
    Staff Member

    Joined:
    May 7, 2018
    Messages:
    213
    Likes Received:
    105
    The version of Cura provided by the Robo team is tailored for Windows (no surprise here). So my journey started on the Ultimaker website with a download of the Linux version of Cura. In my home directory, I created a new directory and called it Cura (of course). I moved "Cura-3.3.1.AppImage" from Downloads directory to Cura directory and then enabled the execution permissions. A double-click and Cura came up running.

    So, now Cura had to be updated with the Robo C2 information. On a whim, I clicked the MAC OS download listed on the Robo website. The needed information is listed there. Skipping Step 1, I followed the rest of the steps (2 - 7). So now, Cura is up and running for my new Robo C2 printer on Linux!

    At Step 4, you will need to download and unzip the C2 profiles. I used the new directory "Cura" as the holding area for the zipfile and its contents.

    In Step 5, you will need to drill down into the directory holding the actual profiles. "Cura/Cura 2.3 Robo C2 Profiles/Quality". As mentioned, you will need to import each profile, one at a time.

    In Step 7, you will need to drill down into the Material directory for the file to import.

    Lastly, The Optional step of "Add the Octoprint plugin to a Robo printer using Cura 2.5" can be skipped. Instead, go to Cura, click on Plugins, then Browse plugins, and then select / install the Octoprint connection.

    As a matter of note, I use Linux Mint 18.3

    (written on the 9th of May 2018)
     
    #1 tkoco, May 9, 2018
    Last edited: May 20, 2018
    Geof and mark tomlinson like this.
  2. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,581
    Likes Received:
    2,269
    Thanks @tkoco ! Very useful info for anyone using a linux set up!
     
  3. tkoco

    tkoco Administrator
    Staff Member

    Joined:
    May 7, 2018
    Messages:
    213
    Likes Received:
    105
    Update: I was trying to figure out why the Robo PLA material import was not showing up in Cura. The answer is found in the printer settings. (This setting is never mentioned in the MAC OS instructions).

    The FIX:

    Open Cura, click on Preferences, then Configure Cura.
    Select Printers from the left side list.
    On the new page, click on Machine Settings.
    Select the Extruder 1 tab and change the Compatible Material .... from the default of 2.85 to 1.75
    Close & Close

    Click on the drop down menu of Material on the main screen. Robo PLA should now be visible.

    (written 20 May 2018)
     
    WheresWaldo and mark tomlinson like this.

Share This Page