1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

How To: Cura 15.04 Setup

Discussion in 'Software' started by Mike Kelly, Jan 9, 2015.

  1. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    Anyone want to walk me through setting the first layer height in Cura. I am slightly too high and the bed leveling thing wants me to use screws to set my height.
     
  2. Mike Glass

    Mike Glass Active Member

    Joined:
    Dec 29, 2014
    Messages:
    268
    Likes Received:
    123
    G1 Z-0.5 is what I'm using.
     
  3. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Yup reduce your offset if you're too high with 1.0
     
  4. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    I went all the way to 0 and it was pretty much the same. Can I go lower? if so how "-1.0" ?
     
  5. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Z1.0 would make it negative.

    Just to be sure your nozzle is touching the bed? In the cura terminal what response codes are you seeing
     
  6. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    Do I need these and if not how can I turn them off?
     

    Attached Files:

  7. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Nope you don't need them. I use it to make sure my nozzle is primed and ready. Put a ; in front of it to comment it, or just delete it.
     
  8. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    I just tried 10 and Z10 and I saw no change? I must be doing it wrong.

    What do you need video ? the gcode? my first born?

    Thanks by the way.
     
  9. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Video of it running through the auto leveling as well as the response values in the terminal window

    Edit: Also your starting G-code
     
  10. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    OK so here is what I have.




    < echo:Unknown command: ""
    < echo:Active Extruder: 0
    < echo:Unknown command: "53"
    < Bed x: 15.00 y: 20.00 z: 0.49
    < Bed x: 107.00 y: 20.00 z: 0.17
    < Bed x: 199.00 y: 20.00 z: -0.29
    < Bed x: 200.00 y: 130.00 z: -0.50
    < Bed x: 108.00 y: 130.00 z: 0.10
    < Bed x: 16.00 y: 130.00 z: 0.46
    < Bed x: 15.00 y: 240.00 z: 0.67
    < Bed x: 107.00 y: 240.00 z: 0.31
    < Bed x: 199.00 y: 240.00 z: -0.37
    < Eqn coefficients: a: -0.01 b: 0.00 d: 0.61
    < planeNormal x: 0.01 y: -0.00 z: 1.00
    < echo:endstops hit: Z:-0.37
    < Error:No Line Number with checksum, Last Line: 17
     

    Attached Files:

  11. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Hmm that seems fine to me. Can I see your startup G-code?
     
  12. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    ;Sliced at: {day} {date} {time}
    ;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
    ;Print time: {print_time}
    ;Filament used: {filament_amount}m {filament_weight}g
    ;Filament cost: {filament_cost}
    ;M190 S{print_bed_temperature} ;Uncomment to add your own bed temperature line
    ;M109 S{print_temperature} ;Uncomment to add your own temperature line
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 ;X0 Y0 ;move X/Y to min endstops
    ;G28 Z0 ;move Z to min endstops
    M565 Z-1.0 ; Define Z offset at Z1.0mm
    G29 ;Run auto-level
    G1 Z15.0 F{travel_speed} ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    ;G1 F200 E3 ;extrude 3mm of feed stock
    ;G92 E0 ;zero the extruded length again
    G1 F{travel_speed}
    ;Put printing message on LCD screen
    M117 Printing...
     
  13. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Hmm let's try commenting out the G1 Z15.0. You said you tried M565 Z-0.5?
     
  14. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    This is what I have tried. Am I messing with the wrong line? All the different colours were the same line just edited differently

    ;Sliced at: {day} {date} {time}
    ;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
    ;Print time: {print_time}
    ;Filament used: {filament_amount}m {filament_weight}g
    ;Filament cost: {filament_cost}
    ;M190 S{print_bed_temperature} ;Uncomment to add your own bed temperature line
    ;M109 S{print_temperature} ;Uncomment to add your own temperature line
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 ;X0 Y0 ;move X/Y to min endstops
    ;G28 Z0 ;move Z to min endstops
    M565 Z-1.0 ; Define Z offset at Z1.0mm M565 Z-1.0 ; Define Z offset at 1.0mm M565 Z-1.0 ; Define Z offset at Z10.0mm M565 Z-1.0 ; Define Z offset at 10.0mm <=4 diffrent ways.
    G29 ;Run auto-level
    G1 Z15.0 F{travel_speed} ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    ;G1 F200 E3 ;extrude 3mm of feed stock
    ;G92 E0 ;zero the extruded length again
    G1 F{travel_speed}
    ;Put printing message on LCD screen
    M117 Printing...
     
  15. Robert Choban

    Robert Choban Active Member

    Joined:
    Aug 22, 2014
    Messages:
    279
    Likes Received:
    27
    Mike I have a few question about speed settings in cura. These are what I current have, should I change these to something else?
    Travel 150.0
    Bottom layer 20
    Infill 0
    outer shell 0
    inter shell 0
     
  16. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Green means it's commented out. So you've actually tried it 0 different ways. Anything after a ; is ignored

    You need to change the value after M565 to be Z-0.5 or something
    If you want I guess? I don't bother.
     
  17. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    Oh, ya see I was changing the wrong part. Thanks I will give that a go
     
  18. k1e1v1i1n

    k1e1v1i1n Active Member

    Joined:
    Dec 11, 2014
    Messages:
    230
    Likes Received:
    73
    OMG I have so much control. I don't have to get it close, I can get it perfect!

    I have been printing and reprinting the 5mm steps first layer over and over trying to get it just right.

    Z-1.0 nope
    Z-.50 nope
    Z-.75 nope
    Z-.60 nope
    Z-.55 nope
    Z-.57 hell yes

    Now I need to figure out how to set the jerk speed.
     
  19. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    Jerk is a feature in the firmware. How come you're looking to change it?
     
  20. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,360
    Likes Received:
    7,168

    Just a reminder:

    programmers.jpg
     

Share This Page