1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Marlin Firmware Upgrade 1.1.0 RC8 & RCBugFix (For R1 & R1+PLUS)

Discussion in 'Mods and Upgrades' started by WheresWaldo, Jun 11, 2015.

Thread Status:
Not open for further replies.
  1. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Here are the files for Marlin 1.1.0 RCBugFix as of January 1, 2017. I have separated them out into several compressed archive files. Just download the one you need and extract the appropriate files within the Marlin source subdirectory. You cannot use configuration files from previous Marlin releases or from previous Release Candidates. These archives contain the complete source modified as noted. This version and future versions of Marlin must be compiled on Arduino IDE 1.6.8 or newer.

    Basic steps required:
    1. Download one of the attached files appropriate for your hardware
      RC8_ABL_R1_01-01 for Robo R1 with 8 mm Z Axis threaded rods
      RC8_ABL_PLUS_01-01 for Robo R1+PLUS and R1's upgraded with the Z-Axis lead screw upgrade kit from Robo3D
      RC8_ABL_TR8_01-01 for Robo R1's with upgraded Z Axis 3rd party lead screws
    2. Compile and upload to your Arduino 2540 board using the Arduino IDE. Compilation has been tested with Arduino IDE version 1.6.13 and 1.8.0.
    3. After successful upload, clear EEPROM memory by issuing the following two commands in terminal mode:
      M502
      M500
    4. Re-enter you Z axis offset using M851 as a positive number. M565 support is not supported in this version
    Common to all these files are:
    1. Set up for Hexagon hotend
    2. Full Graphics LCD enabled
    3. EEPROM memory enabled
    4. Automatic Bed Leveling enabled w/16 probe points (4 x 4 grid)
    5. BILINEAR bed leveling enabled as default
    6. Major performance improvement for Graphical LCDs
    7. Some other stuff
    New - FADE control allows you to compensate for bed unevenness over a longer range of Z heights. By default, all corrections are made in layer one. To enable this you must issue a M420 Zn.nn code either in a terminal window or added to the beginning of your startup script. Value n.nn is the number of millimeters you would like the FADE to occur in.

    New - The LCD now features a more streamlined small font and a big font for single line items. If you LCD exhibits screen corruption as a result of the sped up code, change line # 500 in Configuration_adv.h to a value of 10. This function will work on most LCD screens with a value as low as 5 uS which can speed up the screen writes significantly. The full speedup (using 5 uS screen delay) can save as much as 300,000 CPU cycles.

    New - With the proper wiring you can now control RGB LEDs direct from your printer using the M150 code. Requires that #define RGB_LED be enabled (Configuration.h line # 1388) and the LED is attached to pins 34, 43, 35 by default. (This feature is currently disabled)

    Please note that I am not one of the Marlin developers. If you have an issue with this release post here first. If it is determined that it is not a configuration issue, then you may be directed to post the issue on Marlin's GITHUB. I cannot guarantee success using beta firmware, I can vouch for error free compiling with these included files. If there are issues with the configuration let me know and we can work on them together. Original post (#1) edited to provide a link to RC8 and current RCBugFix files.
     
    #961 WheresWaldo, Jan 3, 2017
    Last edited: Jan 9, 2017
    Alan Childs and anngeelow81 like this.
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Notes:

    Everyone, I stopped doing archives for the old 5/16" threaded rod version, the line is still in Configuration.h if you still have that printer and want to use this newer Marlin version.

    As a result of the different lead screws if you are using MESH you cannot use an adjustment of 0.025 mm for every variation. It will result in using fractional steps which is physically and electrically impossible. So the following adjustment distances are used
    • 8 mm Threaded Rods the adjustment is 0.025 mm which requires 4 micro-steps
    • Plus Lead Screws the adjustment is 0.02 mm which requires 2 micro-steps
    • TR8-8 Lead Screws the adjustment is 0.04 mm which requires 1 micro-step
    @danzca6 Filament change is not enabled in this new version and I am not sure it actually works post RC8, if I am reading the issues and current pull requests correctly.
     
  3. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,077
    I will have to verify this tonight. It would be a shame not to have this feature.
     
  4. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I think M600 is broken too, or maybe that is only what is broken.
     
  5. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I got some RGB LEDs today in the mail, going to play with the lights in the Robo with RCBugFix
    20170103_161602.jpg 20170103_161707.jpg
     
    Geof likes this.
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Been monitoring Marlin's GITHUB and there have been no new commits since 12/30/2016. I believe the contributors are taking a needed break. On a side note, I will be switching compilation verification to only Arduino IDE 1.8.0. That is the new unified version of the IDE. I retroactively tested the latest versions and compilation works with no errors.
     
  7. mcsams

    mcsams New Member

    Joined:
    Feb 17, 2016
    Messages:
    11
    Likes Received:
    2
    @WheresWaldo I just uploaded RCBF_MESH_PLUS_01-01 and started to do Mesh Leveling. The problem I'm having is Mesh Leveling hangs after hitting the X-axis switch when it starts the Home XYZ routine.

    I did an Auto Home and that worked fine.

    Any thoughts?

    Thanks.
     
  8. anngeelow81

    anngeelow81 Member

    Joined:
    May 20, 2016
    Messages:
    41
    Likes Received:
    9
    I have that issue too. Doesn't move and sticks on the xyz screen with mesh.
     
  9. mcsams

    mcsams New Member

    Joined:
    Feb 17, 2016
    Messages:
    11
    Likes Received:
    2
    @WheresWaldo I reverted back to your December 7th release RC8_MESH_PLUS (I very much appreciate what you do for the forum BTW) and did not have any issues with the Mesh Leveling routine. The Home XYZ worked fine.

    I went through the code and could not identify anything obvious that would cause the issue.

    Would this be a potential "bug" to report?

    Thanks
     
  10. Steven Stowell

    Steven Stowell New Member

    Joined:
    Dec 29, 2014
    Messages:
    15
    Likes Received:
    2
    Had the same problem. I reverted back to an older build as well.
     
  11. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I will double check, I think there may be an issue that has been reported already, I know RC8 works, but I haven't touched my printer since New Years so I can't tell you if I am having the same problem.

    I found several bug reports related to MESH being hung up. there is even one patch to try to fix it, but it does not seem to solve the problem. This was discussed as late as yesterday on Marlin's GITHUB. I am going to pull the current RCBugFix and not post anything for January 15th until the contributors get a handle on this.
     
    Sonny's Robo3D and Geof like this.
  12. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I won't be doing a release of Robo configuration files for RCBugFix for mid-January. There is an apparent bug in the MESH leveling section of code and a pull request claiming to fix it. Until that pull request is merged into the code, it is of little use to release files. If others are experiencing issues with MESH leveling just hanging then I suggest you report them to the GIT maintainers as it may push them to merge in the code sooner rather than later. Just do a search on open issues in the RCBugFix branch on their Git repository.

    I am not sure exactly what everyone is seeing but this is the latest open issue (https://github.com/MarlinFirmware/Marlin/issues/5616) with the MESH routines, if your experience is similar, then add your voice to that thread.
     
  13. Lary

    Lary New Member

    Joined:
    Dec 23, 2016
    Messages:
    15
    Likes Received:
    4
    I just upgraded to the new firmware and the RepRap Full Graphic Smart Controller but the SD Card doesn't work. I have read that you need to change the configuration.h to #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER and also #define SDSUPPORT. I changed those but it gives me the message that the SD card is inserted but can't read the card. Do you have any ideas on how to make this work? I have seen various items but figured someone here would know for sure.
     
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,668
    Likes Received:
    7,316
    How are you trying to read the card?
     
  15. Lary

    Lary New Member

    Joined:
    Dec 23, 2016
    Messages:
    15
    Likes Received:
    4
    I inserted it into the slot of the graphic display and want to print a .gcode file but it doesn't show any files. It shows that the SD Card was inserted then when you go to the main menu it says No SD Card. Like I mentioned I have seen some articles but they seem not work.
     
  16. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,668
    Likes Received:
    7,316
    Reformat the SD card then try a short filename 8.3
    Like MYFILE.GCO
     
  17. Lary

    Lary New Member

    Joined:
    Dec 23, 2016
    Messages:
    15
    Likes Received:
    4
    Didn't work either.
     
  18. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @Lary,

    In message # 973 you said,
    There should be no reason to change those in this firmware. Are you sure you are using Marlin 1.1.0 or are you using Robo supplied firmware? Every version I have posted here already has the Full Graphics Smart LCD and SD support enabled.
     
  19. Lary

    Lary New Member

    Joined:
    Dec 23, 2016
    Messages:
    15
    Likes Received:
    4
    The one that you supplied. Maybe I should reload yours again and see if that fixes it. They were in your post of December 6th since that is the latest link I can find. You reference newer ones but I don't see the links.
     
  20. Lary

    Lary New Member

    Joined:
    Dec 23, 2016
    Messages:
    15
    Likes Received:
    4
    When the Robo 3D r1+ boots up the screen says: RoboR1 Plus ABL ready. That is the correct one? It still has the same issue. It looks like you may have a newer version that doesn't have a link: RC8_ABL_PLUS_01-01 where can I find that file?
     
    #980 Lary, Jan 19, 2017
    Last edited: Jan 19, 2017
Thread Status:
Not open for further replies.

Share This Page