1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved New C2 - Connection Interrupted error and New Image won't work!

Discussion in 'Troubleshooting' started by BenJoeM, May 25, 2018.

Thread Status:
Not open for further replies.
  1. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    New C2 arrived this week as a warranty replacement. Fired it up and it is said "connection interrupted error". So I followed the troubleshooting guide and had no luck. I contacted tech support and they sent me a new image to burn. I burned the new image they sent to a new SD Card to be safe and the new image when I put in the SD Card immediately wants to go into Updating mode and sits there updating and never finishes. I never get to the home screen at any point.

    If put the original image I am back with the Connection Interrupt Error.

    Tech Support said maybe the image was corrupted so they resent it and so I downloaded again, burned it again, and BANG! Same exact problem as before.

    Any thoughts? My last thought is to try a different image all together and see if that solves it.

    Quick update, installed a different Image - Same Updating Robo Screen, no change.
     
    #1 BenJoeM, May 25, 2018
    Last edited: May 25, 2018
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    If the first new image didn't help another will not either.
    It is probably either the USB cable loose/bad between the pi and the controller board or a bad controller board.
     
    Geof likes this.
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    That error means that the rPi failed to talk with the controller board.
    Once you know that it becomes a lot more obvious :)
     
  4. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    Correct, I have tested all the cables with no luck. Still same issue. New Image has the exact same result on my older C2 that has a z-offset issue and is being sent back for warranty
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    Sounds like a bad controller then.
     
  6. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    Does that mean they need to send a new printer?
     
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    Your call. If you feel up to it you can probably swap the board yourself. I have some disassembly photos in a thread I did. It is not real hard just be careful.
     
    Geof likes this.
  8. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    Well at this point Robo has told me to go to hell. So I am stuck with two dead C2s. Most likely will try to sell them for parts at this point.
     
  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    @Jerry RoBo 3D

    Let's loop in Robo corporate and get an opinion :)

    In reality, yes. If the cable is good between the Pi and the controller board and you still get that error with a valid SD card image in the Pi it can only be the board and it is not user serviceable (could you replace it? Sure, but tearing these apart to reach the guts on the C2 is difficult.
     
  10. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    This is why I am attempting to get Actual Robo folks looped in, I really doubt that is the answer. If it is out of warranty (which would be the worst case) they should still be willing to service them.
     
  11. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    This is my second C2. My first one worked for a week, but I live in central America so getting them to send parts and get it fixed took forever. Due to my travel schedule, it was hard to sit down and just figure out how to replace the entire ribbon cable, etc. So they finally sent me a new one since by the time we got it half working it was out of warranty. Tech support told me I was screwed. But someone stepped in and helped me and sent me this one. The new one arrived and it 100% does not work with this error. So I am positive they want to send me a new one. But I have not sent the old one back waiting to see if this one even works. The shipping label they sent to send it back is for USA, not my Central America Country. I was told I need to foot the bill and all tech support is now cut off until they have the new printer in hands.

    So I have two bad printers, Some guy named Dan is telling me they will do nothing until I fork out the cash to send their broken printers back to them that I didn't break. Sorry, not dealing with this. I have already started a complaint with the BBB and plan to push on this. At this point would prefer my money back. I have done everything asked of me except send back the printer because I want to know if the printers will even work.
     
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    Ah, I suspect that is @Dan here on the forum. He is one involved in that side of things.
    I can see them wanting to get the one returned, they are at this point out a printer :) You meanwhile are also out the printer (technically two).

    I also get the deal with international shipping, it is a non-trivial cost if you have to foot it for repairs.

    They probably should make an arrangement to cover shipping outside of CONUS since they certainly want to do business there.

    Lets see what corporate has to say if we can get their attention here.

    I don't see how you are going to get any real progress on this unless you are willing to return printers to them for diagnosis and/or repairs. If you want to see that it works for you, fine, but it is clearly not working and will need some attention to get it there.
     
    #12 mark tomlinson, Jun 4, 2018
    Last edited: Jun 4, 2018
    Geof likes this.
  13. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    I am quoting to ship it tomorrow to see what the cost. Just surprised st the candor of the company to make this right.
     
  14. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    Lots of dirty laundry in the air here, I reached out with a link to this thread so Jerry can step in (I know Mark tagged him as well). I'm uncomfortable speaking about the buisness end of things, but I'm certain the machine can be made to work if needed. I'll keep eyes on this post and if it comes to trouble shooting I'll jump back in
     
    BenJoeM and mark tomlinson like this.
  15. Jerry RoBo 3D

    Jerry RoBo 3D Administrator
    Staff Member

    Joined:
    Oct 28, 2013
    Messages:
    139
    Likes Received:
    126
    @BenJoeM There can often be issues with updates in far away places. Is it possible to run the update again while you have the printer connected directly with an ethernet cable? Can you connect the unit directly to your router or modem?
     
    BenJoeM, Geof and mark tomlinson like this.
  16. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    I can connect it directly.

    I will make a short video to show what is happening for clearer understanding.

    am
     
  17. Jerry RoBo 3D

    Jerry RoBo 3D Administrator
    Staff Member

    Joined:
    Oct 28, 2013
    Messages:
    139
    Likes Received:
    126
  18. BenJoeM

    BenJoeM Member

    Joined:
    Feb 12, 2018
    Messages:
    39
    Likes Received:
    8
    @Jerry RoBo 3D

    Video 1 - Original Image that was sent with the printer, this gets the reset error and wants me to update. - I plugged it directly into my ethernet and let it sit for 3 hours, it does not go beyond the updating screen at any time. This is the original reason I am posting and contacted tech support with this printer (which is a warranty replacement for the last printer that did not work for over 9 months) https://drive.google.com/file/d/1zn89VgJ_KJmv7TH2navSu05bcJhstpj-/view?usp=sharing

    Video 2 - I was sent a new updated version of the image twice, and also two other images. All of them have the exact same result as this one, It does not recognize the error but 100% goes immediately to the update screen. I also left this on with ethernet for 30 minutes with no change. This one I am positive is not the same image as my printer since the robo screen turns red, but it was what was sent, but the results are 100% the same with every image emailed to me: https://drive.google.com/file/d/1Jkh0Q93YJwLP1KilN3y_YND7j0q9BpWU/view?usp=sharing
     
    Geof and mark tomlinson like this.
  19. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,712
    Likes Received:
    2,320
    That 2nd one has a Red Screen---- Red is R2..... Blue is C2. That is very concerning to me. Can you take the SD card out of your Blue Screen one and put it in your 2nd ones raspberry pi? Curious if the 2nd one has an R2 image holding you up.
     
    BenJoeM and mark tomlinson like this.
  20. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,570
    Likes Received:
    7,229
    I did not know that :)
     
    BenJoeM likes this.
Thread Status:
Not open for further replies.

Share This Page