1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

R1 non-plus Marlin 2.0.x Bugfix UBL

Discussion in 'Projects' started by eisman, Jan 27, 2019.

  1. eisman

    eisman New Member

    Joined:
    Jan 25, 2019
    Messages:
    5
    Likes Received:
    2
    Got Marlin 2 working on my R1, and trying to use UBL. After I clear EEPROM and do G29 P1 my mesh looks like this:

    Code:
    Recv: Bed Topography Report:
    Recv:
    Recv:     (  1,235)                                      (219,235)
    Recv:         0       1       2       3       4       5       6
    Recv:  6 | +26.940  +26.940  +29.297  +27.571  +24.133  +23.391  +23.391
    Recv:    |
    Recv:  5 | +16.848  +16.848  +18.586  +21.021  +21.204  +22.410  +23.616
    Recv:    |
    Recv:  4 | +6.755  +6.755  +7.875  +14.471  +18.275  +21.429  +24.583
    Recv:    |
    Recv:  3 | +0.522  +0.113  -0.295  +4.304  +9.896  +19.060  +28.224
    Recv:    |
    Recv:  2 | +0.293  -0.050  -0.392  +1.274  +8.469  +12.223  +15.976
    Recv:    |
    Recv:  1 | +0.160  -0.147  -0.454  -0.741  +3.847  +10.863  +17.879
    Recv:    |
    Recv:  0 |[+0.160] -0.147  -0.454  -0.741  +3.847  +10.863  +17.879
    Recv:         0       1       2       3       4       5       6
    Recv:     (  1,  1)                                      (219,  1)
    
    This obviously is not representative of a flat piece of glass. Any Ideas?

    Hereis my config:

    Code:
    Send: M503
    Recv: echo:  G21    ; Units in mm (mm)
    Recv: echo:  M149 C ; Units in Celsius
    Recv:
    Recv: echo:Filament settings: Disabled
    Recv: echo:  M200 D1.75
    Recv: echo:  M200 D0
    Recv: echo:Steps per unit:
    Recv: echo:  M92 X80.00 Y80.00 Z2560.00 E723.38
    Recv: echo:Maximum feedrates (units/s):
    Recv: echo:  M203 X500.00 Y500.00 Z50.00 E25.00
    Recv: echo:Maximum Acceleration (units/s2):
    Recv: echo:  M201 X900.00 Y900.00 Z100.00 E10000.00
    Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv: echo:  M204 P1300.00 R3000.00 T3000.00
    Recv: echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv: echo:  M205 B20000.00 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
    Recv: echo:Home offset:
    Recv: echo:  M206 X0.00 Y0.00 Z0.00
    Recv: echo:Unified Bed Leveling:
    Recv: echo:  M420 S1 Z10.00
    Recv:
    Recv: Unified Bed Leveling System v1.01 active.
    Recv:
    Recv: Active Mesh Slot: 1
    Recv: EEPROM can hold 16 meshes.
    Recv:
    Recv: echo:Material heatup parameters:
    Recv: echo:  M145 S0 H190 B60 F255
    Recv: echo:  M145 S1 H240 B110 F0
    Recv: echo:PID settings:
    Recv: echo:  M301 P37.44 I3.34 D105.05
    Recv: echo:  M304 P193.56 I38.11 D245.77
    Recv: echo:Z-Probe Offset (mm):
    Recv: echo:  M851 Z0.00
    Recv: echo:Filament load/unload lengths:
    Recv: echo:  M603 L0.00 U100.00
    
     
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,806
    Likes Received:
    3,521
    Make sure you are as mechanically level as possible first, then you may need to run the leveling routine multiple times. I am still on 1.1.9 but I had to level then print the test pattern, then manually adjust some of the points. I even think I had to set probe offsets so it did not try to probe off the back of the bed. It has been so long since I created my bed maps (I have 2 beds and they are saved in two different eeprom slots).
     

Share This Page