1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved What should G29 make the printer do?

Discussion in 'Troubleshooting' started by DGGT6, Sep 15, 2019.

Thread Status:
Not open for further replies.
  1. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Hello.
    Firstly, many thanks to the regulars here for helping with solutions over the past years. Your info has been invaluable to me (and many others) in getting our Robos running well.
    You have helped me upgrade my Beta through to a "Plus" with 8mm threaded rods and Marlin 1.8.9.
    I have also added screws under the magnets in the 4 corners of the bed so I can get a nice fine adjustment but now I want to try and use a bed leveling system to hopefully eliminate the unevenness of the glass.
    For some reason I have never been able to get my Robo to do any sort of auto level.
    My start script is,
    G28
    M565 Z-1
    G29
    M92 E792.67 etc etc.
    Even typing in G29 in the Comms window of Simplify3D does nothing.

    UBL is "uncommented" in Marlin (no //) as are all the other leveling options.

    I didn't want to go to a separate sensor like a BL Touch but perhaps I may have to.

    Any thought on how to get my Robo to Auto Bed Compensate?.

    Many thanks,
    Doug
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    You need to look at your code there and compare it to the UBL documentation.
    I think you will see a problem.

    I don't personally use UBL (I use ABL -- what came stock with the older version of Marlin)

    http://marlinfw.org/docs/gcode/G029-ubl.html

    (you also need to terminate GCode commands with a semi-colon ";" just as the examples in the docs do)
     
  3. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Thanks Mark, but I am afraid I have no idea what I am looking at on that link.
    I thought G29 was all you needed to type to get the Robo to do its dance, that is all that was in the Symplify3D scripts when I selected Robo R1 in Sim3D.
    That site says.....
    G29 ; execute ABL my actual script says...... G29 ; run auto-level
    What am I missing?

    ABL will be fine, I just want compensate for a "wavy" piece of glass (9 point grid?). I have the 4 corners setup really well, but there are some sections that are too close to the nozzle and some that are too far away for a good 1st layer.

    Cheers,
    Doug
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    You specifically called out UBL (Unified Bed leveling: http://marlinfw.org/docs/gcode/G029-ubl.html) which is not the default and is not supported by the stock version of the firmware, so I assumed you were more familiar with the firmware itself.
    The G29 will NOT cause the autoleveling dance until after the G28; Note this is G28 and G29 -- NOT g28 or g29 :) Marlin is letter case-sensitive so make sure you have it correct.
     
    #4 mark tomlinson, Sep 16, 2019
    Last edited: Sep 16, 2019
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    Get the exact version of Marlin that you are using too ... just to make sure we are all on the same page.
     
  6. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Hello Mark,
    My Arduino program says I am using Marlin 1.8.9.
    My scripts in S3D all have capital Gs.
    I mentioned UBL and all the other types of bed leveling do not have the // in front of them.
    Should only one type (ABL BiLinear) be available and all the others commented out?(//)

    Thanks,
    Doug
     
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    post your configuration.h
     
  8. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Hi Mark,
    here we go, config.h.

    Many thanks,
    Doug
     

    Attached Files:

  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    Make sure your startup script is semi-colon delimited :

    G28;
    M565 Z-1;
    G29;


    rather than :

    G28
    M565 Z-1
    G29


    Still looking through the configuration.h
     
  10. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    Also post the link to the version of Marlin you are using (where you downloaded it)
     
  11. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Hi Mark,
    here is my exact starting script which starts with the "default codes" from S3D.
    G28 ; home all axes

    M565 Z-1 ; set the offset for auto-leveling mechanism

    G29 ; run auto-level

    M92 E792.67

    G92 E0

    G1 Z1.4 F500

    G1 Y10 X10 F500.0

    G1 X40 E9 F500.0

    G1 X130 E30 F500

    G92 E0

    G1 Z5 F5000 ; lift Z by 5mm

    I can't be positive where I downloaded Marlin from but I thought it was from this forum. My download folder has these 2 files..... Robo3dR1-119bugfix & Marlin-bugfix-1.1.9.
    Is the 1.8.9 the version of the Arduino program rather than the Marlin Version?? (Silly me!)

    Cheers,
    Doug
     
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    Those are not official Robo firmware releases. Those were done by other members here in the forum and you will need to find the thread you downloaded those from and post there regarding issues/questions.

    I still run stock firmware versions on all of the Robo printers I have. They have customizations in the configuration.h for various things, but all of the R1 series are on stock firmware and so is the C2 :)

    I can't offer you any real support on that version since I didn't switch to it, but there are probably a number who did.
    Probably you used this thread: http://community.robo3d.com/index.php?threads/marlin-1-1-9-release-for-robo-r1.22329/

    I think @WheresWaldo has migrated to that version on a printer.
     
  13. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    One major change with later (version 1.1.x) Marlin releases was that they deprecated the entire use of M565 so your Z offset for the autoleveling would be ignored in that release and the entire process for doing autoleveling is new and different :)

    There are other (often better) options available in that release (i.e. you are not stuck with bilinear ABL, you can use UBL and MESH leveling as other options). I manually level all of my printers and the ABL that I have enabled on some of them is really more of an affectation since they are already as mechanically leveled (trammed if you are more familiar with CNC terminology) as they can get.
     
  14. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Many thanks for trying to help Mark. You have been do this for a long time and your answers to other questions over the years have helped me enormously as I get started in this new field of "magic"!
    I will pop my questions over to the 1.1.9 thread.
    One thing I have noticed that in my printer code was a line that said UBL was inactive. See attached photo.

    Thanks again Mark
     

    Attached Files:

  15. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    Did you create the mesh?
    There is some talk here : https://reprap.org/forum/read.php?415,689515

    The Documentation is over here -- you need to follow the UBL startup guide if you want to enable it.
    http://marlinfw.org/docs/features/unified_bed_leveling.html

    I personally do not use it so I am not your best reference :)

    I use ABL (BiLinear) on a couple of machines, but all have been manually leveled so most I use no ABL at all.

    @WheresWaldo might have some feedback on UBL -- not sure. I do recall someone on here using it so you may want to start a thread on that under projects.

    Someone else did post a thread here: http://community.robo3d.com/index.php?threads/struggling-with-ubl.18378/
    and here: http://community.robo3d.com/index.php?threads/r1-non-plus-marlin-2-0-x-bugfix-ubl.22981/
    and one here in the R2 section (but how you use UBL would not be printer specific): http://community.robo3d.com/index.p...rlin-1-1-9-ubl-extras-work-in-progress.22457/
     
  16. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Thanks Mark,
    I haven't altered/edited anything in the 1.1.9. I saw there was comments from ROBO & BH and assumed it was "pre-set" for Robo R1 printers.
    Have had a look at some of the links you posted and noticed a Gcode to initiate UBL

    A Activate Activate the Unified Bed Leveling system. (i.e., M420 S1)

    Perhaps this is all I need to do to switch it on?...... G29 A;
    I will pop over to the UBL thread and post.
    Thanks again.
     
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,338
    Likes Received:
    7,035
    If the version you are using (the Marlin version) supports UBL then it is the process they documented:

    1. Setup the UBL parameters in Configuration.h and Configuration_adv.h. (yours may be done -- no clue)
    2. Perform automated probing.
    3. Perform additional manual probing, if needed.
    4. Fill in un-probed points in the mesh
    5. Run the test print utility.
    6. Fine tune the matrix.
    7. Repeat steps 5 and 6 until satisfied.
    Done. At that point you use G29 Lnn or M420 Lnn (where "nn" is the mesh number).
     
  18. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    I have SUCCESS!!!
    G29 A; was all I needed to initiate UBL!!!!!!!!!!!!!!!!!!!!!!!
    I was then able to send the code to get it to probe the bed using the nozzle.
    However, when I went to print the test mesh, the nozzle was too close to the bed ie touching.
    I think this is because of the ROBO method of Z homing.
    As my Robo zeros the z height it pushes the bed down and of course it does this across the entire bed.
    I presume this is why I need to have a 1.4mm Z offset in my Global GCode Offsets in S3D?
    There has been a bit of talk about Z offsets and UBL not working together but I have not found a solution (or one I can understand) yet.
    I will be posting this question in a 1.1.9 thread soon unless I can figure it out.
    Thanks again for pointing me in the right direction.

    Cheers,
    Doug
     
    mark tomlinson likes this.
  19. DGGT6

    DGGT6 New Member

    Joined:
    Apr 11, 2019
    Messages:
    10
    Likes Received:
    2
    Well I think you have done it again Mark. Problem solved!
    I got Robo to dance all across the floor/bed!
    She started printing the mesh verification out too high off the bed but I entered M851 Z0 and she printed on the bed nicely.
    Thanks again for your patience and persistence with me and all the other members on this forum.

    Cheers,
    Doug
     
    mark tomlinson likes this.
Thread Status:
Not open for further replies.

Share This Page