1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Solved Z axis height is off

Discussion in 'Troubleshooting' started by Drew Appling, Mar 2, 2015.

  1. bubbletron

    bubbletron New Member

    Joined:
    Mar 2, 2015
    Messages:
    11
    Likes Received:
    1
    Not to bring this up from the dead but I am having the same issue once I installed the XXL controller. The only reason I am commenting now is because it seems all of the links are broken. If anyone has a current one it would be greatly appreciated. Thanks
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    What links?


    The only link I see in this thread of value is for the firmware download.
    You can get there from the main robo page (HOME button -- top left link) but I'll save you the four clicks:

    http://guide.robo3d.com/Wiki/ROBO_3D_Firmware_Release_Notes
     
  3. bubbletron

    bubbletron New Member

    Joined:
    Mar 2, 2015
    Messages:
    11
    Likes Received:
    1
    Oh oops! I fixed mine already in the XXL lcd controller.. I thought the first link took you straight to the download or something. Every time I clicked it, it said the page wasn't found. Thanks for that though!
     
    mark tomlinson likes this.
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    It is confusing since they have (twice) updated to new forum software and the old links are in various states of dead :)
     
    Geof and bubbletron like this.
  5. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I currently have 2 R1+plus printers, I have flashed the firmware from the Robo site for the R1+, but my zsteps show 800 on both machines. I have the XXL screens on both of them, and they read ROBOR1PLUSV2. What should the zsteps be? X=80 Y=80 Z=800.
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    800 is correct for the R1+

    #define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,800,723.38} // default steps per unit for RoBo 3D R1+ (X, Y, Z, E)
     
  7. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    And where's Waldo said I should change the esteps to 820, so that's what I did. But still getting under extrusion even now in Cura 15.04.

    Sent from my Galaxy S7 using Tapatalk
     
  8. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    ?
    What do Z steps have to do with under extrusion?

    eSteps -- yes, Z steps? no
     
  9. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I'm just trying to weed out the settings. What is supposed to be there and not.

    Sent from my Galaxy S7 using Tapatalk
     
  10. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    All I have found in forums is z steps are either 2267 or 2250. The 800 threw me

    Sent from my Galaxy S7 using Tapatalk
     
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    Those are numbers for the beta and r1, not the plus.
    The C2 and R2 are different as well :)

    This is why you must make sure you are using the correct firmware configuration before reloading it. You also (on the R1+) need to flush the flash eprom or no changes to the firmware will take effect. (EEPROM is enabled in the R1+)
     
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    ==== EEPROM GCodes ====

    M500 Store current settings in EEPROM for the next startup or M501.
    M501 Read all parameters from EEPROM. (Or, undo changes.)
    M502 Reset current settings to defaults, as set in Configurations.h. (Follow with M500 to reset the EEPROM too.)
    So after firmware is fixed you need the M502 and an M500 at some point for them to work.
     
  13. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    That's great, but there is hardly any settings, shown for the R1+

    Sent from my Galaxy S7 using Tapatalk
     
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    There is only the difference in the Z steps/mm between any of the R1 series machines. That is it. Nothing else.

    Well, the beta did NOT have autoleveling if you count that far back :)
     
  15. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Right I was already told all that, and have I have flashed the firmware AND used the M500, M502 codes. I have done everything but replace the nozzles. I don't believe it to be a hardware problem, as I have 2 R1+ printers, that started under extruding after I calibrated the extruders, flashed the firmware and used the M500 and M502 codes

    Sent from my Galaxy S7 using Tapatalk
     
  16. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I understand everyone's inpatients with me, but I've only been printing a year and not a coder, or mess with the settings alot

    Sent from my Galaxy S7 using Tapatalk
     
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    If you have changed the Z steps then you have not calibrated the extruder.
    E steps is the extruder. Set the value, reload firmware and then do the M502 and an M500
     
  18. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    I have not changed the zsteps, it shows 800 and that's what I left it on until I heard from this forum as to whether or not it is correct. I measured 120mm of filament, then extruded 100mm, the difference was divided by what I told to extract, then multiplied by the actual. I came up with 950 for the esteps.


    Sent from my Galaxy S7 using Tapatalk
     
  19. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,553
    Likes Received:
    7,226
    So did you reset the eSteps, reload the firmware and do the M502 and an M500?
     
  20. aznhlfan

    aznhlfan Active Member

    Joined:
    Sep 19, 2015
    Messages:
    383
    Likes Received:
    59
    Yes, with the Arduino IDM I thinks it's called, in the configuration h.

    Sent from my Galaxy S7 using Tapatalk
     

Share This Page