1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Chimera Upgrade Guide (WIP)

Discussion in 'Mods and Upgrades' started by jtn7040, Aug 13, 2015.

  1. jtn7040

    jtn7040 Active Member

    Joined:
    Jun 13, 2015
    Messages:
    251
    Likes Received:
    32
    This is just a basic walk through on how I upgraded one of my Robo3d's with the Chimera Upgrade. It is actually very simple so don't feel intimidated at all.

    First thing's first you're going to want to print out ALL the parts that you need before you upgrade!


    Extruder (i've had success with both of the below)
    http://www.thingiverse.com/thing:933829
    http://www.thingiverse.com/thing:275593

    New X-Carriage and fan ducts

    http://www.thingiverse.com/thing:671881

    This cable management clip is a very good idea to have. It saved me a lot of headaches when running G29 Autolevel

    http://www.thingiverse.com/thing:844879/#files

    Now the things you need to buy... (and the links/stores i purchased them from)


    Cyclops and Chimera Hotend (purchased from PrintedSolid)

    http://printedsolid.com/collections...s/products/e3d-dual-extrusion-chimera-cyclops

    Additional heatbreak (just incase)

    http://printedsolid.com/collections/accessories-and-upgrades/products/e3d-v6-replacement-parts

    2 MK8 Drive Gears (for extruders [but check what you need for the extruder of you choice])
    http://www.amazon.com/gp/product/B00THZK97I?psc=1&redirect=true&ref_=oh_aui_detailpage_o09_s00

    RRD Fan extender

    http://www.amazon.com/gp/product/B00GHE3456?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00

    2 Nema17 motors (You can use Geared motors if you like i just printed geared extruders to save money)

    http://www.amazon.com/gp/product/B00PNEQI7W?psc=1&redirect=true&ref_=oh_aui_detailpage_o02_s00

    Stepper Driver
    http://www.amazon.com/gp/product/B00E8BVTRA?psc=1&redirect=true&ref_=oh_aui_detailpage_o03_s00

    Stepper Driver Heat sink (Not really needed however it makes me feel better)

    http://www.amazon.com/gp/product/B007XACV8O?psc=1&redirect=true&ref_=oh_aui_detailpage_o01_s00

    Assembling your Chimera
    (See http://wiki.e3d-online.com/wiki/Cyclops_&_Chimera_Documentation for detailed instructions on how to build up the hotend)

    [Picture of assembled hotend and X-Carriage]

    My X-Carriage was printed out of ESUN PETG at 90% infill and 3 Top/Bottom layers with 1 perimeter layer (the first was printed from PLA and the second ABS; I had the most success with the PETG)
    These settings made it easy to press in the linear bearings into place.

    The cold end fan is wired directly into existing cold end fan connector.

    The two print cooling fans can be wired in parallel
    [Picture of Cooling fan wiring]

    RAMPS Board Wiring

    Extruder 1(T0) is to be plugged into D10
    Extruder 2 (T1) is to be plugged into D09
    Heated bed is to be plugged into D08
    (polarity does not matter for the above)

    Thermistor
    Extruder 1 should be plugged into T0
    Extruder 2 should be plugged into T2
    Heated bed into T1
    (polarity does not matter for the above)

    Wiring Diagram used for RAMPS

    http://reprap.org/mediawiki/images/thumb/6/6d/Rampswire14.svg/600px-Rampswire14.svg.png

    The RRD Fan extender is plugged into the Servo expansion slot on the RAMPS board and is powered from the 12V supply line that powers the cooling fan attached to the base of the printer. (You will connect that fan directly into the 12V supply leads)

    [Picture of RRD installed]

    Firmware Changes [Chimera and Cyclops]

    Download the latest firmware from the Robo3d website and open it using the Arduino.cc editor

    In configuration.h
    Motherboard identifier must be changed to 34. (In the Stock firmware it is 33)
    Below that change Extruders from 1 to 2

    Search for Temp_Sensor_

    Change Temp_Sensor_0 and Temp_Sensor_1 to 5 [Unless you are not using the Thermistors that came with your Chimera/Cyclops]

    Pins.h

    Fan pin (IO Buffer) is to be changed to 6
    NOTE: this is only if you purchased the exact same RRD Extender that I linked too!

    Cyclops Only Firmware Changes

    Configuration.h
    search for Extruder_Offset and uncomment Extruder_Offset_X and Extruder_Offset_Y
    Set both of these values to 0

    Pins.h

    Temp_1_Pin must be changed from 15 to 13

    Chimera Only Firmware Changes

    Configuration.h

    search for Extruder_Offset and uncomment Extruder_Offset_X and Extruder_Offset_Y
    The Y to -18 (If you have T0 as the extruder towards the back of the printer)
    For now leave X offset set to 0 (we'll calibrate this later)


    I will attach my configuration.h and my pins.h files if you need to use them

    Calibrating X-Offset

    (continue here)

    I will finish up the post over the next week (i've had some family emergencies come up, however for all the people messaging me about this i'm hoping this will get you started. Sorry for the delays)
     
    #1 jtn7040, Aug 13, 2015
    Last edited: Aug 19, 2015
  2. Nickbrown17

    Nickbrown17 New Member

    Joined:
    Jul 25, 2015
    Messages:
    9
    Likes Received:
    0
    Hope the family is doing well, thanks for the guide.

    I'm planning on getting started on this in the next month or so. In preparation I bought a Nema17 directly from Robo so it matches the one on the stock machine. Can I use these 2 for my extruders, or do I need the 64oz ones you used?

    Can't wait to see the guide progress, thanks again.
     
  3. jtn7040

    jtn7040 Active Member

    Joined:
    Jun 13, 2015
    Messages:
    251
    Likes Received:
    32
    If you use the geared extruder that I linked too you should be fine with the stock robo ones however I've had issues printing bronzefill without high torque motors just a heads up

    Sent from my SM-N915T using Tapatalk
     
  4. Magic-Goat

    Magic-Goat Member

    Joined:
    Mar 4, 2014
    Messages:
    75
    Likes Received:
    10
    Hope you managed to sort out your family emergencies.

    This guide is great. I'm just finalizing my hybrid extruder design so this is extremely helpful :p

    Just a couple of things i got stuck on:

    There's two ' #define FAN_PIN' IO pins, one is set to 4 and the other set to 7. Which one do i change?

    Do you need to change the X offset? Both hot ends are opposite each other?


    Thanks for the help :)
     
  5. davidb

    davidb New Member

    Joined:
    Nov 18, 2015
    Messages:
    3
    Likes Received:
    0
    do you have any videos of this upgrade?
    did you have to replace the daughter board I read somewhere for the robo plus you had too??
     
  6. Mike Kelly

    Mike Kelly Volunteer

    Joined:
    Mar 11, 2013
    Messages:
    6,967
    Likes Received:
    2,275
    The R1 +Plus does need a new RAMPS 1.4 board as they modified it to remove E1's capabilities

    Older R1's do not need a new RAMPS 1.4 board but will need an additional stepper driver
     
  7. davidb

    davidb New Member

    Joined:
    Nov 18, 2015
    Messages:
    3
    Likes Received:
    0
    ok thank you
    I went with the e3d v6 with volcano eruption pack instead
     
    #7 davidb, Nov 29, 2015
    Last edited by a moderator: Feb 22, 2018
  8. Jason Bates

    Jason Bates New Member

    Joined:
    Jan 28, 2016
    Messages:
    7
    Likes Received:
    0
    I am trying to do this upgrade on my R1+ and have became stuck :( I installed the new ramps 1.4 board, and installed the new driver. The chimera hotends heat up correctly and read the temperate which is great. I cannot for the life of me get the extruder motors to do anything. I have tried switching out the cables, motors and drivers but that hasn't helped at all. Any guidance or troubleshooting tips would be amazing. I'm happy to post any pics or configurations files if that will help. Thank you in advance!
     
  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,117
    Likes Received:
    6,997
    So neither extruder works?
    Odd. The R1+ did have the E1 connector allocated to the second Z so I could see (maybe) the firmware not using it for a real extruder (E0 should work though).
     
  10. Jason Bates

    Jason Bates New Member

    Joined:
    Jan 28, 2016
    Messages:
    7
    Likes Received:
    0
    Yeah neither of them work

    Sent from my SM-G955U using Tapatalk
     
  11. RMoncello

    RMoncello New Member

    Joined:
    Jun 4, 2014
    Messages:
    9
    Likes Received:
    5
    Well, I know I'm a few years behind, but has anyone come up with a solution in this matter, I have upgraded all the hardware and replaced the RAMPS board, but all I can get it to do now is to move one of the extruders... Still cannot get the second one to move at all.
     
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,117
    Likes Received:
    6,997
    Did you replace Robos version of Marlin with a standard version that does not have the second extruder used for one of the Z axis?

    You will need to tweak configuration.h to match the hardware specifics for Robo of course (size, limit switches, etc) pretty much just use your old configuration.h
     
  13. RMoncello

    RMoncello New Member

    Joined:
    Jun 4, 2014
    Messages:
    9
    Likes Received:
    5
    I must be missing something (of course) I get all kinds of errors...

    Has anyone gotten the ROBO R1+ working with a Cyclops that I can take a look at your configuration file... any help would e greatly appreciated!!!
     
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,117
    Likes Received:
    6,997

Share This Page