1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

CommunityOS for Robo Printers (and others)

Discussion in 'Off Topic' started by WheresWaldo, Jun 3, 2019.

  1. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @JeffreyB Yeah Robo installed the screen upside-down so they had more room for the connector. Since Community OS was built for the Robo I focused on getting that orientation working.
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,422
    Likes Received:
    7,299
    Really interesting. I think they switched displays at some point -- I know the newer C2 units had HDMI (mine did not) and also on mine the

    lcd_rotate=2

    was enough to fix it.
     
  3. EmbraceNext

    EmbraceNext New Member

    Joined:
    Jun 23, 2018
    Messages:
    23
    Likes Received:
    5
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,422
    Likes Received:
    7,299
    @WheresWaldo can better comment, but I imagine it likely would -- with the caution noted below.
    The HDMI connected LCD screens tend to "just work" with less fiddling around with drivers.

    The touchscreen part is the bit that makes all of them problematic. If anything needs tweaking it is that since the video will normally "just work". There are so many variations out there, I stopped trying to test them all. Worst case they need a driver installed/configured (usually with a sudo apt-get install command).

    I know I have not tested this one...so go into it with open expectations.
     
  5. EmbraceNext

    EmbraceNext New Member

    Joined:
    Jun 23, 2018
    Messages:
    23
    Likes Received:
    5
    I will go ahead and give it a shot and play around. I have a question in looking through the config.h file. I know this is probably basic but I can't find it.

    Where do you define the printer that is being used? I found a bunch of if blocks. But I couldn't see where its set to a specific variable, especially the e3d selection:

    #define CUSTOM_MACHINE_NAME " Robo C2"
    #define DETAILED_BUILD_VERSION SHORT_BUILD_VERSION CUSTOM_MACHINE_NAME
    #endif
    #if RBV(R2_ED3V6)
    #define CUSTOM_MACHINE_NAME " Robo R2 with E3D V6"
    #define DETAILED_BUILD_VERSION SHORT_BUILD_VERSION CUSTOM_MACHINE_NAME
    #else
    #define CUSTOM_MACHINE_NAME " Robo R2"
    #define DETAILED_BUILD_VERSION SHORT_BUILD_VERSION CUSTOM_MACHINE_NAME
    #endif
    #if RBV(C2)
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,422
    Likes Received:
    7,299
    If that is the firmware on this image -- I have not looked at it. Not sure what version it is.
    If that is another version -- let me know exactly which one and I can take a look.
     
  7. EmbraceNext

    EmbraceNext New Member

    Joined:
    Jun 23, 2018
    Messages:
    23
    Likes Received:
    5
  8. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,422
    Likes Received:
    7,299
    Ah, yea I will let @WheresWaldo comment on that. I have not even looked at that version :)
     
  9. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Yes it will work with the capacitive screen provided you use the mods on the capacitive screen replacement thread. That is how I used it.

    @mark tomlinson the R2 has always had an HDMI screen and it is mounted upside down.

    PS - I had to go back and look at that version too. I haven't used it in quite a while.
     
  10. Kilrah

    Kilrah Well-Known Member

    Joined:
    Apr 18, 2017
    Messages:
    498
    Likes Received:
    332
    I will need to try this one day :)
     
  11. GPY

    GPY New Member

    Joined:
    Jul 14, 2021
    Messages:
    6
    Likes Received:
    0
    Trying to get a Robo R2 working with CommunityOs (can't boot with standard RoboOs 2.0) but I can't get past the Octoprint error of Code 43. i did the text editing as instructed. Really frustrating. What am doing wrong?
     
  12. GPY

    GPY New Member

    Joined:
    Jul 14, 2021
    Messages:
    6
    Likes Received:
    0
    I meant "Code 403".
     
  13. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,728
    Likes Received:
    2,328
    @GPY i don’t believe this is a supported thread any longer. Probably better off doing a Robo release
     
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,422
    Likes Received:
    7,299

Share This Page