1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Converting C2 into the FT-5

Discussion in 'Mods and Upgrades' started by colton81, Jun 5, 2017.

  1. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    also getting this in octoprint

    Code:
    Changing monitoring state from 'Connecting' to 'Operational'
    Send: N0 M110 N0*125
    Recv: echo:Unknown command: ""
    Recv: ok
    Send: N1 M115*39
    Recv: FIRMWARE_NAME:Marlin 1.1.2 (Github) SOURCE_CODE_URL:https://github.com/Robo3D/R2-Mini-Marlin/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Robo C2 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv: ok
    Send: M21
    Recv: ok
    Send: M115
    Recv: FIRMWARE_NAME:Marlin 1.1.2 (Github) SOURCE_CODE_URL:https://github.com/Robo3D/R2-Mini-Marlin/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Robo C2 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv: ok
    Send: M115
    Recv: FIRMWARE_NAME:Marlin 1.1.2 (Github) SOURCEError:MINTEMP triggered, system stopped! Heater_ID: 0
    Recv: Error:Printer halted. kill() called!
    Changing monitoring state from 'Operational' to 'Error: Printer halted. kill() called!
    '
     
  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,296
    Likes Received:
    7,024
    Yea, it sees :

    MINTEMP triggered, system stopped! Heater_ID: 0

    Which means it is not reading the thermistor for that heater (usually 0 is the 1st extruder heater).
     
  3. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    Yea thats what i was reading which i dont have anything else connected just the stepper motors so o guess i need to connect the thermistor. Im confused because it was working before i redid the config file and only had the motors connected
     
  4. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    still didnt work but this time i keep getting this

    Code:
    Connecting to: /dev/ttyACM0
    Changing monitoring state from 'Offline' to 'Opening serial port'
    Connected to: Serial<id=0x733ba6d0, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
    Changing monitoring state from 'Opening serial port' to 'Connecting'
    Send: N0 M110 N0*125
    Recv: �Np|$nH�JP.v��Z�za�J�onm+T=Dj�~�HMJ=<H^�^�{V�-�7��%i�g
    Recv: &�]+MBo6DV�P<��H3H6F�J�JJ�J�HJ�
    Recv: �=Y:&(/^7
    Recv: *'J�Z�!�
    Recv: �a�Jk�Z�x�:&�+^>H�$p|�%�%�%h%�8��k^>Y�NVV�>aHM�6�|4�%�J�AHJ�=HJP|@a�&��M/M6
    Recv: IM^+j�6L
    Recv: I�6Xokh�4�&�
    Recv: I�&n^L*I�&8nL*8�J�z"�Jj�J�(k�I�
    Recv: g
    Recv: �Mah$p|
    Recv: �I�j�IF�JV
    Recv: o��J�Z�jhQ5S�%��%�J�*6+X{6�Hnl�P<4�9J�J�X�
    Recv: �|F]L$p|��%��
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,296
    Likes Received:
    7,024
    wrong baud rate - you are getting garbled stuff
     
    Geof likes this.
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,811
    Likes Received:
    3,536
    Change the baud rate to 250000, Marlin firmware and OctoPrint default to this speed
     
    mark tomlinson and Geof like this.
  7. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    Thanks i didnt think to check octoprint so far now everything is working other then im going to have to change the steps per mm ill tell it to move 100mm and it moves 200+
     
  8. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
  9. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    Got all the electronics mounted on the C2 except for the hotend carriage still trying to figure out how im going to mount it. Need to fix the steps per mm and trying to figure out what the max voltage and amps the mainboard can take dont just want to plug in the heated bed and it end up blowing my board.
     
  10. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    So looks like the ft5 heated bed says its 19amps at 12V i think the amps are going to be to high for the C2 board but not sure
     
  11. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,581
    Likes Received:
    2,268
    Get a SSR and don't run it off the board ?
     
  12. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    On the ssr though how would i connect it because i technically dont have a psu to connect to directly?
     
  13. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,581
    Likes Received:
    2,268
    You would have to install a PSU to take the place of your PS
     
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,296
    Likes Received:
    7,024
    Yep. 19amps is too much for a RAMPS so I imagine it is too much for the unknown Robo electronics.
    You are far better off going with standard electronics where you know what it can do :)
     
    Geof likes this.
  15. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    Yea i dont want to risk anything ill probably wait on the heated bed untill i buy the duet
     
    Geof likes this.
  16. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    One thing i noticed is with the c2 carriage it has a ribbon wire anyway to get that wired up to a different board?
     
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,296
    Likes Received:
    7,024
    picture. Not sure which wire you are referring to
     
  18. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,296
    Likes Received:
    7,024
    If you mean the one from the main board to the extruder carriage, replacing that would be a pain.
     
    Geof likes this.
  19. colton81

    colton81 Active Member

    Joined:
    Feb 21, 2017
    Messages:
    328
    Likes Received:
    71
    yea scratch that lol well now im stuck but should be simple if i can figure it out maybe one of you know. my x end stop is on the opposite side of where the C2 originally had it so instead of it being X min it is now the X max but it still shows when triggered that is it X min. how do i change this? ive been looking in config.h and see i can invert the min and max but not sure if that will work
     
  20. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,296
    Likes Received:
    7,024
    You are going to need to make fundamental adjustments to the Marlin firmware. You can in Marlin configure MAX and or MIN triggers for each axis.

    Since you are doing something custom here you need to get really familiar with customizing the firmware too.
     

Share This Page