1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Community Favorite Marlin 1.1.9 Release for Robo R1+

Discussion in 'Mods and Upgrades' started by Bradf80, Sep 12, 2018.

  1. 3dfun4me

    3dfun4me New Member

    Joined:
    Aug 13, 2018
    Messages:
    15
    Likes Received:
    1
    M851 by itself is just querying the z height from eeprom for your terminal to see, try M851 Z.08 to actually set z height.

    After that, I got nuthin'.



     
  2. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    yea i have it set in the eerom i watch it in the terminal pull it with the value and its correct
     
  3. 3dfun4me

    3dfun4me New Member

    Joined:
    Aug 13, 2018
    Messages:
    15
    Likes Received:
    1
    How high from the bed does it print?

     
  4. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    it will print with the end stops fully extended on the glass
    i suspect it has to do with
    #define Z_PROBE_OFFSET_FROM_EXTRUDER 0
    forcing the print to use that value instead of the one in the eeprom about to test
     
  5. 3dfun4me

    3dfun4me New Member

    Joined:
    Aug 13, 2018
    Messages:
    15
    Likes Received:
    1
    This is not a problem that I have had. I wonder if setting the number to something different would help. Not sure if that number should be positive or negative.

     
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,818
    Likes Received:
    3,539
    @slider240sx
    Just out of curiosity what does M119 report?
     
  7. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    i was about to start a print with the old firmware give me 5min to upload the new firmware back to it
     
  8. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    Send: M119
    Recv: Reporting endstop status
    Recv: x_min: open
    Recv: y_min: TRIGGEREDRecv: z_min: open
    z is off the bed when i took that
    i was looking into the endstops being inverted in the config, but its the same as my old firmware settings(aside from the one that isnt in the old firmware)
     
  9. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,818
    Likes Received:
    3,539
    I see you mention Z was off the bed.
    Where was the extruder when you did this, because Y was triggered for some reason.
    The results tell me that it was off the X switch but it must have been all the way rearward.
     
  10. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    sorry i was exhausted last night, i re did the m119 with all axis sitting on their end stops
    Send: M119
    Recv: Reporting endstop status
    Recv: x_min: TRIGGERED
    Recv: y_min: TRIGGERED
    Recv: z_min: TRIGGERED
    Recv: ok
    g29 p6 doesnt help either, i want to post my m502 here before i start making other changes or revert
    =====
    Send: M501
    Recv: echo:V55 stored settings retrieved (655 bytes; crc 53326)
    Recv: Unified Bed Leveling System v1.01 active.
    Recv: Recv: Unified Bed Leveling initialized.
    Recv:
    Recv: Mesh loaded from slot 1
    Recv: Mesh 1 loaded from storage.
    Recv: echo: G21 ; (mm)
    Recv: echo: M149 C ; Units in CelsiusRecv:
    Recv: echo:Filament settings: Disabled
    Recv: echo: M200 D1.75Recv: echo: M200 D0
    Recv: echo:Steps per unit:
    Recv: echo: M92 X80.00 Y80.00 Z800.00 E800.00
    Recv: echo:Maximum feedrates (units/s):
    Recv: echo: M203 X500.00 Y500.00 Z50.00 E25.00
    Recv: echo:Maximum Acceleration (units/s2):
    Recv: echo: M201 X900 Y900 Z300 E10000
    Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv: echo: M204 P600.00 R3000.00 T3000.00
    Recv: echo:Advanced: Q<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv: echo: M205 Q20000 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
    Recv: echo:Home offset:
    Recv: echo: M206 X0.00 Y0.00 Z0.00
    Recv: echo:Unified Bed Leveling:
    Recv: echo: M420 S1 Z10.00
    Recv: Recv: Unified Bed Leveling System v1.01 active.
    Recv: Recv: Active Mesh Slot: 1
    Recv: EEPROM can hold 16 meshes.
    Recv: echo:Material heatup parameters:
    Recv: echo: M145 S0 H190 B50 F0
    Recv: echo: M145 S1 H235 B80 F0
    Recv: echo:pID settings:
    Recv: echo: M301 P21.83 I1.93 D61.67
    Recv: echo: M304 P180.09 I8.11 D1000.24
    Recv: echo:Z-Probe Offset (mm):
    Recv: echo: M851 Z-1.65
    Recv: echo:Filament load/unload lengths:
    Recv: echo: M603 L0.00 U100.00
    Recv: ok
     
    #30 slider240sx, Nov 6, 2018
    Last edited: Nov 6, 2018
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,339
    Likes Received:
    7,036
    OctoPi has its own startup GCode block so make sure it is not doing anything you do not need.
     
  12. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    i only have ending gcode in octopi
    ; disable motors
    M84

    ;disable all heaters
    {% snippet 'disable_hotends' %}
    {% snippet 'disable_bed' %}
    ;disable fan
    M106 S0
     
  13. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    ive tried both
    //#define AUTO_BED_LEVELING_BILINEAR
    #define AUTO_BED_LEVELING_UBL //--ROBO-BF
    both seem to ignore my z offset but act fine when homing. the only setting i really changed from the firmware posted here was the thermistor.... i didnt think it was relevant because from what documentation i could find the ramps is the same between 1.4 and 1.5 other than a fuse change. with that mentioned i installed a generic ramps 1.5 and ive had good prints using the robo supplied firmware so i didnt think it would be an issue
    i will be trying the rest of the options tonight, altho i do expect the same result and im pretty much at a dead end now i would love to get one of the newer firmware updates to work so i can take advantage of the UBL because i have one corner of the bed up higher than the rest, and if i shim the other 3 corners it will cause the bed to move around doing a print
     
  14. 3dfun4me

    3dfun4me New Member

    Joined:
    Aug 13, 2018
    Messages:
    15
    Likes Received:
    1
    M851 Z-1.65 looks awfully suspicious. How about

    M851 Z1.2

    Instead.
     
  15. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    that would just cause it to eat the bed more
    http://marlinfw.org/docs/gcode/M851.html
    also i put the offset in the firmware...
     
  16. Bradf80

    Bradf80 New Member

    Joined:
    Mar 24, 2015
    Messages:
    24
    Likes Received:
    7
    I just got some time to look into the firmware. The new code does not have the steps for the E1 for the other Z axis motor. I added the default steps for Z to E1 and I will see if that's all it was. Going to test this evening and see if that resolved the Issue of one motor moving at a different rate than the other.
     
    mark tomlinson likes this.
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,339
    Likes Received:
    7,036
    Given how Robo wired the R1+ that would be a likely cause.
    Note that with a standard RAMPS 1.4 there is no real need to use a second stepper driver*, but that is what they did with their setup so you have to watch out for it :)





    *the standard RAMPS has two stepper motor output connections on the Z for that very reason. The Z moves slowly and with almost no jerk/acceleration so a single driver can handle it easy.
     
    #37 mark tomlinson, Nov 10, 2018
    Last edited: Nov 10, 2018
  18. 3dfun4me

    3dfun4me New Member

    Joined:
    Aug 13, 2018
    Messages:
    15
    Likes Received:
    1
    Would the 1.1.9 be the last update of the 16 bit firmware? And therefore would be the final firmware update to the r1+ because its arduino is limited to 16 bit?
    (gonna take a push from somebody to get me to leave the stability of 1.1.1 mesh.)
     
    #38 3dfun4me, Nov 10, 2018
    Last edited: Nov 10, 2018
  19. slider240sx

    slider240sx New Member

    Joined:
    Jul 21, 2018
    Messages:
    24
    Likes Received:
    3
    any idea on what im missing for UBL? i tried all the bed leveling options in the 1.1.9 and it still wont print off the bed, as if its just ignoring an z offset i set
     
    Angel C likes this.
  20. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,818
    Likes Received:
    3,539
    There is a UBL tutorial on the Marlin.org pages somewhere.

    Only the Marlin developers can say if 1.1.9 is the end of 8-bit Marlin. I don't think that is the plan yet, they do have some framework for a Marlin 2.x
     

Share This Page