1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Marlin Firmware Upgrade 1.1.0 RC8 & RCBugFix (For R1 & R1+PLUS)

Discussion in 'Mods and Upgrades' started by WheresWaldo, Jun 11, 2015.

Thread Status:
Not open for further replies.
  1. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @Robert55
    I think the one in the link supplied with the error is newer. That one is version 1.19.1

    This library is necessary to support the full graphics LCD smart controller that is enabled by default in this firmware. (That is because I use that one)
     
  2. Robert55

    Robert55 Member

    Joined:
    Apr 27, 2015
    Messages:
    94
    Likes Received:
    34
    "Not quite a Noob, but close... Remember DOS??? LOL" Just recently retired, got the time now - had to backtrack on the library. Got it, no problem. Compiled and uploaded. I'm into this for the Mesh Leveling, primarily. When I ran a small file, it went right to printing. How do I enable Mesh?

    The text file supplied after you unzip the RAR file should have a little more info.
     
    #1022 Robert55, Mar 3, 2017
    Last edited: Mar 3, 2017
  3. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Do you have a LCD smart controller or the Full Graphics smart controller?
    if so try and follow this video


    At the end he says MESH will need to be done for each print, that is no longer true, after you have done MESH simply go to the Control menu and select Store Memory, now you MESH is saved and will be reused for every print.
     
    Rob J likes this.
  4. Robert55

    Robert55 Member

    Joined:
    Apr 27, 2015
    Messages:
    94
    Likes Received:
    34
    I've got this one - it's a little late for me to even hook it up tonight - give me about 6 hours and I'll get back to yu. Thanks.http://www.ebay.com/itm/like/141938740733?lpid=82&chn=ps&ul_noapp=true
     
  5. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @Robert55

    With that controller you will need to edit two lines in Configuration.h, they are as follows:

    ORIGINAL at ~ line # 1247 and line #1265
    Code:
    //#define REPRAP_DISCOUNT_SMART_CONTROLLER
    
    ...
    
    #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER  //--BH
    

    to this
    Code:
    #define REPRAP_DISCOUNT_SMART_CONTROLLER
    
    ...
    
    //#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER  //--BH

    The menus are about the same and the instructions should work the same. It can be done from a terminal screen that MatterControl or OctoPrint or other front ends may have but the LCD is easier .
     
    #1025 WheresWaldo, Mar 4, 2017
    Last edited: Mar 4, 2017
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,668
    Likes Received:
    7,316
  7. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    There has been a few questions about startup gcode that works with MESH, here is what I use in S3D
    Code:
    M82
    G1 Z15
    G21
    G28
    G29
    G90
    M117 Printing ...
    That's it, pretty simple and direct.
     
  8. Robert55

    Robert55 Member

    Joined:
    Apr 27, 2015
    Messages:
    94
    Likes Received:
    34
    THAT, Sir, is just what I needed. Solved my Z offset problem - no consistency. Copied and pasted the old original and replaced it with this. Thank you. Have a really wonderful weekend. Now I have to figure out how to integrate this into a 2 process print - everyone wants to probe in the middle... lol I use a .8mm nozzle for the base of this business card, and I'm attempting to use a .2mm for detail. http://www.thingiverse.com/thing:2052212 Could we perhaps do the probe at the x/y home position and still keep the mesh information?? I'm not quite a noob (DOS and Radio Shack Color Basic, anyone??), but I draw the line at C###... ;)
     
    #1028 Robert55, Mar 10, 2017
    Last edited: Mar 10, 2017
  9. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @Robert55 I am not sure what you are asking, perhaps start a thread in General Questions or Troubleshooting.
     
  10. Robert55

    Robert55 Member

    Joined:
    Apr 27, 2015
    Messages:
    94
    Likes Received:
    34
    I need the startup gcode have the hotend probe the bed at the x/y home instead of the middle of the bed.

    Sent from my LGLS996 using Tapatalk
     
  11. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Then you need to do it this way, from this:
    Code:
    M82
    G1 Z15
    G21
    G28
    G29
    G90
    M117 Printing ...

    to this:
    Code:
    M82
    G1 Z15
    G21
    G28 X Y
    G161 Z
    G29
    G90
    M117 Printing ...

    I haven't tried this myself and it might not work, I think there may be another way. It needs investigating. G28 now homes only X and Y and should leave the probe (nozzle) at X0 and Y0, the G161 tells the printer to home Z and I am pretty sure it won't move to the center but just do it where the nozzle sits.
     
  12. digitalsolo

    digitalsolo New Member

    Joined:
    Mar 23, 2016
    Messages:
    21
    Likes Received:
    5
    Running RC8 with MBL now on my Robo. No issues at all, LCD is working great and printer behavior is excellent.

    I wish I could get Marlin 1.1 with MBL running on my Ultimaker 2 clone. I may have to rip out the Ulitmaker electronics and do a RAMPS build on it and see if I can get it all working that way. I'm too spoiled with MBL...
     
  13. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,668
    Likes Received:
    7,316
    danzca6 likes this.
  14. digitalsolo

    digitalsolo New Member

    Joined:
    Mar 23, 2016
    Messages:
    21
    Likes Received:
    5
    Oh it runs Marlin straight from Ultimaker (my board is a direct clone UM2 Ultimainboard). But it runs 1.0, not 1.1 and porting all of the LCD stuff for the fancy OLED over from 1.0 to 1.1 formatting in Marlin is way more work (and really skill) then I can deal with. I can make the printer work a-ok on RC1.1, but I lose the LCD/controller/SD functionality which I'm not willing to give up.

    I'm thinking about ripping it apart and redesigning the gantry to use linear rails with a quad supported bed anyway, so maybe I'll try a different more generic RAMPS/LCD combo.

    Anywho, sorry for going SQUIRREL! on the thread here. :D
     
  15. Bradf80

    Bradf80 New Member

    Joined:
    Mar 24, 2015
    Messages:
    24
    Likes Received:
    7
    Anyone having any thermal runaway errors since the last update? Didn't have them before, now I have to turn my fan off for most of the print because of the thermal errors when the fan is close to the bed and on.
     
  16. Robert55

    Robert55 Member

    Joined:
    Apr 27, 2015
    Messages:
    94
    Likes Received:
    34
    Nothing that couldn't be explained by the damn wire breaking and a connection coming loose, damn it.

    Only problem I have is trying to get that start code to probe at x/y home. It started printing mid-air, so I changed it back.

    Sent from my LGLS996 using Tapatalk
     
  17. Bradf80

    Bradf80 New Member

    Joined:
    Mar 24, 2015
    Messages:
    24
    Likes Received:
    7
    I've got no broken wires. Both machines have the same problems. I'm running the bed at 90 and the fan cools it down to the point that it halts for a temp error. By cooling down, I mean less than 5c
     
  18. Robert55

    Robert55 Member

    Joined:
    Apr 27, 2015
    Messages:
    94
    Likes Received:
    34
    Damn. I'm having a problem with some PETG right now. Also temperature, but it's the filament.

    Sent from my LGLS996 using Tapatalk
     
  19. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    You will need to retune PIDs if you go to the latest version. I had to and now all my temps are rock steady, they weren't before, so there must be a small change to how the PID is calculated.
     
  20. Bradf80

    Bradf80 New Member

    Joined:
    Mar 24, 2015
    Messages:
    24
    Likes Received:
    7
    Will do. I'll post back if it does or does not resolve it.
     
Thread Status:
Not open for further replies.

Share This Page