1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Matter Control vs OctoPrint

Discussion in 'Software' started by Crypto3d, Nov 4, 2017.

Thread Status:
Not open for further replies.
  1. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    For some reason I can print a model without problems when sliced and printed from Matter Control. But if I export the g-code to file and upload that to OctoPrint the print starts off too high. It's close but it's like it loses the z-offset or something. I know in matter control we fine an offset and have the macro to adjust the offset but it looks like that isn't making it into the gcode. Has anyone else had that problem? Any ideas on what I can do to fix it? Here is the start of the gcode that was exported from MC:
    ; Generated with MatterSlice 1.0
    ; filamentDiameter = 1.75
    ; extrusionWidth = 0.4
    ; firstLayerExtrusionWidth = 0.4
    ; layerThickness = 0.2
    ; firstLayerThickness = 0.3
    ;
    automatic settings before start_gcode

    G21 ; set units to millimeters

    M107 ; fan off

    M190 S63 ; wait for bed temperature to be reached

    M104 T0 S210 ; start heating extruder
    1
    T0 ; set the active extruder to 0

    ; settings from start_gcode

    G28 X0 Y0 Z0 ; home all axes

    G1 Z5 F5000 ; lift nozzle

    M109 S210 ; set the extruder temp and wait

    G28 X0 Y0 Z0 ; Home Z again in case there was filament on nozzle

    G29 ; probe the bed

    ; automatic settings after start_gcode

    T0 ; set the active extruder to 0

    G90 ; use absolute coordinates

    G92 E0 ; reset the expected extruder position

    M82 ; use absolute distance for extrusion
    ; Layer count: 67
    ;
    LAYER:0
    M107

    G0 F9000 X115.993 Y109.048 Z1.299
    ;
    TYPE:SKIRT

    G1 Z1.299

    G1 F1800 E0

    G1 F1080 X117.598 Y109.488 E0.08303

    G1 X118.922 Y110.104 E0.15588
     
  2. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,587
    Likes Received:
    2,272
    Your not setting a z offset in your start up script. M565 Z-1.0 brtween the G28 and G29. Test and adjust the -1.0 number until you have the perfect first layer
     
    mark tomlinson likes this.
  3. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    That makes sense. That was my first instinct but does that mean that matter control handles that on it's own when you are printing directly via USB from matter control? Because there is a z offset and an offset macro in matter control but neither of those settings make it to the start up gcode. Thanks!
     
  4. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,587
    Likes Received:
    2,272
    Matter control does a lot of wierd stuff like that :)
     
  5. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    Yeah I've been trying to switch over to cura but it seems to be doing some weird stuff too. I have another post about that if you have any suggestions!

    I'll try putting in the z offset on the startup script in matter control and see if that fixes my matter control problem. Thanks!
     
    mark tomlinson and Geof like this.
  6. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    Well I added that to my startup gcode and it seems to have made no difference. You can see the M565 command in my gcode but the Matter control sliced gcode still prints way too high:

    ; Generated with MatterSlice 1.0
    ;
    filamentDiameter = 1.75
    ;
    extrusionWidth = 0.4
    ;
    firstLayerExtrusionWidth = 0.4
    ;
    layerThickness = 0.2
    ;
    firstLayerThickness = 0.3
    ;
    automatic settings before start_gcode

    G21 ; set units to millimeters

    M107 ; fan off

    M190 S63 ; wait for bed temperature to be reached

    M104 T0 S210 ; start heating extruder
    1
    T0 ; set the active extruder to 0
    ;
    settings from start_gcode

    G28 X0 Y0 Z0 ; home all axes

    M565 Z-0.85;

    G1 Z5 F5000 ; lift nozzle

    M109 S210 ; set the extruder temp and wait

    G28 X0 Y0 Z0 ; Home Z again in case there was filament on nozzle

    G29 ; probe the bed
    ;
    automatic settings after start_gcode

    T0 ; set the active extruder to 0

    G90 ; use absolute coordinates

    G92 E0 ; reset the expected extruder position

    M82 ; use absolute distance for extrusion
    ; Layer count: 67
    ;
    LAYER:0
    M107
    G0 F9000 X115.993 Y109.048 Z1.299
    ;
    TYPE:SKIRT
    G1 Z1.299
    G1 F1800 E0
    G1 F1080 X117.598
     
  7. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,587
    Likes Received:
    2,272
    Your start up script is very odd
     
  8. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,587
    Likes Received:
    2,272
    The m565 has to be between a g 28 and g 29, yours is not, matter controls has a lot of garbage in there lol
     
    mark tomlinson likes this.
  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,339
    Likes Received:
    7,036
    It needs to be after the LAST G28 and before the (only) G29 :)
     
    Geof likes this.
  10. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,818
    Likes Received:
    3,539
    Here is how I would clean up that MatterControl startup script
    Code:
    G1 Z5 F5000 ; lift nozzle
    M109 S[temperature] ; set the extruder temp and wait
    G28 ; Home all axes
    M565 Z-1.0 ; Set Z Offset
    G29 ; probe the bed
    I actually had to install MC to find this. It is in Settings >> Printer >> Advanced >> Custom G-Code

    Also the Z-1.0 is just a baseline, your printer might need to be closer (more negative) or further away to get a consistent first layer (less negative).
     
  11. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    Thank u both for the suggestions. Other than the m565 command everything else was just what matter control put in there. I tried first putting the m565 command between the g28 and g29 like mentioned and that didn't work for me so I tried again with it the way you see it now. Maybe I should have restarted matter control first before saving the gcode but the command made it into the code. It's almost like matter control is setting the z coordinates without considering the offset.

    In matter control under settings, printer, print area there is a z offset you can define. Should that be zero if I define it with the m565 in the startup script? Thanks!
     
  12. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,339
    Likes Received:
    7,036
    Yes, because what MC has there is not the bed leveling Z offset. It is a global Z offset. Not what you want.
     
  13. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,587
    Likes Received:
    2,272
    make sure you are using the correct capitals and spaces :D it matters

    G28 ; home all axis
    M565 Z-1.0 ; set the offset for auto level
    G29 ; Autolevel dance


    if its not written correctly you will have issues. the ";" sets a comment so you can add notes as to what each thing is/does if desired like I did above.
     
    mark tomlinson likes this.
  14. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    I'll get rid of the global offset and try this again tonight. Thanks!!!
     
    Geof likes this.
  15. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,339
    Likes Received:
    7,036
    Moved to software section
     
  16. Crypto3d

    Crypto3d New Member

    Joined:
    Oct 10, 2017
    Messages:
    15
    Likes Received:
    6
    Success! After removing the global z offset and adjusting the start up gcode as recommended and then restarting matter control, I exported the gcode and was able to upload to octoprint and it printed just like it did from matter control. So I'm finally getting the same results whether matter control is directly connected to the printer or the gcode is exported and printed through octoprint. Thank you guys, you are awesome!
     
    Geof and mark tomlinson like this.
Thread Status:
Not open for further replies.

Share This Page