1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

R2 v2 Bed S3D First Layer Gap Issues

Discussion in 'Troubleshooting' started by TransBat, Jul 3, 2018.

Thread Status:
Not open for further replies.
  1. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    My R2 v1 bed pogo pins started to fail, and Robo quickly sent me a new v2 bed. I'm running my machine stock with their buildtak surface on the v2 bed. I should note, I am able to complete prints on my R2 - but the gaps in my first layer are something I didn't have prior to the bed swap. Here's what I've done so far:
    • Auto-leveling has been disabled in Octoprint (replaced with a G28 vs the 2.0 firmware G36).
    • v2 bed has manually leveled/fine-tune leveled.
    • z-offset currrently set to -6.52
    Originally, I tweaked a R2 S3D profile from @Ed Ferguson dated 2017-08-27 (linked here)
    I'm using eSun PLA+ filament. I used to run 215/60 on the previous v1 PEI bed with Ed's profile - but those settings v2 Buildtak bed made parts were near impossible to remove!

    Lowering my hot end to 205 and bed to 45 has made print removal much easier, and hasn't had any effect on first layer gaps, and has reduced stringing too (retraction distance 1.50mm, speed 2400mm/min).

    I've included a photo gallery with details/settings in the comments - please feel free to leave comments and refer to them (I'll update the gallery as needed): https://photos.app.goo.gl/9y4mpd4eDEgXTGky5

    Using these guides (visual Ultimaker and Simplify3D Print Quality) and previous forum discussions here, I believe I likely have the following issue(s):
    • Under extruding
    • Extrusion Multiplier tweak needed (never touched that setting)
    • first layer width/height
    • print temp
    • z-offset closer (hesitant to touch this - when lowered to -6.50 or lower, prints SUPER hard to remove)
    I know to want a "perfect" first layer might be akin to madness, but I know the gaps I have can be sealed up a bit more. I feel like my Simplify3D profile isn't translating variables correctly, or I'm missing something else that should be obvious. Been toying with this issue for about a week, and figured I should seek some guidance from you all ;) I've also included my current S3D profile.
     

    Attached Files:

  2. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,523
    Likes Received:
    7,305
    • z-offset currrently set to -6.52
    Pretty sure this is ignored if you are not using autoleveling so ... manually level it a bit lower. First layer looks a tiny bit too high.
     
  3. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    While I certainly could be wrong (and I likely am) - I thought the value saved in the EEPROM was actually kept/honored. Making any adjustments and manually saving the value in the EEPROM definitely has an impact in the squish factor. I thought that was the point of having the manual level and fine-tune leveling wizards - to help you calculate a value used when you print even if the auto-level is off :(

    I started out with -6.54 before lowering to -6.52.

    I will try -6.50 again with the profile settings I uploaded, and send the image to the gallery.
     
  4. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,523
    Likes Received:
    7,305
    The value used by the M565 in the startup GCode is used only by the autoleveling routines.
    Now I am not 100% certain that the newer Marlin even honors the M565 (it was deprecated) so whatever is being called MAY be slightly different, but if it is an autoleveling offset the way it has been -- it will not be used if autoleveling is not invoked (regardless of it being stored in the flash EPROM or not). This is because the older autoleveling didn't work that way. The newer v1.1x may behave differently since Robo is now using BiLinear I think and that may behave differently.

    @WheresWaldo or @Geof may have some insight.
     
  5. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    While we wait for the others to chime in - I manually adjusted the eeprom from -6.52 down to -6.50 to -6.48. I saw NO visible changes in the print (photo gallery updated), unless the adjustment of .04 was taking you a bit too literal on the tiny bit too high :rolleyes:

    It would appear you are indeed correct, so I'll have to go back through the manual leveling/fine tune wizard to help adjust my z-offset. While I could use the thumbscrews - it took me over an hours to get it leveled out nicely as it is, so I'll run those wizards for now (open to other suggestions).
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,523
    Likes Received:
    7,305
    If you can manually level it (was a pain on the C2 and that has a smaller bed) then you can totally remove the Z offset and autoleveing GCodes -- nothing needed.
     
  7. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    Mark, my apologies, but I am unsure how to accomplish that without using the manual and fine-tuning wizards. I can and have used the thumbscrews on my R2 to help level out the bed as best as possibly while using the fine-tune wizard with both circles and lines, and I know I can use the motor controls to raise and lower the bed. Am I missing something obvious that can help save an offset without these wizards?

    I encountered severe issues with the auto-leveling change after the 2.0 firmware upgrade. Jerry from Robo had said once I had the bed dialed in (I mentioned using the manual bed calibration and fine-tine wizards) to replace the G36 and G29 with just the G28 in Octoprint. I did exactly that - and my Octoprint still only has the G28 in the area where the previous G36 and G29 commands were.

    I've included an updated R2 circle bed level image in the gallery after adjusting my z-offset using fine tune wizard with both circles/lines, and now and my z-offset is now "calibrated" at -6.34 (why the "huge" difference from -6.52 I have no idea).
     
  8. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    @mark tomlinson you sir, are a fine genius and gentleman. I think I might have overdone my squish with the -6.34, but if you take a look at the latest image in the gallery - I think we've got a winner if I increase the distance just a little bit between my nozzle and bed.

    I'm still curious to know about other ways to level the bed, and why there appears to be no more value adjustments with any value saved to the eeprom. I'm guessing whatever value gets saved during those wizards gets buried somewhere in Octoprint that I cannot see, but the R2/Octoprint honor that value even if the G28 has removed the bed leveling routine/wizard.
     
  9. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,523
    Likes Received:
    7,305
    There are a number of different ones you can use with Marlin 1.1.x (which is what the C2/R2 use):

    http://marlinfw.org/docs/features/auto_bed_leveling.html

    Have fun reading up ;) ABL, Unified Bed Leveling and Mesh Bed Leveling are the ones it includes now.

    Everything autoleveling related would be in the startup GCode for MOST of the autoleveling methods.
     
  10. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    Thanks Mark, that will make for some good reading. After a little more digging, I believe this is where the Marlin Plugin values are being stored/recorded: https://help.robo3d.com/hc/en-us/ar...tting-your-z-offset-through-the-web-dashboard

    My R2 is at the office, so I won't be able to verify until Thursday, but perhaps I can test that theory on my C2. As far as I can tell from skimming your resources and my Octoprint startup code, the use of the G28 instead of a G35/36/29 combination should have auto-leveling disabled. Presumably it might retrieve the z-offset from this stored area, since no leveling occurs when I submit a print.

    I'd still be curious to hear from Geof or Waldo about the z-offset/eeprom storage and it being used or not. My slight tweaking of the epprom z-offset value from -6.54 to -6.48 clearly was too small. I need to lower the bed a bit more, maybe and lower the left half my bed just a smidge as that side is a bit more smooshed.

    Thanks again for helping me determine my z-offset was the culprit - just goes to show how often that can be the crux of getting everything else setup correctly :p
     
  11. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,329
    Hey there I’m late to the party! If you’d be so kind to open octoprint and send a M502 and a M500. Then redo your offset on the R2 machine, nowhere else. Don’t use the fine tune wizard. I was just helping somebody that stopped the autolevel but something about the fine tune wizard was really messing with the first layer and saving weirdness to eeprom. Was very odd, if your happy with the first layer now certainly leave as is but if you run the fine tune I’d bet you’ll see it run autolevel, weird lol
     
  12. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    @Geof My R2 is at the office, but I need to calibrate my C2 for proper first level as well. Would I be correct that the steps would be similar?

    I can run the M502 and M500 on my C2 in a little while. I can definitely confirm that if you use the fine tune wizard on either R2/C2, the autolevel does run - even if the G36/G29 has been removed and only the G28 remains.

    I was trying to explain yesterday (albeit poorly) - without those various leveling wizards - I honestly have no idea how to help level my bed and run tests that I can use to make small adjustments and set my offset. (I did read some of the various Marlin bed leveling types Mark linked me to)

    My apologies for what I'm sure seems like a silly questions, but how does one go about setting and testing a z-offset without those wizards?
     
  13. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @TransBat
    You need to connect to the web interface to issue any commands without using the wizard, you cannot do it from the LCD.

    Resulting from the leveling scheme Robo chose to implement you will never get to that magical perfect first layer. It can be close, depending on how flat your bed is when heated (just so you know only milled beds are almost flat, Robo's bed isn't milled). So the best you can hope for is to get the four corners correct and then the offset to get the proper squish, and hope the auto-level IR sensor works as well as it should/could. I haven't used the wizard in a long time so I can't help much there, but I do know that you might be able to get by with only leveling once and then setting the correct offset. I believe that is how @Geof uses his Robo's. The key is if your bed is as mechanically level as possible, and that may not be the same as using the paper guage at the four corners, then auto-leveling may not be needed if the printer homes properly. Homing sets the zero points for X Y and Z, then the offset lowers the nozzle the required amount to get to the bed. Technically you once the bed is mechanically trammed to the gantry (I hate using 'level' because nothing in a 3D printer needs to be level, you can print upside-down if you wanted to) then leveling is just another time wasting step that can be eliminated. So here is how I think it should work.

    Level as best you can at the four corners using the paper guage. Home, then run the offset wizard, the offset wizard might include the homing I am not sure. Now find a print that covers the extremeties of the bed and print just a single layer. regardless what the paper level came up with, you will find that some corner or two may be too high or too low, adjust the screws and reprint until you get all the corners looking the same. Now the only thing left is to fine tune the offset, I do this by hand (not the wizard) moving in increments of 0.02mm. The reason for this increment is that is the finest full step measuerment you can acheive with the hardware supplied. Remember the offset affects the entire bed, it is a global offset. That is why it must be mechanically trammed first. Once set the way you want it then from the OctoPrint web interface issue an M500 command to store all the settings in EEPROM. FYI if you do an M502 followed by an M500 at any time it resets all those settings to zero or null so you will lose your work. Now If I recall correctly, this is where @Geof will tell you that he does not "auto-level" anymore and only uses G28 to home then prints.
     
    #13 WheresWaldo, Jul 4, 2018
    Last edited: Jul 4, 2018
    Geof and mark tomlinson like this.
  14. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,523
    Likes Received:
    7,305
    and I will tell you the same about my C2. Not autoleveling any longer.
     
    Geof likes this.
  15. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    Thank you all for the responses. Let's see if I got any of this right ;)

    • Remove auto-leveling code from Octoprint and other slicers
    • Mechanically/manually level the bed at the 4-corners as best one can (manual bed calibration with paper, or perhaps use a small torpedo level at each corner)
    • Home the Bed (G28)
    • Run Z-offset wizard (fairly sure this issues a G28 /runs an auto-level)
    • Print single-layer item that covers extreme edges of bed.
    • Manually adjust z-offset (adjust values in eeprom? adjust in Octoprint?)
    • Test again with single-layer print.
    • When happy with results, send M500 from Octoprint
    @WheresWaldo although I understood your statement about only being able to make 0.20mm adjustments - that feels like a bit of a big jump. Why do the wizards offer to make adjustment as small as 0.01mm if they aren't actually able to make that adjustment? I believe even all of the various z-offset wizards run an auto-level once, but with the other leveling code stripped out of Octoprint (and S3D) - the auto-level never runs again.
     
  16. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Do not use a torpedo level, you are technically not leveling you are tramming the surface of the bed to match the gantry. Earth level has no place in 3D printing. Oops my mistake, that should have been 0.02 mm, I fixed my mistake in the previous post.
     
    Geof likes this.
  17. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    My mistake on the torpedo level - totally make sense now that you've explained it the way you did :) And thanks for clarifying that 0.02mm adjustment. Do you make that adjustment in the eeprom setting, or manually go into Octoprint and set the z-offset by adjusting by 0.02 there?
     
  18. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I did that on the LCD, don't know how @Geof or @mark tomlinson do it with their printers. Because you set it and don't really have to store it until you finalize it, but you can set it in OctoPrint with am M206 Zn.nnn command
     
  19. TransBat

    TransBat Member

    Joined:
    Dec 23, 2016
    Messages:
    67
    Likes Received:
    35
    I feel like a broken record - but thank you all @mark tomlinson @Geof and @WheresWaldo :D I ran through the steps we discussed, and after applying some small tape squares in the corners where the bed was lower in the rear - and I have a beautiful spiral bed level test (see gallery for updated picture). I issued the M500 command via Octoprint, and received the following output:

    Send: M500
    Recv: echo:Settings Stored (498 bytes; crc 36253)
    Recv: ok

    The machine survived a reboot, and printed out the circle level again just fine, so I'd rate this a huge success.

    I'll run a few more test prints (found a few from thingiverse that will reach the edges with a single layer square and circle) just to be sure. Leveling the C2 bed with tape shims manually wasn't nearly as painful as I thought it would be :rolleyes:

    I'll report back on my R2 once I'm back in the office tomorrow. Thank you all again for your assistance - I'm convinced there's not much the three of you (and some other super helpful forum members) can't solve :cool:
     
    Geof, WheresWaldo and mark tomlinson like this.
  20. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,329
    I use the LCD but after a Home offset the only thing I use is the eeprom-home offset value and manually adjust, if it seems that isn't working (its been finicky at times) I do the same Waldo. Set it with gcode via octoprint.
     
Thread Status:
Not open for further replies.

Share This Page