1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Marlin Firmware Upgrade 1.1.0 RC8 & RCBugFix (For R1 & R1+PLUS)

Discussion in 'Mods and Upgrades' started by WheresWaldo, Jun 11, 2015.

Thread Status:
Not open for further replies.
  1. WADZOQUADZ

    WADZOQUADZ Member

    Joined:
    Mar 16, 2015
    Messages:
    90
    Likes Received:
    23
    Im sure it can be done. With RC5 it use to home Z at the corner of the bed. RC6 homes z in the middle of the bed.

    As for autoprobing mesh wouldnt it be possible to do the points just like autolevel but have it acount for the difference in each probie instead of just setting a plane .Then you can just set a offset . Seems possible. Might be more accurate with a actual probe though and not going off the endstops for probing. A touch probe wouldnt put as much pressure on the bed.
     
  2. WADZOQUADZ

    WADZOQUADZ Member

    Joined:
    Mar 16, 2015
    Messages:
    90
    Likes Received:
    23
    I was reading a few posts in the reprap forum of others having issues with mesh leveling with RC6 . Mainly the deactivating after homing and first layer height issues. I think there is definitely a bug its just a matter of pinpointing the cause. The deactivating a bug in code but not sure about the offset issues. Having the same problem on my fixed endstop makerfarm leads me to believe the offset issue is more of a bug then printer issue. If it werent for it doing it on that printer i would think maybe the robo homing the Z at different physical spots is whats throwing it off.
     
  3. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I think epatel is on to something, they changed his code by declaring the variables differently than he had originally written the code. I bet someone forgot some reference somewhere.
     
  4. WADZOQUADZ

    WADZOQUADZ Member

    Joined:
    Mar 16, 2015
    Messages:
    90
    Likes Received:
    23
    Yup i saw that.
     
  5. WZ9V

    WZ9V Active Member

    Joined:
    Apr 9, 2016
    Messages:
    218
    Likes Received:
    64
  6. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @WZ9V I saw your comment, and to be honest, even though I want the same thing, I don't want it before 1.1.0 is introduced. Part of the problem is that code is being added that is not thoroughly thought out or tested during the RC process. I would love for the team to focus on what is currently broken before they add some other code that is not intended to fix the broken stuff. No disrespect to Roxy-3DPrintBoard or to epatel, but she hasn't added any new code to her repository since mid April and for epatel to wait to see what she does is just plain dumb. Fix what is there first, then extend it.

    FYI - IIRC, this behavior did not exist in RC3 so it was introduced later in the RC process.
     
  7. zenekNY

    zenekNY Member

    Joined:
    Aug 29, 2015
    Messages:
    148
    Likes Received:
    17
    Did you guys figure out what to do with the issue of Thermal Runaway kicking in too quickly?
    I tried printing PolyFlex at (230C) today and when the part cooling fan kicked in, the E3D struggled to maintain steady temperature, it has just a 25W heating element. When printing PLA at (200C) it has no problem keeping steady temperature. I wouldn't know about such thing as Thermal Runaway if the printer didn't seize with the "THERMAL RUNAWAY" message on the Full Graphic Controller.
    I turned the cooling fans down to 50% and it made it through the print.
     
  8. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    I usually suggest replacing it with a 40w heater core.
     
  9. zenekNY

    zenekNY Member

    Joined:
    Aug 29, 2015
    Messages:
    148
    Likes Received:
    17
    probably best bet, I know it is totally off topic on this thread, but do you have any good source for them? are they all pretty much the same? I don't want to waste my time replacing it and finding out it would either not meet my expectations or burn out after a week of using.
     
  10. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    @zenekNY I think the developers looked at this and determined a course of action to remediate the Thermal Runaway. I believe it is this pull request: https://github.com/MarlinFirmware/Marlin/pull/3705

    We should see this incorporated into the next RC or you could configure the current RCBugFix since it is already in there.
     
    zenekNY likes this.
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    http://www.amazon.com/TOOTO-Reprap-Ceramic-Cartridge-Printer/dp/B019Q6AN96

    5. Less than 10 bucks, Prime (so two days from now you have them)
    At that price they would need to fail ... a lot.

    Never had one die, yet :)
     
    zenekNY likes this.
  12. zenekNY

    zenekNY Member

    Joined:
    Aug 29, 2015
    Messages:
    148
    Likes Received:
    17
    Thank you very much, will have some spares in case I got another ROBO :)
     
  13. daniel871

    daniel871 Well-Known Member

    Joined:
    Apr 18, 2015
    Messages:
    1,322
    Likes Received:
    510
  14. WADZOQUADZ

    WADZOQUADZ Member

    Joined:
    Mar 16, 2015
    Messages:
    90
    Likes Received:
    23
    You can change time time and temp hysteris in config.adv to make the thermal runaway setting less tight i believe .
     
  15. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    As far as I can tell this is just a modified ABL on Marlin 1.0.0. So if you want to try it put it in another thread and discuss it there.

     
  16. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Testing RCBugFix today to see about Thermal Runaway. I currently have a 10+ hour print started so I won't know until I am done with this.

    This took me longer to set up than normal as they have made numerous changes to settings in configuration.h by adding either new features or expanding the set of parameters for existing features. Expect to see most of these changes in RC7 if and when it becomes available.
     
  17. daniel871

    daniel871 Well-Known Member

    Joined:
    Apr 18, 2015
    Messages:
    1,322
    Likes Received:
    510
    When I have a printer that uses bed leveling again I'll give it a shot.
     
  18. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Found a possible cause for MESH leveling turning itself off and being removed from memory. If you home any single axis in your end gcode it turns off MESH. MESH expects that you home all axes and is apparently not coded to see if all axes are homed. So individual homing seems to turn it off but G28 all by itself will keep it on. G28 all by itself will not turn it on. I had a G28 X0 in my end script and that shut off MESH after each complete print. So check you end gcode and make sure if you want to move the extruder you use a G1 command and not a home command.
     
    mark tomlinson likes this.
  19. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,597
    Likes Received:
    7,311
    So, a work in progress (in terms of consistent behavior)?
    Still, has a lot of potential and they will get it sorted.
     
  20. John Edwards

    John Edwards New Member

    Joined:
    Jan 2, 2016
    Messages:
    16
    Likes Received:
    5
    Ahh. It's entirely possible (probably) that my losing MESH settings followed homing in XY or in Z from octoprint controls. I'll try that out when I get home.

     
Thread Status:
Not open for further replies.

Share This Page