1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Unanswered Part cooling fan configuration.

Discussion in 'Troubleshooting' started by Oisin, Oct 25, 2016.

  1. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Does anyone have any experience with PETG?
     
  2. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Thank you Mark! Very helpful links.
     
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,672
    Likes Received:
    7,318
    Best of luck. I have only used PET and that very little so hopefully the others who have used PETG can help.
     
  4. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Thanks Mark. I hate to give up on PLA but the curse of the Robo strikes again I guess. Maybe PETG will respond better to my cooling fans and will produce better overhangs.
     
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,672
    Likes Received:
    7,318
    Well, good luck :)
    PLA is (IMHO) the easiest of all filaments to get to behave.
    I prefer using some of the nylon blends and love Alloy 910, but PLA is the easiest to make bow to your will :)

    Sometimes though you can get a bum spool. I have one older one that is just too darn stringy all the way down to the point it is too cold to print... Still OK for larger prints, but not for detail stuff.


    Nylon can be a trial to master ...
     
  6. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,330
    I'd get in a few spools of pla to take filament out of the equation. Petg is good stuff for the most parting requires little or no cooling but.... It pulls chunks out of glass....
     
  7. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23

    Doesn't seem to be behaving for me no matter what I do. I'll buy some PLA too. The Robo money sink deepens!

    And Good I have heard that actually. I use a PrintInZ bed instead of the glass. I'll see how it performs with that. Hopefully it doesn't get welded on.

    @Geof When you say 'requires little or no cooling', do you mean that this overhang test would potentially print without issue with no cooling? It'll be interesting to see how my cooling fans affect this test with PETG.
     
    #128 Oisin, Nov 14, 2016
    Last edited by a moderator: Nov 14, 2016
  8. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,330
    I print with my cooling fans barely on. like 20%....most users print with no cooling fan, I find with my setup and enviroment (lots of heat in the war room) that a litte cooling goes a long way.

    If it were me I'd cut that file to run half the overhang (save yourself some print time and material) the last 4 are really all your going to be concerned with. But run that test with no fan, then with 20% fan...etc until you find the performance and finish that you like best :D
     
  9. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Okay so I got the PETG. Turns out it wouldn't adhere to my PrintInZ bed. So I removed that and cleaned the glass. Reperformed MESH leveling and sprayed on some hairspray. It stuck to that relatively well. Still a risk of warping though. I tried printing at the recommended 240C and the bed at 80C. The curl was still present with no cooling (I thought it might be). With 100% cooling, the attached image was the result. No better. Right now I'm trying to print it at 220C with 100% cooling.

    *Edit* I've also just tried Geofs method of 10 perimeters. Same result. These tests were all done at 40 to 55mm/s which is far far higher than I normally print though. Not sure if that has anything to do with it.

    *Edit* Had a couple of jams. Not a good sign. I'm trying a print at 250 now. Also heard someone say they print it at 215 to help overhangs. I might try that too since I already know it extrudes at 220 from earlier.
     

    Attached Files:

    #130 Oisin, Nov 15, 2016
    Last edited: Nov 15, 2016
  10. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Not sure what's going on with my extruder, but it doesn't seem to be able to hold the temperature despite it only being 50 degrees higher than I print for PLA.
     

    Attached Files:

    • 1.png
      1.png
      File size:
      41.6 KB
      Views:
      4
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,672
    Likes Received:
    7,318
    Check the GCode terminal for errors.

    If there are any (read the whole thing, errors will scroll away quickly) then we need to know which ones.
    If there are none it could be the heater core. The hexagon has a 30w unit and the E3D a 25w unit.
    I always suggest the 40w cores. They are very cheap and work so much better.
     
  12. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    I've got the 40W core + silicone boot to protect the heater block from airflow. I'll check the console if it happens again.
     
  13. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,077
    You may want to do a PID tuning at the higher temp you are trying for. Might help smooth things out, but that is just a guess.
     
    mark tomlinson likes this.
  14. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    I could try it I suppose. I did it for 210 for PLA. I'll do it again if this test fails. I'm printing at 215 right now. We'll see how that goes soon enough.
     
  15. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Do you gentlemen know if there's a way to PID tune for multiple different temperatures? The temperature for PLA is rock solid but for PETG it drops by 20C when the fans come on, stopping extrusion. Same for the bed. The reason I ask is because if I have to change my PID values every time I change material I'll have to redo MESH bed leveling which takes a while. Maybe you know a way to input the PID values without replacing the firmware and clearing the MESH settings?
     
    #136 Oisin, Nov 16, 2016
    Last edited: Nov 16, 2016
  16. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    Do your PID tuning at the highest available temperature you use. Also ramp up the fan speed. For example on PETG and Nylon, the two hottest materials I extrude, the fan only turns on to 60% at layer 3. Then I ramp that up to 70% at layer 6, 80% at layer 10, 90% at layer 15. That way after each fan interval the hot end has a chance to stabilize.

    By the way you can insert PID codes with M301
     
  17. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,077
    I know...I really wish there was a way to save off the MESH probe points and reload. M301 allows you to temp set PID settings until you turn off your printer so you can test the new values. Below is an example of what your PID M303 could come back with and what to use in M301. If that ends up fixing it, then do an M500 to save until the next time you load new firmware.

    Clasic PID
    Kp: 19.56
    Ki: 0.71
    Kd: 134.26

    M301 P19.56 I0.71 D134.26
     
  18. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    So not at the temperature I want to print at? Do PID tuning at 250 or 260C? I'll do what you suggested with the fan settings.

    Thanks for that tip, Danzca! That'll save me a lot of time.
     
  19. Oisin

    Oisin Member

    Joined:
    Apr 14, 2015
    Messages:
    384
    Likes Received:
    23
    Performed PID tuning at 235 and stored it temporarily like Danzca suggested, however the hotend is still struggling to hold temperature when it wasn't an issue yesterday or at all with PLA at 100% cooling. Very weird. I'll take the boot off the hotend and see what the issue is later. The heat from the hotend has warped the openings of my fan shrouds. Maybe they're blowing air over the top of the heater block now.
     

Share This Page