1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

E3D Titan Extruder

Discussion in 'Mods and Upgrades' started by RotusZ, Apr 9, 2016.

  1. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    Thats sweet. on the watertight.. yea its best to fix it in the model originally, but have you tried this?
    https://modelrepair.azurewebsites.net/

    I have ran a TON of busted ass .STL files I found on thingiverse through it and its fixed them for me every time. I think I lost count of busted STL files that are unprintable from thingiverse, but that netfab link fixed them. I usually run my stl files through it for shits and gigs before putting on thingiverse anyway. ( i still include the original cad files too )
     
  2. Ezra Ehrhard

    Ezra Ehrhard Member

    Joined:
    Apr 9, 2016
    Messages:
    31
    Likes Received:
    18
    I have not. I used meshlab to fix the manifold vertices but my lack of skills stepped in i think. I thought it was watertight, used FreeCAD to make it solild so I could make changes to it and by the time I got it updated and the STL generated out of 123D it had errors again. I will try that site next time I need some fixing. I ended up using the X idler file from Mike's full ROBO model. He provided a step file so its all good now. I am just waiting for a few other prints to finish so I can go back to upgrade parts :)
     
  3. minicoop25

    minicoop25 New Member

    Joined:
    Mar 21, 2015
    Messages:
    7
    Likes Received:
    0
    ok so while installing the Titan extruder in the process the extrude and retract got flipped around and now my extrude is my retract and vice versa any ideas on how to fix it?
     
  4. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,330
    Sounds like you need to flip the wires on your stepper

    If they are plugged in backwards they run backwards :)
     
    mark tomlinson likes this.
  5. TstarkEngineering

    TstarkEngineering Active Member

    Joined:
    Mar 10, 2016
    Messages:
    114
    Likes Received:
    38
    Or reflash with a true or false change under configuration h
     
    Geof likes this.
  6. minicoop25

    minicoop25 New Member

    Joined:
    Mar 21, 2015
    Messages:
    7
    Likes Received:
    0
    i didn't even touch the wires though and they dont unplug
     
  7. minicoop25

    minicoop25 New Member

    Joined:
    Mar 21, 2015
    Messages:
    7
    Likes Received:
    0
    how do i do that?
     
  8. TstarkEngineering

    TstarkEngineering Active Member

    Joined:
    Mar 10, 2016
    Messages:
    114
    Likes Received:
    38
    Have you flashed your firmware before?
     
  9. minicoop25

    minicoop25 New Member

    Joined:
    Mar 21, 2015
    Messages:
    7
    Likes Received:
    0
    i have not done that before
     
  10. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    23,693
    Likes Received:
    7,323
    The stepper motors do unplug from the RAMPS card.
     
    Geof and danzca6 like this.
  11. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    What mount did you end up using? and are you using the stock motor?

    You can reverse it in the firmware if needed. Sounds like you might need help with that though? I found this video very helpful for mucking with the firmware..it wont show exactly what you need to do to reverse your motor but it will show how to do the firmare buisness with ardino.

     
  12. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,729
    Likes Received:
    2,330
    I think id just flip the wires. Worry about learning config.h mods after you've been up and running. Changing to much can really frustrate you in a hurry.
     
    TstarkEngineering likes this.
  13. minicoop25

    minicoop25 New Member

    Joined:
    Mar 21, 2015
    Messages:
    7
    Likes Received:
    0
    i figured it out but thanks for your help
     
  14. 3D Printer Man

    Joined:
    May 21, 2016
    Messages:
    226
    Likes Received:
    57
    I agree with you too.
     
  15. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    I just ordered a second titan for my newer robo R1+. I did not order a new motor. So I may be trying starkengineerings mount. Though my simple mount would work. might as well try a new mount/carriage.. i have an E3D to add on anyway so gonna do it all at once.
     
  16. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,077
    That's awesome. Check the teeth on the hobb on the new one compared to the old. They have updated it since the initial release batch. Curious to hear if it works better for you.
     
  17. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    I havn't really had any issues with the titan I have but I'll take a look. one thing I have noticed is it likes to run with the spring loose. If I crank it down is when problems happen.
     
  18. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,077
    Here is an example of the new hobb teeth profile on the left. TStark (his picture btw) had issues with it shredding his filament and he got one of these and it solved the issue. You can see the width of the grooves is wider on this one along with some other minor differences compared to the one I got off the first batch from Printed Solid. If you don't have a holographic sticker on the side of your Titan, you probably have the older style on the rigth. I have thought about getting one just in case I start having issues with other filament. I only use Hatchbox PLA at the moment, but want to get into others now that I have the Titan and more of my projects are calling for more varieties of materials.

    Titan.jpg
     
  19. Ezra Ehrhard

    Ezra Ehrhard Member

    Joined:
    Apr 9, 2016
    Messages:
    31
    Likes Received:
    18
    Is E3D replacing the bolt? While I have a Holographic sticker I am fairly certain that I have the older hobb. I was shredding the Flashforge PLA that I have been using but I tighened up the tension and it seems to have taken care of the issue. I have not any any issues with PETg that I normally print with. Here is my hobb:

    [​IMG]
     
  20. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,593
    I would like to know this also, is E3D replacing all the hob gears with the new revision? I haven't even mounted mine yet or done anything with it since I have no time right now. But it would be nice to know that it is guaranteed to work once I do take it out of the box and start playing with it.
     

Share This Page