1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

Differential IR height sensor, Attemptin' Clone....ain't sure of success...now stage 10

Discussion in 'Mods and Upgrades' started by jim3Dbot, Aug 25, 2015.

  1. KTMDirtFace

    KTMDirtFace Well-Known Member

    Joined:
    May 18, 2015
    Messages:
    1,247
    Likes Received:
    461
    Thanks thats about what mine is at. I printed a few dummy blocks when i first installed it to use as calibration.

    I print a lot with it and its never had a problem, its great. Just sometimes i get buildup of PETG crap on my nozzle that falls off in a print and then the sensor hits it. Doesn't happen much. Sensor is tough lol. It is by FAR my favorite mod i have done to my R1. Hell I don't even have a heated bed anymore and don't need one. made some s3d settings changes to really smash that first layer down. and I print on an alum bed with a sheet of sanded lexan on top. works great.

    I no longer get insconsistant and weird left/right discrepancies on the first layer as it did with the stock z stops.

    No Geof and Waldo I'm still NOT on mesh.. LOL

    [​IMG]

    [​IMG]
     
    #381 KTMDirtFace, Jan 3, 2018
    Last edited: Jan 3, 2018
    Geof and jim3Dbot like this.
  2. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,857
    Likes Received:
    3,556
    Why change what works, even if it is better.
     
    Geof and jim3Dbot like this.
  3. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123

    Great Squatchy.........BoBo would be proud!
     
  4. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123
    Jim,

    Hello, I got your name from WheresWaldo. He tells me you know all about the IR sensor on the R2. My sensor works, but not very well at all. I was hoping you could either give me some tips, or maybe point me in the direction of an upgrade.

    I have UBL enabled and the other day I spent the entire day printing and modifying test grids of my mesh. The IR sensor was off on 90% of them and by quite a bit. Some of them required adjustments of +-0.150mm, which is kind of high relatively speaking. Is there anything I can do about this, or am I pretty much stuck with what I have? I just don't want to have to do this every time because it was horrible.

    Thanks,
    P. Wayne

    PW,

    Man sorry, I have the R1, and not using UBL..........although I should..........I know your sensor is Robo 're-layed' out from Mr.Crockers original design, but I don't know what, if anything Robo did with the code...........The original mini-ir code, is kinda universal, operates in the Digital & Analog mode by recording the voltage drop from the Ramp/Rambo/etc driver board, then switching to, what it needs.........since the Robos have Ramps, the Mini will always be in 'Digital Mode', 2 blinks.........Would be cool to know if someone with a R2 removed one end of the output wire from mini..........then note if the mini blinked 4x, (analog mode).........that would speak volumes if the original code was revised.........just morbid curiosity.......You may try positioning the mini approx center of bed & use the appropriate M command to repeatably drop the Z while looking at the screen Z trigger height...........should be pretty 'dead nuts on' each time.........keep me posted...Jimmy

    I'm posting this PM here, just in case any of you R2 experts have any ideas to help this member........I think it may be noteworthy to others..........Take Care


     
    #384 jim3Dbot, Jan 4, 2018
    Last edited: Jan 4, 2018
  5. grant

    grant New Member

    Joined:
    Aug 7, 2017
    Messages:
    24
    Likes Received:
    3
    Where am I able to buy one of these kits? Definitely interested in this, my bed is unlevel and can't get it perfect with MESH.
     
  6. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,429
    Likes Received:
    7,056
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    21,429
    Likes Received:
    7,056
    Bear in mind that this will not magically level the bed for you :)
    If MESH isn't helping this may not make it better.
    Still a good enhancement, but not a miracle. If the bed is mechanically unlevel to an extreme (i.e. bowed glass) then that is what you need to fix.
     
    jim3Dbot likes this.
  8. grant

    grant New Member

    Joined:
    Aug 7, 2017
    Messages:
    24
    Likes Received:
    3
    Looks like they are sold out, I was able to find one one eBay last one left. My bed isn't totally out of wack, just can't get the first layer perfect, have to adjust it on the fly. I need to order a new bed anyway, took a chunk out of my plate the other day..
     
  9. grant

    grant New Member

    Joined:
    Aug 7, 2017
    Messages:
    24
    Likes Received:
    3
    Also has anyone gotten MESH to work with the ir sensor?
     
  10. Martyprints

    Martyprints New Member

    Joined:
    Apr 20, 2017
    Messages:
    11
    Likes Received:
    1
    my robo r1+ board has 2 pin end stops, is there any way i can still use this? i bought one from filastruder. there's no third pin or even a hole to solder one in...


    EDIT: Nvm read some more of this thread and figured it out.
     
    #390 Martyprints, May 17, 2018
    Last edited: May 17, 2018
  11. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123
    Just received some feedback from a fellow printer guy, Lance ..........I sent him a few IR's for his R2......with an addition of a 100K pull-up resistor, (output to +5V) the IR's function great.......just lettin' all know.........jimmy
     
    #391 jim3Dbot, Oct 26, 2018
    Last edited: Oct 26, 2018
  12. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,664
    Likes Received:
    2,291
    Hey Jim thats great to hear! Means they work the same on the C2. I had assumed the Irs used were clones? Any pics of their setup you can share? any changes that needed made aside from the resistor (and where?) This is very exciting.
     
  13. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123
    @Geof I will shoot an email to Lance, hopefully he can add some installation info......In the past with these IRs.....A pull-up is required if the board is not a Ramps board......Just grab the resistor......and connect to the three pin header.....that would be the two outside pins....+V & Output....if you have an 1/8 or 1/10 watt resistor you can tack on the mini IR itself.....may be easier to solder resistor in the cable or on the driver board itself......I'll email Lance now........Take Care
     
  14. Geof

    Geof Volunteer Moderator
    Staff Member

    Joined:
    Nov 9, 2015
    Messages:
    6,664
    Likes Received:
    2,291
    Jim thank you very much! I think long term this will be a great thing for owners as I believe the IR sold by robo is quite expensive
     
  15. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123
    Written by Lance submitted by me, "The spec is 10k to 47k. I used the 100k because it was all I had."
     
    mark tomlinson likes this.
  16. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123
    Pics & more info coming soon....later this afternoon.
     
    Geof and mark tomlinson like this.
  17. Brad Jackson

    Brad Jackson New Member

    Joined:
    Mar 2, 2016
    Messages:
    1
    Likes Received:
    3
    So, maybe a lot later than that afternoon LOL

    FWIW Just purchased and installed one of your boards; it's working in a mostly-stock R1+ with Marlin 1.1.9 and UBL.

    I initially bought a BLTouch, then discovered that the RAMPS board in the R1+ is missing not only the pins but the signals on the Servo pins :( Went online to look for help and found this thread; decided to order an IR board from Printed Solid. Printed out a mount and setup a Configuration.h file before the board arrived; installation took maybe an hour, most of which was spent figuring out the right M851 Z-offset number :p

    I have my UBL matrix setup at 12x12 with 2mm rises. A full probe took about 10 minutes and produced very consistent, believable results - MUCH better than I ever had with those silly microswitches :rolleyes:

    My Simplify3D GCODE scripts are now blank, with all scripts being handled in OctoPrint (Thanks Gina!), and Simplify3D's Z offset is now 0.00 with my EEPROM setting of M851=Z-2.33. Yes, it's negative! Because although the probe mechanism itself is located above the nozzle, the locus of the LED beams is below it ;)

    Thanks for putting in all the time and effort to make this, Jim!

    Merry Christmas, Happy Holidays, Season's Greetings, or whatever floats your boat! :D
     
  18. jim3Dbot

    jim3Dbot Active Member

    Joined:
    Jun 1, 2015
    Messages:
    246
    Likes Received:
    123
    Thanks Brad & a Merry Christmas to You and your Family :)
     
    Geof likes this.
  19. Deneteus

    Deneteus New Member

    Joined:
    Feb 10, 2018
    Messages:
    6
    Likes Received:
    3
    I was referred to this thread when I started asking questions about this device on eBay and I have a couple questions.

    1. Besides this forum. Has anyone created any documentation for this device?
      I haven't seen a single page installation guide or any PDF documentation.
    2. Has there been any board level changes in the past 2 years?
    3. What happened to the pics in post #337?
    4. Has anyone here created mounts for the Ender-3?
    5. What is the height that the sensor needs to be mounted at from the tip of the nozzle?
    6. I noticed the DC42 version has a 6 pin ICSP port for updating the device? How would you update this device or are they read only?
    7. What was the reason for using Pink LEDs and does it have a different effect on different surfaces?
    8. What surfaces does your device work with compared to the DC42 version?
    9. Do you have a Thingiverse account where you post all of the mounts?
    10. What is the deal with adding a pull-up resistor? Can this be modified on the board instead?
    I read through a bunch of these posts but there really needs to be a sticky with all of the most recent info.

    Thanks in advance!
     

Share This Page