1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

E3D v6 Information, Installation Guides, and Review

Discussion in 'Mods and Upgrades' started by Mike Kelly, Oct 23, 2014.

Thread Status:
Not open for further replies.
  1. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
    Are you certain you have the R1+?
    The mechanical differences between the Beta and the R1 and R1+ make it very important to know which one you have or you will get the incorrect firmware.

    Robo does a poor job of versioning the firmware so that makes things difficult as well.
     
  2. cdsl810

    cdsl810 Member

    Joined:
    Feb 5, 2016
    Messages:
    46
    Likes Received:
    14
    Well, it came in a factory-sealed box that says ROBO R1 +Plus. Had the hexagon head, quick-release plate, quick-release filament thingy, and leadscrews... so I assumed it was a R1 +. I found the issue with the X axis crashing... but the firmware update has rendered everything useless. The steps seem to be way off in every direction. a square comes out like an 8-ish sided ball of yarn. The extruder seems to be extruding way too fast (like 10x) as well.

    The warning about DO NOT UPDATE FIRMWARE must not be a suggestion with the newest version
     
    #422 cdsl810, Feb 23, 2016
    Last edited: Feb 23, 2016
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
    The current firmware for the R1+ is the one labeled LeadScrew update.
    The warning because it is a confusing page and they do NOT have one labeled R1+.

    You can't be letting mattercontrol updating it either :)
     
  4. cdsl810

    cdsl810 Member

    Joined:
    Feb 5, 2016
    Messages:
    46
    Likes Received:
    14
    That is the file that I uploaded to the Mega. All my movement steps are off by a factor of 10... I send a move command of 1mm and get 10mm... the extruder squeezes out about 10x more filament than it should.

    The firmware version that my unit shipped with is not the same as the leadscrew upgrade version that I flashed. The leadscrew version appears as ROBO3DR1V3 on the XXL display. The original firmware showed ROBO3DPLUS.

    I'm patiently waiting for tech support to see if I can just get the original file.
     
    #424 cdsl810, Feb 23, 2016
    Last edited: Feb 23, 2016
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
    I'd suggest contacting Robo support then and see where that firmware is.
    Yours is the first R1+ I have heard of that was not using the firmware there.

    Look in CONFIGURATION.H and see what the steps/axis are set to.
    It should be this:

    #define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,800,723.38} // default steps per unit for RoBo 3D R1+
     
  6. cdsl810

    cdsl810 Member

    Joined:
    Feb 5, 2016
    Messages:
    46
    Likes Received:
    14
    Thank you, Mark.

    The version I just uploaded (leadscrew upgrade) had this setting:

    #define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,2560,723.38}

    So, this will take care of the Z axis being way off by putting back at 800. As far as the overextrusion, maybe I just have to go through and recalibrate to take into account the E3D... I'm using the same extrusion multipier, etc. that I was with the Hexagon.
     
  7. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
    That is not the leadscrew update version then\

    The line I pasted you was from that. Somehow you downloaded the wrong one.
     
  8. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
    Or somehow it has gotten screwed up on the web server side @Harry can you confirm?
     
  9. Vader1974

    Vader1974 New Member

    Joined:
    Mar 19, 2015
    Messages:
    20
    Likes Received:
    4
    I have a Robo3d R1. I recently upgraded to the e3d v6 lite. My e3d is incredibly loose the the carriage. I am assuming that this is the reason for sloppy printing along the x axis. Is there a new holder or stablizer that I can print? I am guessing that the original extruder holder is damaged in some way, due to the numerous times that I had to remove the old extruder due to clogs and other issues.
     
  10. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
  11. cdsl810

    cdsl810 Member

    Joined:
    Feb 5, 2016
    Messages:
    46
    Likes Received:
    14
    I clicked on that exact link... the resulting downloaded file/folder was ROBO3D_LEADSCREW_V1.zip
    This is the only file I downloaded.

    It appears I actually got the R1V3 file somehow

    Everything is working beautifully now. Thanks!
     
  12. Vader1974

    Vader1974 New Member

    Joined:
    Mar 19, 2015
    Messages:
    20
    Likes Received:
    4
    Can an R1 be fitted with a quick change plate to secure the extruder?
     
  13. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,583
    @Vader1974 Yes it can, you may need longer screws. I have one on my R1 printed in PETG. There are a few up on Thingiverse. Please note, if you use a Hexagon hotend, the slot is slightly smaller than an E3D hotend. Hexagon = 4.2 mm, E3D = 6 mm.
     
    mark tomlinson likes this.
  14. Vader1974

    Vader1974 New Member

    Joined:
    Mar 19, 2015
    Messages:
    20
    Likes Received:
    4
    Thanks. Could that wiggle in my hotend be the cause for random x axis shift?
     
  15. cdsl810

    cdsl810 Member

    Joined:
    Feb 5, 2016
    Messages:
    46
    Likes Received:
    14
    You betcha
     
    Mike Kelly likes this.
  16. maximus5403

    maximus5403 New Member

    Joined:
    Feb 13, 2016
    Messages:
    1
    Likes Received:
    0
    If anyone is looking for a new E3D V6 PM me. I returned my Robo R1 yesterday as my company wants a larger printer, and I have all these new accessories now that I need to get rid of. Most of the items were bought from Printed Solid last week and never used.

    [​IMG]
     
    #436 maximus5403, Feb 25, 2016
    Last edited: Feb 25, 2016
  17. Nathan Simers

    Nathan Simers Member

    Joined:
    Feb 25, 2016
    Messages:
    59
    Likes Received:
    19
    Just ordered the bundle pack from printed solid cant wait. Came with xxl controller and e3d hot end.
     
    mark tomlinson likes this.
  18. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,354
    Likes Received:
    7,166
    Both excellent add-ons.
     
  19. SilverBullet

    SilverBullet New Member

    Joined:
    Oct 4, 2013
    Messages:
    2
    Likes Received:
    0
    I have an original R1 from Kickstarter, I've been printing PLA without much issue, but I'm getting really bad jams with TPU. Would getting this make the TPU get through the printer better?
     
  20. cdsl810

    cdsl810 Member

    Joined:
    Feb 5, 2016
    Messages:
    46
    Likes Received:
    14
    Because the E3D v6 uses a PTFE tube that runs from the hobbed bolt down to the heat break, I would say most definitely it will help with softer and flexible filaments. Feeding should be greatly improved and there is much less back pressure at the nozzle compared to the Hexagon and J-head that the ROBO versions shipped with.
     
Thread Status:
Not open for further replies.

Share This Page