1. Got a question or need help troubleshooting? Post to the troubleshooting forum or Search the forums!

E3D v6 Information, Installation Guides, and Review

Discussion in 'Mods and Upgrades' started by Mike Kelly, Oct 23, 2014.

Thread Status:
Not open for further replies.
  1. Bryn

    Bryn New Member

    Joined:
    Sep 24, 2016
    Messages:
    3
    Likes Received:
    1
    The leadscrew update will work for the R1? I was under the impression that it was for the R1+ only.

    Just checking. Thanks for the help.
     
  2. Patrick Ryan

    Patrick Ryan Member

    Joined:
    Aug 6, 2016
    Messages:
    83
    Likes Received:
    23
    My bad. You are right
     
  3. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    The leadscrew update is the same as the r1+
    If you take an R1 and do the leadscrew update you functionally have an r1+
     
    Geof likes this.
  4. Bryn

    Bryn New Member

    Joined:
    Sep 24, 2016
    Messages:
    3
    Likes Received:
    1
    Thanks for the help. I just redownloaded the old 1.0.6 version of Arduino and it worked just fine. Thanks again.
     
    mark tomlinson likes this.
  5. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    Cool, the alternative is to fix the old source:

    you can "do a search&replace in SdBaseFile.{h, cpp} and replace fpos_t with FatPos_t"
     
  6. Matt P

    Matt P New Member

    Joined:
    Jan 31, 2015
    Messages:
    4
    Likes Received:
    1
    Help!
    I have just installed the E3D V6 hotend and was printing with average results so I followed the instructions on this thread and installed new firmware.
    Now my Z axis will not home. Each time a hit the home button it moves a further 20mm higher. Having first 'homed' to the centre of the build platform (all good) but at around 50mm above!
    X and Y home correctly.
    I have tried negative Z offsets and the leveling procedure to try and re calibrate. No good.
    The Z axis end stop do not work either. Dam thing kept spinning and unscrewed the locating nuts on the lead screw.
    I am running the Kickstarter version (draw runners for Y axis)

    Some pretty clear instructions needed!
    Thanks.
     
  7. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,076
    Did you make sure to get the beta firmware?
     
  8. Matt P

    Matt P New Member

    Joined:
    Jan 31, 2015
    Messages:
    4
    Likes Received:
    1
    There seems to be some confusion over which firmware...
    Which one should I use?
    Is the "Auto_Level_Series_6" listed as for beta the right one?

    If you have a bottom cover with rods that run all the way to the top, you have M8 threaded rods so should be using this firmware: Robo3dR1V2_M8_E3D.zip?dl=0

    For printers with Auto-level switches that does not have the previously described features, use t
    f/Robo3dR1V2_E3D.zip?dl=0

    Finally for users with Beta printers (Mechanical screw that hits the Z min endstop) use this:
    /Auto_Level_Series_6_10_E3D.zip?dl=0
     
  9. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,076
    Matt P likes this.
  10. Matt P

    Matt P New Member

    Joined:
    Jan 31, 2015
    Messages:
    4
    Likes Received:
    1
    Got it. Thanks a heap!
     
    Geof likes this.
  11. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    @Matt P
    You can add autoleveling easy enough if you care to.
    A few bucks for switches and a little wiring,

    PM me if you need details.
     
  12. danzca6

    danzca6 Well-Known Member

    Joined:
    Jul 27, 2015
    Messages:
    2,161
    Likes Received:
    1,076
    Surprised we don't have a thread on making that modification in the archives.
     
  13. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    Yea, my bad. I did it en passant as I was doing some other changes to the first beta and did a rather poor job of documenting it.
     
  14. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,584
    I would think that a Beta user might consider skipping auto-leveling completely and move to MESH and 1.1.0 There would be no need for any additional hardware, would there?
     
  15. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    Good point. I am not sure since I have not looked at that yet/
    Would the single Z switch on the beta suffice? It is not what I would call accurate WRT the bed.
    IIRC (from what I have read on MESH) it wouldn't matter.
     
  16. WheresWaldo

    WheresWaldo Volunteer ( ͠° ͟ʖ ͡°)
    Staff Member

    Joined:
    Feb 18, 2015
    Messages:
    5,905
    Likes Received:
    3,584
    Z endstop is only used for homing on MESH. There is no other use. As long as homing is consistent that is all that is necessary.
     
    mark tomlinson likes this.
  17. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    Then I'd say it is a great alternative :)
     
  18. Matt P

    Matt P New Member

    Joined:
    Jan 31, 2015
    Messages:
    4
    Likes Received:
    1
    I dont know what you guys are talking about. What exactly is MESH?

    The Z-stop is not working after flashing he new/old firmware above.
    ??
     
  19. Rigmarol

    Rigmarol Well-Known Member

    Joined:
    May 14, 2016
    Messages:
    544
    Likes Received:
    280
     
  20. mark tomlinson

    mark tomlinson ༼ つ ◕_ ◕ ༽つ
    Staff Member

    Joined:
    Feb 21, 2013
    Messages:
    22,368
    Likes Received:
    7,173
    I notice you are a relatively new forum member so ...

    Are you aware that this is experimental firmware for the Robo?
    If you are not well familiar with Marlin and the Robo then this is probably not for you, go back to the stock firmware.

    However, it is probably a Z switch out of position if you have an R1+ or an R1 so check those...
     
Thread Status:
Not open for further replies.

Share This Page